D5 ADOTable.IndexName problem with MSAccess 2000

Delphi 5 Enterprise

I am currently connecting to a MSAccess 2000 table using TADOTable. The table data shows up in my DBGrid, but when I try to set the "IndexName" property of TADOTable, I get an EOLEException with the message "Current provider does not support the necessary interface for Index functionality." In the Object Inspector, all of the Index names show up in the drop-down list for the "IndexName" property. If I try to set the property at design time, I get the same error message.

Any ideas?
dhawksAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
bpanaConnect With a Mentor Commented:
IndexFieldNames has nothing to do with the indexes on the table.

just set TableDirect to True
0
 
dhawksAuthor Commented:
I forgot the connection string I'm using for my ADOConnection


Provider=Microsoft.Jet.OLEDB.4.0;User ID=Admin;Data Source=C:\Projects\Database\Test.mdb;Mode=Share Deny None;Extended Properties="";Jet OLEDB:System database="";Jet OLEDB:Registry Path="";Jet OLEDB:Database Password="";Jet OLEDB:Engine Type=5;Jet OLEDB:Database Locking Mode=0;Jet OLEDB:Global Partial Bulk Ops=2;Jet OLEDB:Global Bulk Transactions=1;Jet OLEDB:New Database Password="";Jet OLEDB:Create System Database=False;Jet OLEDB:Encrypt Database=False;Jet OLEDB:Don't Copy Locale on Compact=False;Jet OLEDB:Compact Without Replica Repair=False;Jet OLEDB:SFP=False
0
 
bpanaCommented:
what version of MDAC do you have ?
0
The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

 
bpanaCommented:
make sure the TADOTable is closed while changing the index
0
 
bpanaCommented:
set the Active property of TADOTable to false
0
 
dhawksAuthor Commented:
how would I find the version of MDAC?
0
 
BlackTigerXCommented:
0
 
bpanaCommented:
did you set the Active property of TADOTable to False?
0
 
BlackTigerXCommented:
as for the problem...
did you set the

ADOConnection.CursorLocation to clUseServer and
ADOTable.TableDirect = True

?
0
 
dhawksAuthor Commented:
Setting the Active property to false lets me assign IndexName, but it isn't setting IndexFieldNames for whatever reason.

MDAC is version 2.81.1117
0
 
dhawksAuthor Commented:
If I set the IndexFieldNames directly, it seems to work... why won't it use the FieldNames from the MSAccess Index?
0
 
BlackTigerXCommented:
from the Delphi help:

Use IndexFieldNames as an alternative method of specifying the index to use for a table. In IndexFieldNames specify the name of each column to use as an index for a table. Ordering of column names is significant. Separate names with semicolon. There need not be an index in existence based on the specified columns.
0
 
BlackTigerXCommented:
basically you can specify the IndexFieldNames and Delphi will sort it by that field(s) even if there is not an Index associated with that column, but it will be slow if there's no index
0
 
bpanaCommented:
set TableDirect property to True. this way the recordset will be ordered by the fields in the index. No need to use IndexFieldNames.
0
 
dhawksAuthor Commented:
If I set IndexName, nothing happens with the sorting of the records.

If I set IndexFieldNames, the records are sorted accordingly, but the IndexName property does not change.

I can set IndexFieldNames without setting Table.Active = False, but I must in order to set IndexName.

I still don't understand why the IndexFieldNames property is not being updated accordingly when I set IndexName.
0
 
bpanaCommented:
to obtain the fields which compose the index use something like:
ADOTable1.IndexDefs[1].Fields
0
 
dhawksAuthor Commented:
Setting TableDirect seems to have solved my problem.

Can you tell me what affect setting this property is going to have? Is there anything I should know that might affect other parts of my program?

Thanks!
0
 
bpanaCommented:
there is no negative effect, the setting is by default set to False because not all providers support accessing a table by its name.
0
 
BlackTigerXCommented:
>IndexFieldNames has nothing to do with the indexes on the table.

it has nothing to do with indexes, but it will sort your table by that field(s)
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.