Installed XP Pro on my laptop, have a Motorola SB4200 SURFboard cable modem

and I can't get the internet connection going. My Network Connection shows it being a "1394 Connection Enabled, Firewalled 1394 Net Adapter". In the properties of Internet Protocol I have 'Obtain an IP address automatically' and 'Obtain DNS server address automatically' checked. I connect with the same modem just fine from my desktop running XP Home Edition, but even after I power off my modem and laptop I can't get an internet connection after restarting.

Any suggestions are greatly appreciated.

Scottie
scottie_24Asked:
Who is Participating?
 
Tim HolmanCommented:
What's the make and model of NIC ?  I think you should look for a new driver for it !
0
 
adamdrayerCommented:
at a dos prompt, type "ipconfig /all"

are you getting an IP address?  is it 169.254.x.x?  are you getting any errors?
0
 
scottie_24Author Commented:
I'll check that tonight when I get home and post the results, thanks.
0
Cloud Class® Course: Amazon Web Services - Basic

Are you thinking about creating an Amazon Web Services account for your business? Not sure where to start? In this course you’ll get an overview of the history of AWS and take a tour of their user interface.

 
scottie_24Author Commented:
I get this when typing ipconfig /all:

Windows IP Configuration

That's all.
0
 
adamdrayerCommented:
try "ipconfig /renew"
and then "ipconfig /all" again

how is the modem connected to the computer?
0
 
scottie_24Author Commented:
I get the same thing:

C:\>ipconfig /renew

Windows IP Configuration

C:\>ipconfig /all

Windows IP Configuration

I have an ethernet connection which worked just fine when I was running XP Home Edition before installing Professional.
0
 
scottie_24Author Commented:
I know I'm not giving much info, but about all I can say is the little orange light is on when I connect the ethernet cord to the back of my laptop, and then when I switch the cord over to my desktop PC things work just fine. It appears to me that somehow XP Pro isn't recognizing my ethernet card, but I don't have any idea how to check that.

I really appreciate any help.
0
 
Tim HolmanCommented:
Reset TCP/IP -

http://support.microsoft.com/default.aspx?kbid=299357

Also try turning off your Internet Connection Firewall (ICF) to see if that helps (re-enable afterwards, of course !).

It could be MAC address related - what does 'arp -a' say from a command prompt ?




0
 
Tim HolmanCommented:
The other thing - is your laptop network adapter set to 10/100 Full duplex ?  You can verify this via network properties for your NIC / configure / advanced.
Set the speed to the same speed as the working device is set to.
0
 
scottie_24Author Commented:
Thanks, I'll check this tonight when I get home.
0
 
scottie_24Author Commented:
I'm putting the contents of my reset ip log at the bottom of this message.

I turned off my ICF after resetting IP, but still no luck. When I type 'arp -a' I get:

  No ARP Entries Found


When I right click on my connection icon and to Configure there isn't an Advanced button. When I click on the properties for TCP/IP there is an Advanced button, then tabs for IP Settings, DNS, WINS, and Options, but I really have no idea how to verify or set the my network adapter to 10/100 Full duplex, or if I'm even looking in the right place.

I really appreciate any help.




reset   SYSTEM\CurrentControlSet\Services\Dhcp\Parameters\Options\15\RegLocation
            old REG_MULTI_SZ =
                SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\?\DhcpDomain
                SYSTEM\CurrentControlSet\Services\TcpIp\Parameters\DhcpDomain

added   SYSTEM\CurrentControlSet\Services\Netbt\Parameters\Interfaces\Tcpip_{084E2480-24F6-4E2C-9FBF-442F681A982F}\NetbiosOptions
added   SYSTEM\CurrentControlSet\Services\Netbt\Parameters\Interfaces\Tcpip_{95ED890F-5BF3-41E0-A079-D48A59970084}\NetbiosOptions
deleted SYSTEM\CurrentControlSet\Services\Netbt\Parameters\EnableLmhosts
added   SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{D5FF882B-42E9-413F-AA22-F6F0512D0DD3}\AddressType
added   SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{D5FF882B-42E9-413F-AA22-F6F0512D0DD3}\DisableDynamicUpdate
reset   SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{D5FF882B-42E9-413F-AA22-F6F0512D0DD3}\RawIpAllowedProtocols
            old REG_MULTI_SZ =
                0

reset   SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{D5FF882B-42E9-413F-AA22-F6F0512D0DD3}\TcpAllowedPorts
            old REG_MULTI_SZ =
                0

reset   SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{D5FF882B-42E9-413F-AA22-F6F0512D0DD3}\UdpAllowedPorts
            old REG_MULTI_SZ =
                0

deleted SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\DontAddDefaultGatewayDefault
deleted SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\EnableIcmpRedirect
deleted SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\EnableSecurityFilters
deleted SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\SearchList
deleted SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\UseDomainNameDevolution
reset   Linkage\UpperBind for ROOT\MS_NDISWANIP\0000.  bad value was:
            REG_MULTI_SZ =
                PSched

<completed>

0
 
scottie_24Author Commented:
I can see NIC > Configure > Advanced on my desktop, but it's not there on my laptop.
0
 
scottie_24Author Commented:
It was the driver, thanks.
0
 
Tim HolmanCommented:
Good stuff...
Could you post up the make and model of your NIC and driver version details so that this question may be of use for other people experiencing similar issues ?

Cheers,

Tim
0
 
scottie_24Author Commented:
My NIC is a Broadcom 440x 10/100 Integrated Controller. Details of the driver from Dell are as follows:

R54631.EXE
32-bit Self-extractor module
Xceed Software Inc.
1-450-442-2626
info@xceedsoft.com
www.xceedsoft.com
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.