Solved

Unable to share files/connect to other computers

Posted on 2004-09-14
14
667 Views
Last Modified: 2012-08-14
I have 3 computers on my network right now...I have two routers, one linksys wired 4port, and one wireless...the two routers are connected to each other through open ports, the wired is configured as the dhcp server. 2 pcs are connected to the wired router, my laptop has a wireless connection to the wireless router. neither of my pcs are able to connect to the laptop and vice versa, both pcs are however able to connect to each other and access whatever shares and printers they have. Everyone gets teh internet fine and is able to see the other PC names in the workgroup (yes everyone is on the same workgroup)

Desktop 1-Greg
Desktop 2-Newcomp
Laptop -Toshiba

Method 1: Going into start>run> \\computername
When attempting to connect to Toshiba from any of the desktops, the password screen comes up, but the username is greyed out already with Greg\Guest...and just the password box is available. All PCs have the same username (greg) with the same password. This does not work. The same happens when trying to connect to Greg or Newcomp from Toshiba, the Greg/guest user is greyed out only asking for password.

Method 2: Mapping a network drive to path of pc
The same thing happens when trying to map the network drive. However when you go to browse when mapping a network drive, the work group comes up with all 3 pcs, but then another one called Unknown is shown in there. I can't connect to any of them.

What's going on here? I want to access files that are on Greg from Toshiba but its not working. Any help is greatly appreciated.
0
Comment
Question by:spyder1125
  • 5
  • 4
  • 3
  • +2
14 Comments
 
LVL 8

Expert Comment

by:MarkDozier
ID: 12061668
Do you have the wireless router configured for bridging?
0
 
LVL 2

Accepted Solution

by:
merlinmage earned 250 total points
ID: 12061684
what os are you using..

if its windows xp then on the greg machine you must make sure that you have file sharing enabled...

go to your folder that you want to share

right click > sharing and security

and under network sharing and security run through the sharing this computer on a network wizard.

alternatively you can just click on the part where it says - if you understand the security risks but want to share your files anyway then click this link.  This way you have enabled your windows XP computers for sharing and it will stop trying to use the IPC$ gust share and ask you for a username and password..

you can then log on and use your username and password for greg

regs


-merlin
0
 
LVL 1

Expert Comment

by:SithLoaded
ID: 12061697
Seems to be an account setting problem, because if it was a network issues you wouldn't be able to connect by name.

Try mapping a drive like this:

net use "Drive letter": \\computername\share /user:computername\useraccount

net use z: \\GregsPC\C$ /user:GregsPC\greg

It will prompt you for a password.  Enter in the password and it should work.  Just make sure that user account has rights to that share.

Let me know.
0
 
LVL 10

Expert Comment

by:ngravatt
ID: 12065879
set the password for the guest account.  I think when you are on a workgroup, and you try to access another computer, it always uses the guest account to access the machine.

right-click 'my computer' go to manage.  The users and groups, then users, and you will see the guest account, right click on it and set the password, then try method 1 again.
0
 

Author Comment

by:spyder1125
ID: 12070226
I did what merlinmage said and enabled the sharing on both computers...i got all the shared folders to come up on both computers...however... i still cannot access either of the computers through the c$ command....the username still comes up as either TOSHIBA\Guest or as Greg\Guest....both being greyed out...and when I put in the password, it still won't connect.  In computer managment it displays the C$ as a share on both computers.  Whether I try to map it through the run command, or as mapping a network drive...it still shows up as a Guest.  I tried what SithLoaded said with the net use command, however, the command prompt comes up, says the password is invalid...i enter the right password, and then it just closes out of the command prompt, nothing happens, the drive is never mapped or anything.  I also did what ngravatt said and set the password for the guest account, and when the user id as TOSHIBA\Guest or GREG\Guest came up, i entered the password, but it still wouldn't go in.
0
 
LVL 1

Expert Comment

by:SithLoaded
ID: 12070577
I am not sure if I was clear.

when you type:

net use z: \\gregspc\c$ /user:gregspc\greg

Let's break this down....

net use [drive letter not in use]: \\ComputerName\ShareName /user:ComputerName\ComputerUserThatHasRightsToShare

Say I have a computer named:  Toshiba
On the computer named Toshiba, I have a shared called:  MyShare (or MyShare$) (the dollar sign means its hidden and cannot be browsed to through network neighborhood)
On the computer named Toshiba, I have a user called Greg.
Greg has at least READ permissions on MYSHARE

To map a drive called z: from my other computer called GregsPC, I would do the following at the command prompt:

Net use z: /delete   (deletes any prior mappings to z:)
net use z: \\Toshiba\MyShare /user:Toshiba\Greg
It will say the password is wrong, type the password for the Greg user on the Toshiba PC.  The drive should map fine.

The easiest way to map a drive to another computer is to map it to one of the admin shares on that PC (if win2000 or higher).

C$, D$ (hidden shares for the respective drives)
admin$, etc.

You must know the local administrator's username (if changed) and password on the remote computer.

Net use [drive letter]: \\HOSTNAME(do a ipconfig /all from the remote machine to determine its hostname)\AdminShare /user:Hostname\Administrator

Net use z: \\toshiba\C$ /user:toshiba\administrator
enter in the Toshiba PC's administrator password and it should map.
0
 
LVL 2

Expert Comment

by:merlinmage
ID: 12070671
you could always try adding another share to the c$ root share.. and if you want to make it hidden make sure you keep the $ sign at the end of the share name..  i.e. mynewshare$


however I would also advise you against sharing your entire root HDD as it is a risky thing because then people have access to your entire drive then which equals no privacy at all

-merlin

0
Do You Know the 4 Main Threat Actor Types?

Do you know the main threat actor types? Most attackers fall into one of four categories, each with their own favored tactics, techniques, and procedures.

 
LVL 1

Expert Comment

by:SithLoaded
ID: 12070805
You must be a local administrator to access the Administrative shares (c$, d$, admin$, etc.) on a Win2000 or newer system.
0
 
LVL 2

Expert Comment

by:merlinmage
ID: 12071465
yeah..

thats why you still need to share the drive..

If your heart is really set on having the root of your drive shared then..

go to explorer.. right click on the drive that you want to share and choose properties..

click the sharing tab - should be far right at the top.

there will be a link at the top which says "If you understand the risk but still want to share the root of this drive click here"

click it.. then treat it like a normal share..

regs

-merlin

0
 

Author Comment

by:spyder1125
ID: 12071807
I tried the net use commands again, i got an error message saying "System error 5 has occurred.  Access is denied."  I also tried creating another share, through sharing and security of the "C" drive on the laptop, for the name I put in X$...it worked.  Now why does it work when I have it under x$, and when it is already shared as c$ it doesn't want to connect...still giving me that TOSHIBA\Guest greyed out.  Both computers are being logged on by Greg, he is designated administrator on both machines.

Net use z: \\toshiba\C$ /user:toshiba\administrator
enter in the Toshiba PC's administrator password and it should map.

I did the above and got that system error message.
0
 
LVL 2

Expert Comment

by:merlinmage
ID: 12071834
the reason is because windows xp automatically thinks that it is smarter than the user..

even though you can enable sharing for other folders... untill you click that "I really really want to share my hard drive section" it will not allow anyone to connect to the root drive.

its an extra security feature installed by microsft.  What you have to do is enable that share on the root so that the OS goes.. "oh yeah!! you must want to share that now!! "  ;)

so untill you make the root explicetly shared.. you will continue to receive that error message.

-merlin
0
 
LVL 1

Expert Comment

by:SithLoaded
ID: 12081417
The adminstrative shares could be DISABLED.  Though you mentioned they show up on the computer management screen.  You can check by doing the following:

At the run prompt type: regedit

You will have to edit a particular registry key to reenable them.

Hive: HKEY_LOCAL_MACHINE
Key: SYSTEM\CurrentControlSet\Services\LanManServer\Parameters
Name: AutoShareWks
Type: REG_DWORD
Value: 1

If the vaiue is 0 the administrative shares are disabled, change the value to 1 and reboot.
0
 

Author Comment

by:spyder1125
ID: 12082007
AutoShareWks doesn't exist under that key....should I add it?
0
 
LVL 1

Expert Comment

by:SithLoaded
ID: 12092533
I guess in XP that registry key doesn't exist.  The key does show up in windows 2000 pro systems.  If the key doesn't exist the admin shares are enabled.  Hmmm...

Try this:

Open up a run prompt and type:  \\ThisComputersHostname\c$

For example, If I am on the Toshiba pc.

\\toshiba\c$

That will tell you if the admin shares are working.  You could test it by testing the other shares like: C$, D$, admin$, etc.

0

Featured Post

Find Ransomware Secrets With All-Source Analysis

Ransomware has become a major concern for organizations; its prevalence has grown due to past successes achieved by threat actors. While each ransomware variant is different, we’ve seen some common tactics and trends used among the authors of the malware.

Join & Write a Comment

Lets look at the default installation and configuration of FreeProxy 4.10 REQUIREMENTS 1. FreeProxy 4.10 Application - Can be downloaded here (http://www.handcraftedsoftware.org/index.php?page=download) 2. Ensure that you disable the windows fi…
What’s a web proxy server? A proxy server is a server that goes between clients and web servers, used in corporate to enforce corporate browsing policy and ensure security. Proxy servers are commonly used in three modes. A)    Forward proxy …
This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're looking for how to monitor bandwidth using netflow or packet s…
In this tutorial you'll learn about bandwidth monitoring with flows and packet sniffing with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're interested in additional methods for monitoring bandwidt…

708 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

16 Experts available now in Live!

Get 1:1 Help Now