• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 813
  • Last Modified:

TIFF Graphics Filter not working in Access 2003

For some reason when I specify a path to a linked TIFF file, the image will not display properly.  I get:

"'Run-Time error 2114 'AppName' doesn't support the format of the file 'Z:\path\filename.tiff', or file is too large.  Try converting the file to BMP or GIF format."

I know there is nothing wrong with the file, because I can open it directly by clicking on it.  I have made sure that the file associations in Windows Explorer for TIFF files are set to use Microsoft Document Imaging.  No matter what program I select to open the TIFF files, they will not open with Access.  

I have the TIFFIM32.FLT graphic filter installed in the correct directory.

Any ideas?
0
DanielAttard
Asked:
DanielAttard
  • 5
  • 3
  • 2
1 Solution
 
DanielAttardAuthor Commented:
My copy of Access does not consider TIFF files to be graphic files.  How can I change this?
0
 
will_scarlet7Commented:
Daniel,
    How are you trying to access the image on your form? Do you want it linked or embedded?
Sam
0
 
DanielAttardAuthor Commented:
the image is linked
0
Get your Conversational Ransomware Defense e‑book

This e-book gives you an insight into the ransomware threat and reviews the fundamentals of top-notch ransomware preparedness and recovery. To help you protect yourself and your organization. The initial infection may be inevitable, so the best protection is to be fully prepared.

 
shanesuebsahakarnCommented:
The filter needs to be registered, not just copied into the directory - try downloading and installing this:
http://www.microsoft.com/downloads/details.aspx?FamilyID=cf196df0-70e5-4595-8a98-370278f40c57&DisplayLang=en
0
 
will_scarlet7Commented:
Daniel,
    If the link that Shane posted does not help your situation, the only thing I know of that works for sure involves imbedding the image into your database using Word. From my experience Microsoft Access is rather buggy when it comes to dealing with graphics in formats other than .bmp & .jpg and the only sure solution (except with .png) that I have found is to open Word, insert the picture into a new document, then select the image Ctrl+C, switch back to your database and either in a OLE field in a table or directly on your form paste. It is not the best as the images are quite large this way and cause a fair bit of bloating of the database, but it works. (I'm contemplating using a seperate BE database for a project that I am planning just to store .gif files that have tranparencies)

Sorry I couldn't be more helpful.

Sam
0
 
DanielAttardAuthor Commented:
Thanks shanesuebsahakarn.  I tried your suggestion and downloaded and installed the Office File Converter Pack, but it looks like the TIFF converter was not included in that pack.  I tried to go into Office setup and specify to include the TIFF filter, but that option is not available.  Perhaps what I will need to do is manually create the registry key for the TIFF filter using regedit, and do it by comparison to a functioning machine.  What do you think?
0
 
shanesuebsahakarnCommented:
You can do, although I have no idea which registry keys are involved. AFAIK, the TIFF filter is one of the defaults installed with Office (at least, I've always had it) - although I always specify a full install of Office rather than a typical install - that leaves way too many things I need out.
0
 
will_scarlet7Commented:
Daniel,
    Do you have a copy of the Office 2000  or XP CD handy? If so I think I may have a solution to your problem. For some reason Office 2003 does not include TIFF in the installable graphics filters (At least not when running the version that I have on my machine, which is using WinXP SP2). However if you have the CD from your previous version of Office, you can run the install and only select the graphics filter for the TIFF image type. It will take about 29 megabytes, but I just did it on my machine and it works fine.

God bless!

Sam
0
 
will_scarlet7Commented:
Daniel,
 If you'd like to contact to MOD's and get a refund for the points on this question (assuming the answer above worked for this situation as well as the other) since you accepted the same answer in your other post, it's fine with me.

God bless!
Sam
0
 
will_scarlet7Commented:
ThanX Daniel!
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 5
  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now