Error while trying to run project: Unable to start debugging on the web server. There is no managed code running in the process. In order to attach to a process with the .NET debugger, managed code must be running
in the process before attaching.

I've created a local user, member of the local administartors & debugger users group for testing - so I don't think it's a permissions thing. I've repaired the Dot Net Framework and opened up permissions in IE and

Per Microsoft's Knowledge base, I did try restarting IIS, which did not help. I don't think IIS is the problem as IIS is running since I can open IE and simply run the web app. I just can't debug. The web folder configuration is standard: anonymous with Integrated authentication. I've reinstalled the DN Framework and registered ASP.NET using ASPNET_REGIIS -i. I've also tried logging in as a local user who is a member of the local administrators & debugger users groups.  All other settings and installs are default.

Any ideas?

Thanks -
Who is Participating?
What version of windows are you running?
>> What version of windows are you running?
On the web server, that is.
Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

the_keithmAuthor Commented:

Thanks, but after running that fix - same error. I've uninstalled DBF 1.0 & 1.2.
Reregistered msordbi.dll & reregistered ASP.NET: aspnet_regiis -i.

CB, - I'm running Win XP Pro, SP1
cb1393Connect With a Mentor Commented:
I'm assuming you also installed the .NET server components? Other than that, dunno.
jitgangulyConnect With a Mentor Commented:
I had the same problem and it was on win2003 server. But I had only .net framework sdk on the server and not or anything. I can debug my local app (on my local web server) easily but cannot from server and my last bet would be use framework  disk to install and play around it. Since its a Production I am hesitant to install , but I do not have any choice.

I would just suggest you to install .net framework and required component from VS studio disk/.net framework disk.
the_keithmAuthor Commented:
Well, I 've tried all of the suggestions here, but I'm still stuck - thanks for the attempts guys. points will be split.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.