Webpage on W2K Server not working from the LAN but DOES work from the outside world


I've got a strange problem.
I've got a domainname (www.tcp-web.nl) and setup a simple  under construction page on IIS on W2K Server.

This page is reachable from the outside world but when i try the same url from the local LAN, it gives a DNS error / Page not found

I Cant seem to find the problem, please help

When i do a ping on the url, the following result is displayed:

C:\>ping www.tcp-web.nl

Pingen naar www.tcp-web.nl [] met 32 byte gegevens:

Antwoord van bytes=32 tijd=3 ms TTL=64
Antwoord van bytes=32 tijd=3 ms TTL=64
Antwoord van bytes=32 tijd=3 ms TTL=64
Antwoord van bytes=32 tijd=3 ms TTL=64

Ping-statistieken voor
    Pakketten: verzonden = 4, ontvangen = 4, verloren = 0
    (0% verlies).De gemiddelde tijd voor het uitvoeren van één bewerking in milliseconden:
    Minimum = 3ms, Maximum = 3ms, Gemiddelde = 3ms

My Server-IP:
My Gateway-IP :

Packet filter setting:
-WAN side: All adresses, All ports allowed to LAN port 80
(plus a couple of others including mail from my provider etc.)

Virtual Server setting:
- Service port: 80 -> Server-IP: enabled

Website props:
- IP Adress:
- TCP Port: 80
- Host Header name: www.tcp-web.nl
Who is Participating?
andyswarbsConnect With a Mentor Commented:
My guess is that you can fix this by doing a mapping in your hosts file in sys32 drivers etc.
have you tried browsing to the server by accessing in a browser if that works, then it is an issue with your internal DNS settings... if the IP address does not work try accessing the site by using http://computername... if that does not work, than you most likely have something internal (ie firewall?) that is blocking access from internal users.
ptijsmaAuthor Commented:
Both and http://<computername> work, so now what ?
Internal DNS Settings? How to solve that?
Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

I believe that would be a little out of scope for this topic area, but if the two links I provided work, then you will need to work with whoever maintains the DNS (Domain Name Server) Server within your business to make sure the DNS is set up properly. Typically, this would only be a matter of the administrator for the DNS Server to add in an entry for the domain and make sure it is pointed at the right box.

From the looks of your "ping" above, it is resolving to (the router) instead of resolving to
oops... clicked on submit without finishing my thought!

you need to update your companies DNS to point at the address for the domain name...
ptijsmaAuthor Commented:
The DNS server (which is maintained by my providers DOES point to, try it yourself) but because i'm doing the ping from the Local Network, replies back, beeing the gateway, instead of, beeing the server)

Please keep in mind that this is a local network at home for testing purposes with 1 server (running IIS, FTP server and Mailserver), 3 pc's, and a D-Link router/gateway, thus not a businessnetwork.

I don't run my own DNS server, my Pc's IP Settings are:
        Verbindingsspec. DNS-achtervoegsel: dhcp.dsl.systemec.nl
        Beschrijving . . . . . . . . . . .:
          Intel(R) PRO/Wireless 2200BG Network Connection
        Fysiek adres. . . . . . . . . . . : xx-xx-xx-xx-xx-xx
        DHCP ingeshakeld. . . . . . . . . : ja
        Autom. configuratie ingeschakeld. : ja
        IP-adres. . . . . . . . . . . . . :
        Subnetmasker. . . . . . . . . . . :
        Standaardgateway. . . . . . . . . :
        DHCP-server . . . . . . . . . . . :
        DNS-servers . . . . . . . . . . . :
        Lease verkregen . . . . . . . . . : woensdag 15 september 2004 21:11:24

The strange thing is that for a week ago, i ran Windows 2003 Server and there was no problem. The problem arised when i installed Windows 2000 Server.

        Lease verlopen . . . . . . . . .  : woensdag 27 oktober 2004 13:11:24
ptijsmaAuthor Commented:
Thanks Andy,

This does the trick, although i believe there must be a better solution, but for now, it does the job.
I do not think there is an easier solution.  It is a feature of the way DNS works.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.