Solved

NAT issue on a 515 PIX

Posted on 2004-09-15
12
2,647 Views
Last Modified: 2013-11-16
We are a flat 10.10.x.x network. We recently added the 10.118.x.x to our network and I can't get any of the 10.118 clients out to the internet. In fact, I can't even ping the PIX from the 10.118 network. 10.10 clients can get out to the internet fine.

Ip and subnet info for 10.10 is:

10.10.x.x/16

Ip subnet info for 10.118 is:

10.118.x.x/22

So the subnets we are using are 10.118.76 and 10.118.77 with a 255.255.252.0 mask. All clients are using 10.118.76.1 for their gateway. 10.118.76.1 is a Cisco router that forwards all traffic to the PIX to get outside.


Here is my config:

Building configuration...
: Saved
:
PIX Version 6.3(1)
interface ethernet0 auto
interface ethernet1 auto
interface ethernet2 auto
nameif ethernet0 outside security0
nameif ethernet1 inside security100
nameif ethernet2 dmz security4
hostname Firewall
domain-name domain.com
clock timezone CST -6
clock summer-time CDT recurring
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol ils 389
fixup protocol pptp 1723
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
names
name 10.10.11.124 WebServer
name 10.254.1.3 FTPServer
name 10.10.11.9 MailServer
object-group service FTP tcp
  port-object eq ftp
  port-object eq ftp-data
access-list outside_access_in permit tcp any interface outside eq www
access-list outside_access_in permit tcp any interface outside eq https
access-list outside_access_in permit tcp any interface outside object-group FTP
access-list outside_access_in permit tcp any interface outside eq smtp
access-list outside_access_in permit icmp any any
access-list inside_outbound_nat0_acl permit ip any 10.10.31.0 255.255.255.128
access-list inside_outbound_nat0_acl permit ip any host FTPServer
access-list outside_cryptomap_dyn_40 permit ip any 10.10.31.0 255.255.255.128
pager lines 24
mtu outside 1500
mtu inside 1500
mtu dmz 1500
ip address outside x.x.x.x 255.255.255.248
ip address inside 10.10.11.15 255.255.0.0
ip address dmz 10.254.1.2 255.255.0.0
ip audit info action alarm
ip audit attack action alarm
ip local pool vpn-pool 10.10.31.30-10.10.31.79
pdm location 10.10.11.1 255.255.255.255 inside
pdm location WebServer 255.255.255.255 inside
pdm location MailServer 255.255.255.255 inside
pdm location FTPServer 255.255.255.255 dmz
pdm location 10.30.0.0 255.255.0.0 inside
pdm location 10.40.0.0 255.255.0.0 inside
pdm location 10.50.0.0 255.255.0.0 inside
pdm location 10.10.0.0 255.255.0.0 outside
pdm location 10.10.11.192 255.255.255.192 outside
pdm location FTPServer 255.255.255.255 inside
pdm history enable
arp timeout 14400
global (outside) 10 interface
nat (inside) 0 access-list inside_outbound_nat0_acl
nat (inside) 10 10.0.0.0 255.0.0.0 0 0
static (inside,outside) tcp interface www WebServer www netmask 255.255.255.255 0 0
static (inside,outside) tcp interface https WebServer https netmask 255.255.255.255 0 0
static (inside,outside) tcp interface smtp MailServer smtp netmask 255.255.255.255 0 0
static (dmz,outside) tcp interface ftp FTPServer ftp netmask 255.255.255.255 0 0
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 x.x.x.x 1
route inside 10.30.0.0 255.255.0.0 10.10.1.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
http server enable
http 10.10.0.0 255.255.0.0 outside
http 10.10.0.0 255.255.0.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
sysopt connection permit-pptp
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-MD5
crypto dynamic-map outside_dyn_map 40 match address outside_cryptomap_dyn_40
crypto dynamic-map outside_dyn_map 40 set transform-set ESP-3DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
isakmp enable outside
isakmp nat-traversal 30
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash md5
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
vpngroup vpn-group address-pool
vpngroup vpn-group dns-server 10.10.11.3
vpngroup vpn-group wins-server 10.10.11.2 10.10.11.5
vpngroup vpn-group default-domain domain.com
vpngroup vpn-group idle-time 1800
telnet 10.10.0.0 255.255.0.0 inside
telnet timeout 5
ssh timeout 5
management-access inside
console timeout 0
terminal width 80
: end
[OK]

Any ideas?

Justin
0
Comment
Question by:Justin Durrant
  • 6
  • 4
  • 2
12 Comments
 
LVL 79

Accepted Solution

by:
lrmoore earned 500 total points
ID: 12070862
You simply need another route statement:

>route inside 10.30.0.0 255.255.0.0 10.10.1.1 1
This routes you to the 10.30.0.0 subnet, so you need another route for the 10.118.76.0:

  route inside 10.118.76.0 255.255.252.0 10.10.1.1 1

0
 
LVL 79

Expert Comment

by:lrmoore
ID: 12070872
Same issue on this post, too, where the solution worked:
http://www.experts-exchange.com/Security/Firewalls/Q_21132029.html
0
 
LVL 23

Author Comment

by:Justin Durrant
ID: 12071345
DOH! Thanks. :)  

I will try this tomorrow.

On another note, I am having trouble telnetting into another PIX (different then the one above) via VPN.

Telnet works great from the local LAN, but while connected to the VPN telnet to the router fails.

The local LAN is 192.168.8.0/24 and the VPN assignable pool does fall in that range.

My telnet statement is as follows:

telnet 0.0.0.0 0.0.0.0 inside

Any ideas?
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 12071433
You can't telnet to the PIX from the outside-VPN or not.
You can use SSH to the public IP address

ssh 0.0.0.0 0.0.0.0 outside
0
 
LVL 23

Author Comment

by:Justin Durrant
ID: 12071477
i am not trying to telnet to the outside.. i get a local ip after the vpn is established, so telnetting should look like it's coming from the inside.
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 12071639
Nope. It doesn't work that way. Your telnet request comes from the outside interface. You cannot telnet to the inside interface from the outside interface. To clients on the inside network, yes, you appear as if you are local. To the PIX, however, you are not.
0
How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

 
LVL 2

Expert Comment

by:alkabello
ID: 12073977
Hmmm.... PIX OS 6.3.x

Use the "management-access" command...

Remote Management Enhancements

This feature enables administrators to remotely manage firewalls over a VPN tunnel using the inside interface IP address of the remote PIX Firewall. In fact, administrators can define any PIX Firewall interface for management-access. This feature supports PDM, SSH, Telnet, SNMP, and so on, that requires a dynamic IP address. This feature significantly benefits broadband environments.

The management-access command is a new command added to the PIX Firewall Version 6.3 software. For a complete description of the command syntax for this new command, refer to the Cisco PIX Firewall Command Reference.

/Rubeck
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 12074096
I knew you could use the PDM over a VPN, but I didn't realize that that telnet worked, too..
Reference link
http://www.cisco.com/univercd/cc/td/doc/product/iaabu/pix/pix_sw/v_63/cmdref/mr.htm#wp1137951

I've been working with PIX for years, since 4.x version. New features added all the time, and always learning...

Thanks, Rubeck!
0
 
LVL 2

Expert Comment

by:alkabello
ID: 12074182
No, thank you.... lrmoore.

I've learned a lot of goldies from you, by reading a great deal of your posts on this site..... :-)

/Rubeck



0
 
LVL 23

Author Comment

by:Justin Durrant
ID: 12074371
Yea I have that command in my config.. still doesn't work..

Also, adding that route fixed my other issue! Thanks!

0
 
LVL 79

Expert Comment

by:lrmoore
ID: 12074425
Did you try this:

management-access inside
telnet 10.10.31.0 255.255.255.0 inside

Glad you're working!

-Cheers!
0
 
LVL 23

Author Comment

by:Justin Durrant
ID: 12074471
the telnet issue of in another pix.. i will check the code and get back to you if needed.

Still not sure why the route was needed though since the 10.118 route was already defined on the gateway router.
 
So now it appears that packets from 10.118 to the pix are being send back to the gateway router (10.10.1.1), then back to the pix and out to the net.
 
I suppose I could update the default gateway for 10.118 to my internet router.. but oh well.. this works. Thanks for your help.
0

Featured Post

IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

Cisco Pix/ASA hairpinning The term, hairpinning, comes from the fact that the traffic comes from one source into a router or similar device, makes a U-turn, and goes back the same way it came. Visualize this and you will see something that looks …
When I upgraded my ASA 8.2 to 8.3, I realized that my nonat statement was failing!   The log showed the following error:     %ASA-5-305013: Asymmetric NAT rules matched for forward and reverse flows It was caused by the config upgrade, because t…
In this seventh video of the Xpdf series, we discuss and demonstrate the PDFfonts utility, which lists all the fonts used in a PDF file. It does this via a command line interface, making it suitable for use in programs, scripts, batch files — any pl…
This tutorial demonstrates a quick way of adding group price to multiple Magento products.

759 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

24 Experts available now in Live!

Get 1:1 Help Now