Solved

Folder Share Permissions For HTTP Virtual Directory

Posted on 2004-09-15
27
399 Views
Last Modified: 2013-11-15
I have a folder on one server that is shared. That folder is also a virtual directory in an FTP site on another server. The permissions for that work fine. I have write access, everyone else has read only. I want to add this folder as an HTTP virtual directory on the same server as the FTP site. When I set it up though and try to log in, it won't accept my login. However, if I add IUSR_<SERVERNAME> to the share permissions it works, but allows anonymous access, which I do not want. The permissions on the folder for individuals is fine (it's the same share that the FTP virtual directory uses....). I just need to add some sort of system account so that the IIS services on the remote server can read the permissions on the share. What folder/share permissions do I have to have for it to work as an HTTP Virtual Directory on the remote server? As always, thanks for your help.
0
Comment
Question by:Grime121
  • 14
  • 13
27 Comments
 
LVL 6

Expert Comment

by:karel_jespers
Comment Utility
hi,

on your iis webdav must be enabled (by default prohibited) you created under iis / default webpage a virtual directory:
 (i think you already did)
then:
------
additional to security and share:
additional you must configure the properties of the folder
websharing tab
share this folder (give  the sharename)
edit properties (enable directory browsing) <= else they don't see the contents and it seems they cannot access the page


karel
0
 
LVL 1

Author Comment

by:Grime121
Comment Utility
I don't have IIS installed on the server that as the folder. Therefore I don't have a webshare tab. Do I have to have IIS installed in order to share it on another computer? I thought websharing just added the folder as a virtual directory on the local computer.
0
 
LVL 6

Expert Comment

by:karel_jespers
Comment Utility
iis is handling this kind of stuff
you must install iis
0
 
LVL 1

Author Comment

by:Grime121
Comment Utility
I understand I have to install IIS on the server that is running the webpage, but it has to be installed on the server that hosts the folder share as well? That's kind of strange.
0
 
LVL 6

Expert Comment

by:karel_jespers
Comment Utility
no you dont have to install iis installed on the server thats shares the folder
iis must installed on a server that has access to that folder
the advantage of a virtual directory is that it will make the shared folder availabe using iis to the internet/intranet

karel
0
 
LVL 1

Author Comment

by:Grime121
Comment Utility
Ok, how do I add the webshare then? When I go to the properties on the shared folder from the computer that has IIS the only tabs I see are General, Security, and Customize. There is no Webshare tab like there are for local folders on the IIS server.
0
 
LVL 6

Expert Comment

by:karel_jespers
Comment Utility
on the host where the share resides , there you must configure the tab websharing
0
 
LVL 1

Author Comment

by:Grime121
Comment Utility
Let me be more specific about the error. The virtual directory works fine. It just doesn't let me log in. After three tries it tells me 'You are not authorized to access this page'. These are the permissions I have on the folder:

Share Permissions:
Administrators = Full Control
SYSTEM = Full Control
Everyone = Read

Security Permissions:
Administrators = Full Control
SYSTEM = Full Control
CREATOR OWNER = Special Permissions (Full Control & Take Ownership)
<Foreign Group Account> = Special Permissions (Full Control over their own personal folder in the shared folder)
<Foreign Individual Account> = Read and Execute

With those permissions I can access the FTP Virtual Directory just fine. With my admin account I have full control when connected to the FTP Virtual Directory, everyone in the foreign group account has full access to their subfolders, and the foreign individual account has read and execute access to their subfolder. But, it will not let me log in if I put the same shared folder as a Virtual HTTP Directory.

Now, if I add the Everyone group or the NETWORK account and give them read access, then I can access the HTTP Virtual Directory, but it allows anonymous connections, which I definately do not want.
0
 
LVL 1

Author Comment

by:Grime121
Comment Utility
There is no webshare tab in the folder properties on the host where the folder resides. I think that tab is only available if you have IIS installed, which it is not. :(

Should I install IIS and try it then? I'd rather not have IIS on that server, but if I have to than I will....
0
 
LVL 6

Expert Comment

by:karel_jespers
Comment Utility
is the share place on an ntfs partition?
0
 
LVL 1

Author Comment

by:Grime121
Comment Utility
yes, it's ntfs
0
 
LVL 6

Expert Comment

by:karel_jespers
Comment Utility
then you are completly right, you must install iis on the server where the share resides
0
 
LVL 6

Expert Comment

by:karel_jespers
Comment Utility
seems necessairy for http folder sharing
0
Complete Microsoft Windows PC® & Mac Backup

Backup and recovery solutions to protect all your PCs & Mac– on-premises or in remote locations. Acronis backs up entire PC or Mac with patented reliable disk imaging technology and you will be able to restore workstations to a new, dissimilar hardware in minutes.

 
LVL 1

Author Comment

by:Grime121
Comment Utility
Ok, I installed IIS on the computer that hosts the share, and I set up websharing. It created a virtual directory on the computer that hosts the share, but I want the virtual directory to be on my main IIS server, not the one that hosts the folder share.
0
 
LVL 6

Expert Comment

by:karel_jespers
Comment Utility
when you create the virtual directory you must enter

new virtual directory
next
you give a alias you want
in the path name you use an unc name \\folderserver\sharename

0
 
LVL 1

Author Comment

by:Grime121
Comment Utility
That's what I've been doing all along and I get the access denied error. Here is some more info on the error: "You do not have permission to view this directory or page due to the access control list (ACL) that is configured for this resource on the Web server."

I guess I should have mentioned earlier I have Exchange 2003 installed on the IIS server as well.
0
 
LVL 6

Expert Comment

by:karel_jespers
Comment Utility
in the websharing tab you need to give browser rights i
are disabled by default
0
 
LVL 6

Expert Comment

by:karel_jespers
Comment Utility
websharing tab
select share this folder
then goto edit properties
enable the directory browsing



0
 
LVL 1

Author Comment

by:Grime121
Comment Utility
I enabled it when I created the share
0
 
LVL 6

Expert Comment

by:karel_jespers
Comment Utility
check the websharing tab / edit properties button / directory browsing
once more


i have it running over here (right now)
when i disable the directory browsing i receive your error msgs
0
 
LVL 1

Author Comment

by:Grime121
Comment Utility
When I change it like that on the folder's webshare tab it only effects the virtual directory on the server that hosts the share. The main IIS server that I want to host the webshare is not effected by that because it doesn't use the info from the webshare tab. I did however check the directory browsing setting on the virtual directory on the main IIS server, and it was checked. Just for good measure I enabled everything (read, write, log, dir. browsing, allow scripts & executables, etc.). Still same the error.
0
 
LVL 1

Author Comment

by:Grime121
Comment Utility
It looks like this could possibly be a larger problem than the permissions on just one virtual directory not working correctly. I tried another virtual directory and I'm getting the same access denied message. I'm not sure if it is normal or not though. The directory I tried was http://<domanname>/OMA. It's a directory that Exchange 2003 made, and I'm not sure what it's for, but Administrators is listed as having full control in the permissions, but I still get the 'unauthorized to view this page' error.
0
 
LVL 6

Accepted Solution

by:
karel_jespers earned 500 total points
Comment Utility
i would try to
first create a virtual directory pointing to a share on the host where the iis is running  (the iis you want to use)   <= this must surely work

then create a virtual directory pointing to a share on the host where the other iis is running  


0
 
LVL 1

Author Comment

by:Grime121
Comment Utility
Ok, you lost me on that.... :)

main IIS server is PENGUIN, and the file server w/ IIS folder that I want to share is FLOUNDER. I want to add \\FLOUNDER\IIS as a virtual directory to PENGUIN's default webpage.

Now, where are you saying I should create these virtual directories?
0
 
LVL 1

Author Comment

by:Grime121
Comment Utility
Nevermind. I figured it out. This helped: http://support.microsoft.com/default.aspx?scid=kb;en-us;308150 , but then to stop anonymous logins I had to uncheck Enable Anonymous Access under the Directory Security tab in the Virtual Directory Properties. I'm gonna give you the points anyways for the effort :)
0
 
LVL 1

Author Comment

by:Grime121
Comment Utility
The only thing I wasn't doing correctly when adding the virtual directory was setting it to use a specific account to access the shared folder.
0
 
LVL 6

Expert Comment

by:karel_jespers
Comment Utility
ok fine it worked
goodluck
karel
0

Featured Post

Comprehensive Backup Solutions for Microsoft

Acronis protects the complete Microsoft technology stack: Windows Server, Windows PC, laptop and Surface data; Microsoft business applications; Microsoft Hyper-V; Azure VMs; Microsoft Windows Server 2016; Microsoft Exchange 2016 and SQL Server 2016.

Join & Write a Comment

Suggested Solutions

How to update Firmware and Bios in Dell Equalogic PS6000 Arrays and Hard Disks firmware update.
Are you looking to recover an email message or a contact you just deleted mistakenly? Or you are searching for a contact that you erased from your MS Outlook ‘Contacts’ folder and now realized that it was important.
This tutorial will walk an individual through the steps necessary to enable the VMware\Hyper-V licensed feature of Backup Exec 2012. In addition, how to add a VMware server and configure a backup job. The first step is to acquire the necessary licen…
This tutorial will walk an individual through the process of configuring basic necessities in order to use the 2010 version of Data Protection Manager. These include storage, agents, and protection jobs. Launch Data Protection Manager from the deskt…

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

9 Experts available now in Live!

Get 1:1 Help Now