Solved

Can ping but not see other computers???

Posted on 2004-09-16
46
437 Views
Last Modified: 2013-11-29
I have two computers that can ping each other, surf the Internet but not see each other in Network Neighborhood.  Each computer can see the "workgroup" but not itself or the other computer.  They can also ping the router and NAS.  Here's my layout:

Computer 1:
XP Pro (wireless) laptop
192.168.2.251
firewall disabled
TCP/IP with assigned IP
File and Printer sharing

Computer 2:
Win2k Pro
192.168.2.253
firewall disabled
TCP/IP with assigned IP
File and Printer sharing

NAS (network attached storage)
192.168.2.252

Router (SMC2804WBPR-G)
192.168.2.250
firewall enabled

I have tried enabling NETBios over TCP/IP but that didn't work.  During this time, I also enabled IPX on the laptop then it couldn't surf.  However, it could see itself in Network Neighborhood. I did the same for the wired desktop and it could also see itself.  I then disabled NETBios and IPX on the laptop hoping it could surf again.  Still no surfing.  I rebooted the laptop.  No surfing.  I then rebooted the router and could surf.  I've also connected a wire to the laptop but that doesn't make any difference.

Any ideas why the computers can't see each other?

Thanks,
Brett
0
Comment
Question by:brettrkr
  • 17
  • 10
  • 10
  • +7
46 Comments
 
LVL 2

Expert Comment

by:tztrh
ID: 12073615
it is a DNS issue.
What are your DNS settings on both computers?
0
 

Author Comment

by:brettrkr
ID: 12073786
In TCP/IP properties under the DNS tab on my laptop (XP Pro), I have the primary and secondary IPs from my ISP listed in "DNS server addresses, in order of use:"

"Append primary and connection specific DNS suffixes" is dotted
"Append parent suffixes of the primary DNS suffix" is checked

"Register this connection's addresses in DNS" is checked.
0
 
LVL 1

Expert Comment

by:mkgmkg
ID: 12073886
You should  also add "Clients for Microsoft Networks" in the properties of your Lan Connection. That will solve the problem.
0
 
LVL 3

Expert Comment

by:Ollien
ID: 12074036
The only protocol for your setup that is needed is TCP/IP.  Remove all others.

As well as Flie and Printer Sharing (for Microsoft Networks i assume), makesure you have the Client for Microsoft Networks installed.  Everything else looks ok, I see this problem often, normally if you have no firewall, you have those clients and TCP/IP, it should work.  Also make sure you have the same subnet mask on all computers (normall 255.255.255.0).

Goodl Luck, Ollie.
0
 
LVL 2

Expert Comment

by:tztrh
ID: 12074570
what about winxp firewall. disable it on client computers and then try.
0
 
LVL 5

Expert Comment

by:abu_deep
ID: 12074625
just to make sure that u don't miss somthing  with  the file sharing configration of both pc try to play with this artical....
http://support.microsoft.com/default.aspx?scid=kb;en-us;304040
0
 
LVL 3

Expert Comment

by:Ollien
ID: 12074759
Thanks tztrh, that's kinda what I said, and the original question said that anyway.
Have a look at that article if my suggestion doesn't work, it is fairly lengthy though.

Oh, and sorry mkgmkg for repeating what you said, you must've posted while I was writing mine.

Ollie.
0
 

Author Comment

by:brettrkr
ID: 12074935
Sorry, I do have Client for MS Networks installed.  I'm not sure if the simple file sharing is on.  I'll check once I'm back at the machine.  All machines are in the same subnet mask.  XP firewall is disabled.

Ollien said to not use the file sharing service.  How exactly do I share docs if that is not installed?

Thanks,
Brett
0
 
LVL 7

Expert Comment

by:katacombz
ID: 12075109
also check to see that the are part of the same workgroup...
0
 
LVL 3

Expert Comment

by:Ollien
ID: 12075407
Sorry, maybe you misinterpreted what I said, but I meant to say that you need to include the 'File and Printer Sharing for Microsoft Networks'.  In my first response I meant as well as needing file and printer... you also need...

Try instead of looking through network neighborhood, simply type \\computername in the address bar.  Alternatively, Start > Run > \\computername > Enter.  You may substitute an IP address for a name also.

Ollie.
0
 
LVL 1

Expert Comment

by:joephus
ID: 12075512
Are you trying to connect to the computer by name or IP address, or both?
0
 

Expert Comment

by:kevinf99online
ID: 12076015
So - you can ping the other computers - but I don't recall you answering the question as to what you are pinging - the IP address or the name?

Drop to a cmd prompt by Start > Run > cmd

This will open a dos like window where you can type commands.  Type in: net view

Tell us what you see, and the answer to my first question.

Kevin
0
 

Author Comment

by:brettrkr
ID: 12076281
I'm pinging IPs, not computer names.  I did try //computername from DOS and received this message:
The file name, directory name, or volume label syntax is incorrect.

Will try netview once I'm back to the machine this evening.

Does Network Neighborhood or Windows Explorer connect via computer name rather than IP?  What is required to make each of those work?

Thanks,
Brett
0
 
LVL 8

Expert Comment

by:dhoustonie
ID: 12076386
Lets see if I have this correct:
You have the firewall disabled on both machines.
You have both machines setup with a static ip address and dns servers
The dns servers are your ISP's not your routers

Okay if I have that correct then what you need to do is change the dns settings on your machines to your router. That should resolve your internal networking surfing.

Hope this help
Dave
0
 
LVL 1

Expert Comment

by:joephus
ID: 12076419
yeah the syntax would be \\computername your slashes were going the wrong way. And that won't work in DOS anyway, DOS will interpret \\computer as a command as in \\computername.exe which doesn't exist.  You can try "start \\coumputername" (w/o the quotes) and that will give the results you are expecting.  However to connect to a computer by computername you have to translate the name to an IP address by using a WINS server or DNS server with XP, the prefered method is DNS.  However your ISP's DNS server most likely won't have the computer names of you machine in its DNS configuration.  Try running "start \\xxx.xxx.xxx.xxx" (w/o the quotes and where the X's are the ip address of your other computer.
0
 

Expert Comment

by:D3ad
ID: 12079504
try "net use X: \\computername\share" allso works with the ip
0
 

Author Comment

by:brettrkr
ID: 12080126
For dhoustonie, I the DNS settings of the router are those of my ISP.

I tried start \\xxx.xxx.xxx.xxx for my machine and got:
The system cannot find the file 192.168.2.251

Also, \\computername doesn't work.  I still get the "filename, directory, blah, blah...syntax is incorrect.

Any other suggestions?

Thanks,
Brett
0
 
LVL 3

Expert Comment

by:Ollien
ID: 12081591
When I said enter \\computername, I didn't mention DOS.  I was suggesting to enter it directly in the Open field of the Run box (Start > Run).  Try that.  As the others said, make sure you use the slash's the right way '\\'.
0
 

Author Comment

by:brettrkr
ID: 12082962
This morning I see the desktop can see itself.  I can do \\desktopname and it opens to the shares.  The laptop can also \\desktopname and see the shares.  Neither can access the workgroup or see each other through Windows Explorer.  They can't see the NAS either or \\nas.  Only ping the NAS.  All can still ping each other.

The desktop already has IPX installed.  I uninstalled it and it didn't make any difference.

The desktop sees itself in Windows Explorer.

Thanks,
Brett
0
 
LVL 3

Expert Comment

by:Ollien
ID: 12083132
Good progress.

Could you explain what you NAS is exactly?  I'm not too familiar with the equipment.
0
 

Author Comment

by:brettrkr
ID: 12083182
It is a Network Attached Storage device.  It's just a box with a web interface like a router.  That's how I access it.  I use it to store backups and hold other information. http://www.trittontechnologies.com/products/TRINAS120.html

Nice to know it's good progress.  I'm concerned how the NAS will be seen again.  Since all of the configurations are taking place on the PCs and we can do things to test them, it's not that flexible with the NAS.  However, that can be done last.   Seems as though maybe a setting on the router is causing all of this.  If I get both PCs seeing each other, that doesn't mean they will see the NAS.  That's why I'm wondering if something strange is occuring on the router.

Also, this morning I noticed all of the shares on the desktop where unshared.  Perhaps uninstalling/reinstalling services, clients, protocols caused that.

Brett
0
 
LVL 3

Expert Comment

by:Ollien
ID: 12083270
I suggest that now the problem lies within your NAS, check all the configuration.  Does your devices attain an address via DHCP?

Check out the troubleshooting and FAQ (http://support.trittontechnologies.com/nassupport.html#FAQ).

That is your best source, as I am not familiar with that specific device and it would be quicker for you to check it out.  If you can't get anywhere, I am still happy to help the best I can.

Good luck, Ollie.
0
 

Author Comment

by:brettrkr
ID: 12083364
I don't see how troubleshooting the NAS will cause the two PCs to see each other.  The Tritton FAQs have been worthless so far.

Brett
0
Find Ransomware Secrets With All-Source Analysis

Ransomware has become a major concern for organizations; its prevalence has grown due to past successes achieved by threat actors. While each ransomware variant is different, we’ve seen some common tactics and trends used among the authors of the malware.

 
LVL 8

Expert Comment

by:dhoustonie
ID: 12083413
Your addresses are all static are they not?
The dns server addresses on your computers are your ISP's dns servers not your router?
Or are you using dhcp?
0
 

Author Comment

by:brettrkr
ID: 12083420
The devices attain addresses.  No DHCP.  The external gateway was incorrect for the NAS.  Now both PCs can see the NAS and access its shares.

Sorry if I sounded harsh on that last post.  That wasn't my intention.  Just that the Tritton FAQs really are not much help.

I appreciate your patience,
Brett
0
 

Author Comment

by:brettrkr
ID: 12083433
The router gets the DNS primary & secondary numbers from the ISP.  I use those same numbers for the clients.  They don't change.

Brett
0
 
LVL 3

Expert Comment

by:Ollien
ID: 12083467
Ok, now.... I believe that you said that you could access theh computer shares, and now you say you can access the NAS...

I might be mistaken, but now what is your problem?

Ollie.
0
 

Author Comment

by:brettrkr
ID: 12083516
Right, I can access the shares on the NAS from both PCs.  The laptop can access shares on the desktop.  However, neither computer can see itself or each other.  But the laptop can do run \\desktop and see those shares.  Not the other way around.

At least that's how it was going.  I just checked Windows Explorer again and now everything is working.  No more issues.  I like the fact that it is working but don't like how it was solved because I have no idea what corrected it.  You spend much time trying to get it going and all of the sudden it starts working.

The only thing I can figure that changed was correcting the NAS external gateway.  After waiting a little while, all computers could see each other.  Why would the NAS affect the entire network this way, if that is really what happened?  Everything goes through the router.  So one client not working shouldn't affect the other clients....right?

Do you have any other insight into what you see as the solution?

Thanks again,
Brett
0
 
LVL 8

Expert Comment

by:dhoustonie
ID: 12083583
You should change the DNS settings on your two machines with the ip address of the router. I have an older 2804wbr router and it holds the internal ip addresses information and routes unknowns to your ISP DNS servers. If you change the DNS settigns on your machines to 192.168.2.250, do they start seeing each other? Can you ping them by name?

Dave
0
 
LVL 3

Expert Comment

by:Ollien
ID: 12083613
Somehow, some things can cause total haywire if they are not set up correctly, it just almost creates the computers confused at what they are looking at.  It was also getting all the other little settings tweaked, which eventually came back together at the end.  Sometimes computers just need time to adapt to a new thing, it sounds weird, but it happens.

So basically, it was probably the NAS in combination with something causing the problem, and nwhon you used some methods to try and fix it, you might have made it worse for yourself (your first couple of comments).  In the end, you can't be exactly sure what it was, but at least now it is fixed!

Good work, Ollie.
0
 
LVL 8

Expert Comment

by:dhoustonie
ID: 12083705
The reason your laptop might not being showing the shares is that Simple File sharing has been enabled. If you start my computer, tools, folder options, view, and unselect Use simple file sharing at the bottom.
One possible reason that you are not seeing everyone quickly is that it has taken a while for the dns cache to fill with the entries.
Are your clients setup with 192.168.2.250 as their dns server?
The reason I am being persistent is that, this ip address is a reserved address and would not be stored in the dns servers of your isp, they are also behind your firewall with nat, and all addresses are then changed to your external address and that is the only address that your ISP will have for your network, so when your clients go directly to the ISP's dns servers rather then the router which is setup to store those addresses, they will not be able to access them based on a DNS name, but with an unknown amount of time they will gather the information for a netbios name resoltion to access the other machines on your network. But that takes time, but if other machines are added or you change a configuration, your other machines will not change because the information is stored in a cache.

Please try changing the address of your dns server to 192.168.2.250 and tell us how you find that.
Dave
0
 

Author Comment

by:brettrkr
ID: 12084040
Ollie Thanks.

Dave, you are saying to put the primary and secondary DNS servers as 192.168.2.250.  I don't think they should be the same.  Also, this will not allow me to access the Internet.  I need the DNS settings from the ISP, which are the same as what the router has.

I'm not sure what you point is.  As I've mentioned, the router primary and secondary DNS IPs are the same DNS IPs I'm using on the client PCs.  The router gets these IPs from the ISP and I get them from the router or ISP.  They are exactly the same so what difference does it make where they come from?  The DNS IPs do not change.  I imagine the client PCs hit the router first and get DNS IPs from it, not the ISP.  But they are the same so it doesn't make a difference.  The router is not changing the two DNS IPs it gets from the ISP.  I checked with the ISP and the two DNS IPs they gave me are the ones the router sees automatically.

The 192.168.2.250 IP is used on the client PCs as the gateway, which is the router IP.  The setup you are trying to describe will not work.  192.168.2.250 is not used as a DNS IP.

Brett
 
0
 
LVL 8

Expert Comment

by:dhoustonie
ID: 12085196
The address range that you use is reserved for private use only, in general terms that means that anyone can use the same range of ip addresses as you without having to buy, lease or share them with anyone else.
http://megawx.aws.com/support/faq/software/intextip.html
My own network runs with 192.168.2.* 255.255.255.0, similar to yours. What the internat sees and knows about your network is the ip address assigned to your wan port of your network, the rest of your network is hidden behind a Network Address Translation service run on your router. So the ISP's dns server does not know of Laptop and Desktop because they are hidden behind your firewall and NAT. So as you have only your Isp's dns servers setup when you query it for laptop it has no record for it. But your router is a dns server as well it holds a set of records for 192.168.2.* if you ask for another Ip address out side of this range it will forward the request to your isp's dns server and retrieve the information and pass that back to you computer.

Try setting up dhcp, watch and see what address information it gives your clients.

Dave
0
 

Author Comment

by:brettrkr
ID: 12085431
There's not reason to use dhcp.  I restrict the block of IPs being used only for the clients I need.  You're right, the ISP does not know about the laptop and desktop.  

However, you seem to be going in circles.  I still don't know what you are driving at.  As I mentioned, the DNS server IPs I'm using are those being held by the router.  If I don't use them, I don't have Internet access.  You can try to make it as complicated as you like but It's that simple.

Brett
0
 
LVL 8

Expert Comment

by:dhoustonie
ID: 12086521
Brett, I'm not trying to make it complicated you have said that you don't why you should do that, I have tried to explain my reasoning. I have made two suggestions to your problem to see if they solve your problem permanently. I will rephrase the solutions again in case I am not saying it correctly. I belive the two computers need to change their dns primary server to 192.168.2.250. Your router is perfectly configured, it is just that one setting on your laptop and desktop that I believe you will need to change. Also that you will need to switch off Simple file sharing on Windows XP.
I have asked before and ask again, please try it and post your findings here, you can change them immediately back.

0
 

Author Comment

by:brettrkr
ID: 12086702
dhoustonie, the problem has been resolved so there isn't any way for me to tell if your suggestions will work.  However, I will turn off simple file sharing. Why do you believe it causes issues?

If the primary DNS will be the router, what are you suggesting for the secondary DNS?

Brett
0
 
LVL 8

Expert Comment

by:dhoustonie
ID: 12086788
Lets try one more thing, in the Event Logs for System, do you see messeges similar to this?

The browser has forced an election on network \Device\NetBT_Tcpip_{76374C43-F539-4570-94C3-25CF1B6D7501} because a master browser was stopped.
0
 
LVL 8

Expert Comment

by:dhoustonie
ID: 12087001
With regards your secondary dns server, if your router is down then so is your internet connection, therfore you won't be able to connect to your isp's dns server, so you won't need it.
When Microsoft released Windows Xp they included Simple file sharing, in my opinion it has caused more problems then it is worth, but it required login of the guest account which was usually disabled, so you couldn't view the machine or it's files. By disabling it, it returns the defaults to requiring a username and password.
Another problem is that your user account may have a blank password, if you give the account the same password that should hopefully resolve that.
Hope this helps
Dave
0
 

Author Comment

by:brettrkr
ID: 12087285
It seems quicker to put the ISP's DNS IPs into the client tcp/ip configs.  This goes straight to the ISP and does not involve translation at the router.  Although it is probably cached.

I'll check event logs once I'm back at the machine.

Brett
0
 
LVL 8

Expert Comment

by:dhoustonie
ID: 12087389
It would be marginally faster, but agreed faster for internet addresses, but if the setting was changed it would has increased speed for your own network. When you described that your machines could not see anything in the Windows Network folder but themselves, because there is no internal dns server accessed to find out who is connected, your computers send out Broadcasts to find other computer on your network.
But, and what if your ISP connection is dropped then you still have a DNS server that you would be able to use if you reconfigured the computers to use the dns router.

I would appreciate finding out what is in the logs.

Dave
0
 

Author Comment

by:brettrkr
ID: 12089258
Dave,

Here's an entry from the system long from yesterday starting at about 6:30AM:
Browser
The browser has forced an election on network \Device\NetBT_Tcpip_{3B48F4CE-38EB-42A6-AC74-0FF42E20235E} because a master browser was stopped.

Another one occured four hours later and then 5 minutes after that.  Also, from both PCs, I'm getting the workgroup is not accessible message.  I can't do \\computername anymore.  I can still ping though.  Noticing this when I walked in.  Here we go again.

I also have these entries mixed in between the above:
tcp/ip
The system detected that network adapter Broadcom 802.11b/g WLAN was connected to the network, and has initiated normal operation over the network adapter.

The only thing in the system log for today is:
6:30A (EST) - about an hour before the network came online.
MrxSmb
The redirector failed to determine the connection type.

Possibly, both machines are trying to be browse masters?

Thanks,
Brett
0
 
LVL 3

Expert Comment

by:Ollien
ID: 12089631
Ok, well I thought everything mas fixed.... I don't see why you would bother playing with something like that 'If it ain't broke, don't fix it'.

I suggest you undo everything you did after you said it was all working.

dhoustonie, the router is NOT a DNS server, brett was right to set the DNS to the ISP's DNS.  If he was using the router's DHCP, it would also set the DNS servers to the ISP.  Brett was right about that.  The router's NAT doesn't create a problem here, because the clients access the internet through the NAT, their request goes out as the external IP of the router, not as their local address; I'm afraid you are mistaken.

Brett, if you can get it working like it was, and are happy with that, then I suggest you leave it like that and close the question.

Ollie.
0
 

Author Comment

by:brettrkr
ID: 12089732
Ollie, thanks for the clarification to Dave.  

I didnt change anything.  All I did was come home and have no network.  I was fine when I left this morning.

Brett
0
 

Author Comment

by:brettrkr
ID: 12092590
Here's a little more information.  I've been running the "nbtstat -a computername".  The NAS has the browser master.  The entry __MSBROWSE__ was present only for the NAS - http://www.wown.info/j_helmig/browse.htm.  No other PCs could see it.   I rebooted the NAS and it is now seen by the laptop and desktop.  All computers can see each other also.  Everything is working again.

I thought at first the solution was that the NAS can't be the browse master.  After waiting a few minutes, I see it has the MSBROWSE entry again and everything continues to work.

Brett
0
 
LVL 3

Accepted Solution

by:
Ollien earned 360 total points
ID: 12093693
Congrats Dave!  I'm glad you solved your problem, if that is all, and you are happy the way it turned out, it is good for you to mark the question as answered, so it can be put down as a solution that other people can refer to.

Well done, Ollie.
0
 
LVL 8

Expert Comment

by:dhoustonie
ID: 12095297
To correct Ollien, the smc 2804 router does support dns forwarders, it is a dhcp server that would assign, and I gaurantee this because I have one, that the dhcp gateway address would be the router, the dns server would be the router. The MS Browser hold the list of netbious names. I'm not going to argue with you guys anymore, but I will say this your network went down because you have a problem. I believe and will continue to do so until you try the changes you will find days when your network fails and you need to reboot everything.
Well done, and I wish you the best
0

Featured Post

How to improve team productivity

Quip adds documents, spreadsheets, and tasklists to your Slack experience
- Elevate ideas to Quip docs
- Share Quip docs in Slack
- Get notified of changes to your docs
- Available on iOS/Android/Desktop/Web
- Online/Offline

Join & Write a Comment

Data center, now-a-days, is referred as the home of all the advanced technologies. In-fact, most of the businesses are now establishing their entire organizational structure around the IT capabilities.
Join Greg Farro and Ethan Banks from Packet Pushers (http://packetpushers.net/podcast/podcasts/pq-show-93-smart-network-monitoring-paessler-sponsored/) and Greg Ross from Paessler (https://www.paessler.com/prtg) for a discussion about smart network …
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.
In this tutorial you'll learn about bandwidth monitoring with flows and packet sniffing with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're interested in additional methods for monitoring bandwidt…

746 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

10 Experts available now in Live!

Get 1:1 Help Now