• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 199
  • Last Modified:

Easy: Tweak to add icon to Save menu

Hi guys,

I used to know how to do this. This is the picture:
I have two hard drives in a machine, one for OS and programs, second one for data only. I have a shoetcut to the second drive (Drive F:) on my Desktop. Whenever I'm working on a document or want to save an image or whatever from any app, if I hit Save or Save As I get the Save dialog box with a few icons on the left panel (i.e. Desktop, MY Documents, My Computer, etc..) How do I get my shortcut to the second drive to show in that list? It'd save me one or two double-clicks. If I remember wel, there's a Registry tweak that does just that.

Good Vibes!

1 Solution
From within the save dialog itself, select browse to the folder you wish to add and select "Tools", then click on "Add to My Places". This will add the folder to the list on the right.

Lobo042399Author Commented:
Hi jdeclue,

Sorry for ther delay. I forgot to mention I'm in a W2K environment and there's no "Tools" in the Save dialog box. I know there's a Registry tweak for this... if I could only remember it, Grrrrr.....

Good Vibes!

Lobo042399Author Commented:
Hi again,

Doing some research I just figured something out... the fix you mentioned works for Office apps, but not for other apps. I also found a Registry tweak but it also does it for Office only.

I have also found a reference to editing the following Registry Key:


But I don't see such key in my Registry.

Any help?

Good Vibes!

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

You could redirect your My Documents folder to be your apps drive and not the OS drive.  You can right click on "My Documents" and go to properties to set it, or play with the registry settings here:
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders]

While you are at it you might consider changing the path of your "Program Files" so you dont' have to manually change it
"ProgramFilesDir"="D:\\Program Files"

TweakUI is also capable of changing many of these settings fairly safely.
Follow the instructions of this link http://www.puppypc.com/windows/rt/comdlg_placebar.htm
You only need to create the right registry key.
Lobo042399Author Commented:
Hi Eagle,

Thing is I still want to be able to double-click on an icon (i.e. the My documents icon) on the Desktop and expect to go to that place and not get redirected. Thanks for the sugestion, anyway.


Yes, that is the key I had seen before. I've created the keys following the instructions in that site. It all works fine until I try to set the Custom values. I can create the string and assign the custom value to it (F: in my case) but it doesn't show in the side bar when saving a file. I've uploaded a screencap of the registry screen. As you can see there, Place2 is set to the F: drive. The code generator in the webpage you gave added the two backslashes so I included them. Removing these backslashes to show only F: has no effect. Anything I'm doing wrong?

Thanks and good vibes!


Hi Lobo,
I cannot see your screenshot, have you tried to use the file that is downloadable from the same link I sent you to put back your registry to default conditions, than reapply the .reg file you can create on that page? I am asking because I used that code and I am currently seeing it functioning on my machine. Just to be sure: what Service pack are you using?
I hope it helps, Elbereth21.
Lobo042399Author Commented:
Hi elbereth,

This is SP4. Sorry, forgot to include the URL, silly me. Here it is:


Note that the screencap is from Registrar. But doing it in good old Regedit made no difference. Also, removing the two slashes made no difference either. I also tried using a D_Word and inserting the code for F: and F:// and again, it would not show in the side bar.

Thanks for your help. Good Vibes!

Hi, Lobo
this might seem futile, but take a look at the text (in a .reg file) I am currently using:

Windows Registry Editor Version 5.00


Could it be that your slashes are reversed?
I hope it helps, Elbereth.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now