ftp server and windows xp sp2

I am running a ftp server on a windows 2k3 machine.  It seems to be working o.k.  There are a few problems that I need help with.  
1.  If someone has sp2 for windows xp, that computer can't connect to the ftp server.

2.  It seems like an outside machine takes a while to connect to the computer, even if it is able to.  Is there a way to speed up response time between the ftp server and an outside machine?

Thanks for any help you can provide

Jason
fou99004Asked:
Who is Participating?
 
NetExpertConnect With a Mentor Commented:
Normally if the client use a link to access ftp server, they will access by ftp browsing feature of IE (come with Windows), which is quite clumpsy and won't work most of the time (and it's tricky to configure, especially they're using uni computers).
This one is from Microsoft support site:
"How to Change the Internet Explorer FTP Client Mode
Start Internet Explorer.
On the Tools menu, click Internet Options.
Click the Advanced tab.
Under Browsing, click to clear the Enable folder view for FTP sites check box.
Click to select the Use Passive FTP (for firewall and DSL modem compatibility) check box.
Click OK."
Better ask your students to do it, or your script may be classified as "malicious" and won't be run at all (since it will attempt to change IE settings).

I assume that you let your students access as anonymous user? Why don't you put the file on a HTTP server and give students the link direct to the site (so they'll use http GET method).
Other wise, ask your student to use a free FTP client (filezilla is the one I'm using).

Regarding the server:
logging and dns lookup is something totally different. Look around your server setting, you'll find "dns reserve lookup" check box with comments around it (saying it will slow down your response time). Uncheck that box will do the trick.

Please post your server config (ftp server program, firewall involve, dns setting for server, etc..) and how you distribute the link to your students, so we can give you some detail instructions.

PS: when I say "turn it off" in the previous post, it means "turn the Windows firewall off".

Good luck
0
 
jasperomalleyCommented:
1. It's the firewall for SP2 blocking FTP session. The way normal ("active") FTP works is that you open a control session to the FTP server's TCP port  21, and all data transfer is accomplished by the FTP server opening a session *back to you* from the server's TCP port 20. The FTP clients need to be set to use "passive" FTP, wherein all connections are initiated by the client to the server.

2. Sounds like the server might be trying to do a reverse DNS lookup on the inbound connections' IP addresses, probably for loggin purposes. Turn that option off in the FTP server configuration.
0
 
rafael_accCommented:
sp2 on winxp has come with some security improvements. These include the firewall enabled by default! So, please check the help ...It's all very well documented ...

cheers.
0
 
NetExpertCommented:
What kind of ftp server you are using?
I have the following config:
FTP server (ServU running on port 32021 and FileZilla on port 31021) on a Win2k SP4 with ZoneAlarm firewall (default config, no expert rule for ftp transfer).
client (using raw ftp built in for Windows, FileZilla and CuteFTP) on a WinXP Pro SP2 machine with ZoneAlarm (default config) and Windows firewall ON (plus another firewall from the ISP for wireless access).
Everything works fine (even when switch passive mode ON/OFF or Windows firewall ON/OFF). But I do experience some slow connection / response time in some cases. It looks like the firewall has caused some problems too.

The (Windows) firewall at least should allow you to CONNECT to server anyway.

I would go with what jasperomalley said, but:
- look at the firewall log.
- turn it off (I don't recommend relying on Windows firewall)
- manually set the firewall to allow your FTP client "act as a server" if possible, to avoid the use of passive mode.
- read the ftp server/client and look at it settings (enable passive mode, compresion - which may slow down the response time, dns settings). Normally the DNS reverse lookup is off by default with most ftp server, so, erh, I'm not sure :)
0
 
fou99004Author Commented:
jasperomalley
     I am going to need help on how to set up passive ftp.  Right now, students are getting onto our server by accessing a link to their notes.  The link was done with straight html.  Can I embed the code I need into the html (maybe javascript or something)?  
     Also, I stopped the logging on the server, will this completely stop the dns lookup or is there something else that I had to do.  Thanks.

Jason
0
All Courses

From novice to tech pro — start learning today.