Problems installing USB cordless keyboard & mouse


Hi,

I'm trying to install a "multimedia cordless kit", as it's called,  on my machine but Windows (2000 pro sp4) fails to install it properly.

The cordless kit is a dixall DIX-9001-URF, available from www.dixall.com
The kit comes with a driver disk containing three .inf files (usbwin2k.inf,usbwinme.inf,usbwinxp.inf) and some other files.

When I plug the device in, Windows seem to recognize the device type (the "Found New Hardware" window pops up saying it's found a "USB Multimedia Cordless Kit"). Then the "New Hardware Wizard" opens up and suggests me to search for a suitable driver for the device.

That's where the problems start : After telling Windows which locations to search (floppy disk, ...), it keeps saying it could not find an appropriate driver although the driver disk was in.

I think it finds and reads the .inf files but, for some reasons, decides they're not the good ones.

I tried to copy the files to the hard drive to make sure it wasn't due to an hardware problem (like bad sectors on floppy or something...) but it didn't look like.

I noticed the driver disk contained some .exe files, which I executed, but none of these seemed to install the driver either.


Thanks in advance


LVL 2
belgiansproutAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

CallandorCommented:
Have you tried using the keyboard?  USB keyboard devices in Win2K and WinXP, to my knowledge, are plug-and-play - the USB recognizes it, and that's all that's needed.  My Gyration keyboard works that way.
0
belgiansproutAuthor Commented:

I know, the keyboard and the mouse are working fine indeed when used on one of my laptops (with Windows XP).

It's just that they're not working on my Win2K desktop PC (which is the machine I bought the kit for) - both the keyboard and the mouse.
I also made sure the batteries were ok, just in case.

 
0
CallandorCommented:
What you could try is to remove the USB device driver for your motherboard and reinstall it.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

AuriclusCommented:
After Windows failed to find the driver on the floppy, did you browse there manually and select the "usbwin2k.inf" file?  Did that step fail as well?

Auriclus

0
belgiansproutAuthor Commented:

Callandor: Do you mean uninstall the driver from Windows ? The thing is that no driver has been installed at all. If I look in the device manager, the device shows up under the "Other devices" section (I believe that's where the problematic devices appear) and if I right-click Properties, the "Device status" box says : The drivers for this device are not installed (Code 28).
If I Click the "Reinstall Driver" button it pops up the upgrade device driver wizard, which basically does the same thing as the new hardware wizard and thus doesn't recognize my driver disk either.
I've however tried "Uninstall" as you suggested but the problem remains the same when I plug the device back afterwards.

Auriclus: Yes, I've tried that. I've also tried the other .inf files (who knows?) as well as other locations (c:\winnt\inf) and Windows Update.

The weird thing is that WinXp (on my laptop) didn't require any driver at all. The device was recognized and worked as soon as it was connected.
0
CallandorCommented:
I think that's where your problem lies - on my Win2K system, USB devices show up as Universal Serial Bus controllers, right under System devices.  If it's showing up under Other devices, your USB drivers are not correctly installed, which would prevent your wireless keyboard from being installed.  Perhaps you need to reapply sp4, which has USB patches?
0
eccs19Commented:
I think there is a bit of confusion between the drivers that Callandor & belgiansprout are talking about.  I think that belgiansprout is refering to the drivers for the keyboard showing up as NG, where as Callandor is asking belgiansprout to remove the drivers for the actual USB port(s).  If this is the case, try removing the USB drivers as suggested by Callandor, and re-boot the system and see what happens.  You could also check in your BIOS and see if there is any mention about USB keyboard support, and if so, make sure it's enabled.
0
belgiansproutAuthor Commented:
Callandor: I thought about that as well. I reinstalled SP4 this morning, thinking it might sort things out a bit, but it obviously didn not.

eccs19: I understand what you mean. What Callandor told me was to uninstall the driver for the USB controller itself, instead of the driver for my USB device. Ok I've just tried that : Under the "Universal Serial Bus Controllers" section in my device manager were two drivers, namely "Ali PCI to USB Open Host Controller" (Ali being my motherboard) and "USB Root Hub". I uninstalled both of them and rebooted.

Well, I think the situation just got worse. Upon reboot Windows tried to reinstall the driver for the "Universal Serial Bus Controller" but could not do it. Again, it launched the new hardware wizard and asked me to locate a driver for it! I inserted the Windows 2000 CD as well as the motherboard CD, told him to look in C:\WINNT\INF, but it didn't want to reinstall it. As a result I'm not able to use USB devices anymore.

I think something must be flawed with the hardware or driver installation process. What should I do ? Is there some kind of repair functionality I could use ?  I just don't how to fix that. I'm sure a fresh Win2000 install would solve that, but I'm really not willing to do that.

0
CallandorCommented:
Sorry to hear that it messed up things more.  You should be able to do a repair installation from the CD, which should leave your programs and data intact.  You may need to reapply service packs.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
eccs19Commented:
When you re-booted, did you try doing it without your devices plugged in?  I don't think it would make a difference, but perhaps worth a try.  Perhaps then it will apply the USB drivers properly.  I can't say as I've seen that happen to me before, usually it will just load the drivers back up.
0
belgiansproutAuthor Commented:
I think the problem was due to SP4 that must have broken something when it was installed.

So what I did is I used the Windows CD to reinstall the system files and suddenly everything was back to normal.
I was then able to plug the keyboard and the mouse, they worked straight away - without even requiring any driver disk.

Besides, I've come across many messages on the net from people experiencing all sort of problems with SP4.
It looks like this one is quite bad, to the point that lots of people recommend to stay away from it (!)

Anyway, thanks for your help on this.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Peripherals

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.