• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1005
  • Last Modified:

dsl/router/mandrake/xp probs

hi
i;m trying to get my linux mandrake 10 computer on my network with my windows xp computer through a router

i can get one computer to work at time. they don't both seem to work simultaneously.

are there settings in mandrake that i need to alter to allow this.?

i'm using a dlink DI-704UP router with and actiontech gt701-wg dsl modem through qwest.

the first problem that i had was that the dsl modem and the router used the same ip addy: 192.168.0.1

so i changed the router ip to 192.168.2.1

then i was able to get internet on linux. so i thot the problem was solved.

not so.

now can't get both computer to get connectivity at the same time.

thanks in advnace...
_mike_h
0
solodiver
Asked:
solodiver
  • 14
  • 9
1 Solution
 
solodiverAuthor Commented:


note they both have different internal ip's, in linux i typed ifconfig
and got inet addr: 192.168.2.161  bcast 192.168.2.255 and mask: 255.255.255.0
and on xp ipconfig gave:

ip address: 192.168.2.197
subnet mask: 255.255.255.0
default gateway: 192.168.2.1
0
 
solodiverAuthor Commented:
also when i go to www.whatismyip.com

i get the same ip for both computers: 63.226.18.72

i suppose that is correct, it's just using the dsl connection ip addy

0
 
LuxanaCommented:
can you ping winXP and mandrake?

SO you are saying that even both PC's are connected to same router and thay can ping ecahe other just one PC can get on internet?
0
Cloud Class® Course: Microsoft Exchange Server

The MCTS: Microsoft Exchange Server 2010 certification validates your skills in supporting the maintenance and administration of the Exchange servers in an enterprise environment. Learn everything you need to know with this course.

 
solodiverAuthor Commented:
yes, but i didn't try to ping each other

i disconnected the router and am now only using the dsl actiontec/router with built in ppoe to connect the two

i have usb for winxp and is working fine
i have eithernet for linux and is not working at all
can you tell me how to set up linux on this dsl router?

i did go ahead and ping my xp machine (192.168.0.5)
i also did ping my linux from xp (192.168.0.6)

and both worked fine.

0
 
solodiverAuthor Commented:
basically i can get www.whateverwebpage.com on one xp and NOT on xp, if i don't go to the same web page on both computer is seems to work ok.

i don't know how to explain it other than that.

can't seem to get simultaneous connections...

it seems to be the linux computer that is having the problems xp always works i think.
0
 
solodiverAuthor Commented:
ok sorry to keep updating this but i have some new information.

example of my problem:

say on xp i;'m on google.com,

linux can't bring it up,

so i ping www.google.com in linux and then i can browse www.google.com

odd.
0
 
LuxanaCommented:
# cat /etc/resolv.conf

is your dns seting there corect? do you have more than one nameserver there?
0
 
solodiverAuthor Commented:
cat /etc/resolve.conf

gives me no such file or directory

logged in as root by the way.

-mh
0
 
LuxanaCommented:
what is your setting for DNS in wndows PC?

not  cat /etc/resolve.conf
but
cat /etc/resolv.conf
search
nameserver 192.168.0.1

0
 
solodiverAuthor Commented:
dns settings in windows are not specified.

i don;'t understand the commands i'm supposed to type in.

_mh
0
 
LuxanaCommented:
no problem I'll explane;

so :
cat command reads lines from file /etc/resolv.conf as stantard input and as stantard output will display it on screen. file /etc/resovf.conf contain your dns setting in linux
cat /etc/resolv.conf  -> command
search -> output
nameserver 192.168.0.1 -> output
please also paste here output of command ipconfig /all from your windows

0
 
solodiverAuthor Commented:
ok now i have NO idea what you're talking about.

0
 
LuxanaCommented:
windows:
start->run->cmd->ok

you get command promt and ther type:
ipconfig /all
from my xp I get ouptup like this:
Windows IP Configuration



        Host Name . . . . . . . . . . . . : hostname

        Primary Dns Suffix  . . . . . . . :

        Node Type . . . . . . . . . . . . : Unknown

        IP Routing Enabled. . . . . . . . : No

        WINS Proxy Enabled. . . . . . . . : No



Ethernet adapter Local Area Connection:



        Connection-specific DNS Suffix  . :

        Description . . . . . . . . . . . : Realtek RTL8139 Family PCI Fast Ethernet NIC

        Physical Address. . . . . . . . . : 00-0A-E4-54-B7-68

        Dhcp Enabled. . . . . . . . . . . : Yes

        Autoconfiguration Enabled . . . . : Yes

        IP Address. . . . . . . . . . . . : 192.168.0.2

        Subnet Mask . . . . . . . . . . . : 255.255.255.0

        Default Gateway . . . . . . . . . : 192.168.0.1

        DHCP Server . . . . . . . . . . . : 192.168.0.1

        DNS Servers . . . . . . . . . . . : 192.168.0.1

        Lease Obtained. . . . . . . . . . : Saturday, September 18, 2004 1:56:07 AM

        Lease Expires . . . . . . . . . . : Sunday, September 19, 2004 1:56:07 AM

to make output to file not on screen type command like this:
ipconfig /all > c:\ip.txt
the paste content of c:\ip.txt file here

linux:

opne terminal (console):
first command:
# ifconfig            (paste output here)
then
# cat /etc/resolv.conf                 (paste output here)

so then we can compare setting of your two pc's


0
 
solodiverAuthor Commented:


Windows IP Configuration



        Host Name . . . . . . . . . . . . : MIKE_LAPTOP

        Primary Dns Suffix  . . . . . . . :

        Node Type . . . . . . . . . . . . : Mixed

        IP Routing Enabled. . . . . . . . : No

        WINS Proxy Enabled. . . . . . . . : No



Ethernet adapter Local Area Connection:



        Connection-specific DNS Suffix  . : ph.cox.net

        Description . . . . . . . . . . . : Realtek RTL8139/810x Family Fast Ethernet NIC

        Physical Address. . . . . . . . . : 00-0F-B0-02-A5-F9

        Dhcp Enabled. . . . . . . . . . . : Yes

        Autoconfiguration Enabled . . . . : Yes

        IP Address. . . . . . . . . . . . : 192.168.2.197

        Subnet Mask . . . . . . . . . . . : 255.255.255.0

        Default Gateway . . . . . . . . . : 192.168.2.1

        DHCP Server . . . . . . . . . . . : 192.168.2.1

        DNS Servers . . . . . . . . . . . : 68.2.16.25

                                            68.2.16.30

        Lease Obtained. . . . . . . . . . : Friday, September 17, 2004 7:28:32 PM

        Lease Expires . . . . . . . . . . : Friday, September 24, 2004 7:28:32 PM



Ethernet adapter Wireless Network Connection:



        Media State . . . . . . . . . . . : Media disconnected

        Description . . . . . . . . . . . : Broadcom 802.11b/g WLAN

        Physical Address. . . . . . . . . : 00-90-4B-59-8F-FA

-----------------------------------------

now on mandrake 10 console

in root

ifconfig

results in :

[root@192 solodiver2]# ifconfig
eth0
0
 
solodiverAuthor Commented:
sorry, accidentally posted comments prematurely.
 

need to dailup wi/ liniux to paste the information, brb

0
 
solodiverAuthor Commented:
ok here's the results from ifconfig (before i dialed up) i needed to dialup in order to paste these results

[solodiver2@192 solodiver2]$ ifconfig
bash: ifconfig: command not found
[solodiver2@192 solodiver2]$ su
Password:
[root@192 solodiver2]# ifconfig
eth0      Link encap:Ethernet  HWaddr 00:0D:88:37:2C:9D
          inet6 addr: fe80::20d:88ff:fe37:2c9d/64 Scope:Link
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:1 errors:0 dropped:0 overruns:0 frame:0
          TX packets:83 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:60 (60.0 b)  TX bytes:9546 (9.3 Kb)
          Interrupt:9 Base address:0x5400

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:216 errors:0 dropped:0 overruns:0 frame:0
          TX packets:216 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:16446 (16.0 Kb)  TX bytes:16446 (16.0 Kb)

[root@192 solodiver2]#
0
 
LuxanaCommented:
mike i still can see your /etc/resolv.conf file please paste output here. edit this files but first make backup of current files:
linux:
Edit  /etc/sysconfig/network-scripts/ifcfg-eth0 - This is the main config file for the interface.

DEVICE=eth0
BOOTPROTO=static
IPADDR=192.168.2.200        
NETMASK=255.255.255.0      
NETWORK=192.168.2.0        
BROADCAST=192.168.2.255    
ONBOOT=yes
MII_NOT_SUPPORTED=yes

/etc/resolv.conf should contain the nameserver address(es)
nameserver 192.168.2.1
nameserver 68.2.16.25
nameserver 68.2.16.30

/etc/sysconfig/network
HOSTNAME=yourhostname_goes_here
NETWORKING=yes
GATEWAY=192.168.2.1  
GATEWAYDEV=eth0  

then restart network.Please make backup your current files just in case

sorry to confuse you but I'm in 95% commnad promt user just because I want to make things faster.

then paste here output from command ifconfig again. I'm debian user som my configuration files are different a bit but those above will fit to mandrake.



0
 
solodiverAuthor Commented:
ok i went into /etc/ and sure enough there is a resolve.conf file in there.

not much i can do with it.

should i be typing

Edit /etc/resolve.conf?

if so bash: Edit: command not found

thnx,

_mike
0
 
LuxanaCommented:
not resolve.conf but resolv.conf . edit command is on windows platform

have a look here:
http://web.onetel.net.uk/~showerail/simple_net_setup.html
and
and use some gui editors to edit your files


0
 
solodiverAuthor Commented:
ok here's resolv.conf

search 168.2.1 local
# search 168.2.1 168.2.1 local ph.cox.net local
nameserver 127.0.0.1
nameserver 205.171.3.65
nameserver 205.171.2.65
# nameserver 127.0.0.1
# nameserver 68.2.16.25
# nameserver 68.2.16.30

#ppp temp entry

________________________

/etc/sysconfig/network-scripts/ifcfg-eth0

is:

DEVICE=eth0
BOOTPROTO=static
IPADDR=192.168.0.1
NETMASK=255.255.255.0
NETWORK=192.168.0.0
ONBOOK=yes
MII_NOT_SUPPORTED=no
WIRELSS_ENC_KEY=""
0
 
LuxanaCommented:
ok now make a copy of this current as backup and edit this files as I wrote above then restart network and place here output from command # ifconfig
I always put # or $ in front of commands just to let you know that
# means root
$  means normal user
0
 
solodiverAuthor Commented:
i'm connected now.

linux and xp are working together. well done. how do i grade this so you can get an A?



-mike_hoy
0
 
LuxanaCommented:
good:))

click on accept answer and then it will ask you what grade you want to give.

Lubos
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 14
  • 9
Tackle projects and never again get stuck behind a technical roadblock.
Join Now