Windows 2000 can't login because of bad or missing keyboard driver or registry entry for keyboard.

Windows 2000 can't login because of bad or missing keyboard & mouse drivers or missing registry entry for keyboard/mouse.  OK... I turn on the computer and I get the login CTRL-ALT-DEL dialog box.  However, my keyboard or mouse doesn't work.  I know physically the Keyboard and Mouse are fine because prior to this problem I was following a MS Technical document on renaming some digitally unsigned drivers in C:\WINNT\SYSTEM32\DRIVERS folder to fix a STOP: 0x00000009F DRIVER_POWER_STATE_FAILURE.  This is what I've tried:

Safe Mode   - Same Issue: Can't use keyboard

Safe Mode Command Prompt.  - Same Issue: Can't use keyboard

Last Known Good Configuration   - Same Issue: Can't use keyboard

Recovery Console - Copied some keyboard drivers to C:\WINNT\SYSTEM32\DRIVERS  - Issue: Can use keyboard to perform copy.  However, it didn't fix the problem.

Win2k CD Fast Repair - Same Issue: Can't use keyboard

Any recommendations.  Thanks, Heath.


hmjonesAsked:
Who is Participating?
 
XSINUXConnect With a Mentor Commented:
As you can log into Recovery Consolve, get to the prompt c:\Windows\System32\drivers  and delete kbdhid.sys and try restarting. If that does not help, boot to recovery cosole again and type the command

copy i8042prt.sys kbdhid.sys

This may help.

Cheers
Sinu
0
 
Jeff RodgersNetworks & Communications Systems ManagerCommented:
have you tried plugging in a USB keyboard... Plug and Pray may detect a different kind of keyboard ... I have seen keyboards detected as USB which worked even when the PS2 keyboard won't.

0
 
tfjeffCommented:
I was thinking something similar, only I was thinking of making sure you were using a PS2 keyboard and not a USB keyboard...try both.
good luck
jeff
0
Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
pegasysCommented:
LOL, heh this is cool, but fixable.

Install 2k as if it's a normal re-install from scratch. Upon doing this, it will ask 'operating system found' bla bla bla, upgrade it, don't overwwrite it...

If you upgrade from one os to itself it refreshes the files tow hat they should be

please note that all new SP's that were installed (nothing else though) will have to be re-installed...

Regards

pgx();
0
 
dheeruthakurCommented:
if you have able to manage 1 more computer then its better you insert your hard disk in another computer  as a slave ( open your cpu and take your hard disk, insert this hard disk in another computer ) and take all the data because data is important and format your hard disk and insert this disk in your computer. ( because  keyboard driver load through os and you are not able to repair your os then its better you format and load fresh copy of os otherwise it always gives you problem.  )
If data is not a vital factor boot through bootable cd and install fress copy of os.
       After this boot your  computer through bootable cd ( if you use xp or professional its easy to use ) and make partition and load your fresh os.
       If you have problem in partition and instaulation reply me I will give you step by step instruction.

Dheerendra
(Network Engineer)
0
 
dheeruthakurCommented:
You can only log on using ALT key combinations to create the extended characters in your password.

You installed the U.S. version of Windows NT and the U.S. keyboard is the default keyboard.

NOTE: Keyboard settings are user specific. Although you may select a foreign language keyboard, at logon time (no user is logged on yet) the default keyboard settings are used. So at logon time no country-specific extended characters are available.
RESOLUTION
If you want to continue to use a password that has extended characters, you must change the default keyboard settings in the registry as follows:

Windows NT 3.51:
1.      Run Registry Editor (REGEDT32.exe).
2.      From the HKEY_USERS subtree, go to the following key:
\.DEFAULT\Keyboard Layout
3.      Change the value "Active" to the appropriate string. For example, the string 00000407 defines German keyboard layout and 00000409 defines U.S. keyboard layout. (See "More Information" for a list of language IDs.)
An alternative solution is to use the User Profile Editor to modify the complete system default profile by saving the current user profile information as the system default profile.

Windows NT 4.0/Windows 2000:
1.      Run Registry Editor (REGEDT32.exe).
2.      From the HKEY_USERS subtree, go to the following key:
\.DEFAULT\Keyboard Layout\Preload
3.      Change the value for the following entry to contain the keyboard layout that you want to have avilable at logon. This example would set the default keyboard layout to Japanese:
\.DEFAULT\Keyboard Layout\Preload
"1" REG_SZ = "0411"
NOTE: Beginning with Windows NT 4.0, the first keyboard layout in the list of available layouts is used by default. This behavior replaces the "Active" value that was used in previous versions of Windows NT.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.