Go Premium for a chance to win a PS4. Enter to Win

x
?
Solved

Logging in as root on Mandrake 10?

Posted on 2004-09-17
5
Medium Priority
?
2,005 Views
Last Modified: 2013-12-06
Running mandrake 10. As soon as I create users, I cannot log into the desktop with root.  It automatically defaults to a selection of users. Any way to log in to the desktop with root again?
Thanks
0
Comment
Question by:dissolved
5 Comments
 
LVL 2

Assisted Solution

by:zuralin
zuralin earned 200 total points
ID: 12090321
If you are using GDM you need to go into the settings and set it to allow you to login as root
0
 

Author Comment

by:dissolved
ID: 12090401
how would i do that?
Thanks
0
 
LVL 23

Accepted Solution

by:
Mysidia earned 1600 total points
ID: 12090464
Disclaimer: logging in as root is a really bad idea. It's best to login as a normal user and use su
for administrative tasks. Outside system installation / recovery there no reason you should ever
need to log in directly as root. It's perfectly reasonable that your system not allow you to do so
by default.


In order to successfully login as root, the main thing you need to do is adjust your
display manager's configuration.

First open a terminal window... (i.e. Alt + F2, type konsole  press enter)
Use the command: su -
(Type root password to become root)

Run 'drakedm'  to check which display manager you are using
[The rest of this assumes you're currently using MdkKDM or KDM]

Go back to the terminal...
cd /usr/share/config/kdm

Now open the file named "kdmrc" in a text editor

Find and change the line in the [X-*-Core section] that reads:
AllowRootLogin=false

to
AllowRootLogin=true

Now, once you've made those changes you need to restart the display manager...
Note: if you made an error in editing the configuration file it may not start back up,
so be sure you have installed and know how to use a text editor that you can start
and use in a terminal/console  (Nano or Emacs, for example)

In any case...
One command that will do that is:  service dm restart
0
 
LVL 1

Assisted Solution

by:Darrell Thomas
Darrell Thomas earned 200 total points
ID: 12091124
I just had the EXACT same problem.  Here is how I fixed it:

Login as yourself.  (use the KDE desktop so you can follow along here)

Click on "the star" in the lower left corner to bring up the menu:
go to SYSTEM
go to CONFIGURATION
go to KDE
go to SYSTEM
go to LOGIN MANAGER

this brings up the Configuration-Login Manager window
click on the 4th tab over-- USERS
un-check the box in the Hidden Users menu that says "root"

Logout, and now ROOT is an option at login

:)


0
 

Author Comment

by:dissolved
ID: 12092100
thanks
0

Featured Post

Get your Conversational Ransomware Defense e‑book

This e-book gives you an insight into the ransomware threat and reviews the fundamentals of top-notch ransomware preparedness and recovery. To help you protect yourself and your organization. The initial infection may be inevitable, so the best protection is to be fully prepared.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

SSH (Secure Shell) - Tips and Tricks As you all know SSH(Secure Shell) is a network protocol, which we use to access/transfer files securely between two networked devices. SSH was actually designed as a replacement for insecure protocols that sen…
This article will explain how to establish a SSH connection to Ubuntu through the firewall and using a different port other then 22. I have set up a Ubuntu virtual machine in Virtualbox and I am running a Windows 7 workstation. From the Ubuntu vi…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial
Suggested Courses

927 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question