Solved

XP Remote - access more than one station in LAN

Posted on 2004-09-17
34
410 Views
Last Modified: 2008-02-01
We have 5 different stations in our network. I access one via Windows XP Remote. I opened port 3389 for station 1. I tried opening port 3390 for station 2 (providing the internal ip address of station 2) but  I am unable to connect to the station.

I get the standard dialog box - The client could not connect to the remote computer. Remote connections might not be enabled or the cr might be too busy to accept new connections. It is ....

Need suggestions on how to enable station 2 for xp remote while retaining access to station 1.

tx
0
Comment
Question by:moranassoc
  • 15
  • 10
  • 4
  • +4
34 Comments
 
LVL 6

Expert Comment

by:cwkhang
ID: 12089953
how about using dameware - http://www.dameware.com/, tightvnc - http://tightvnc.com/ or realvnc - http://realvnc.com/.. the configuration of these vnc is easy. i personally dun like xp remote. for open port..if u are using 5 stations, juz open in range of 5900 to 5905. (example, i use realvnc). the best thing is u can control more than 1 station at the same time.
0
 

Author Comment

by:moranassoc
ID: 12089969
thank you for the above but it doesn't address the question i posted.
0
 

Expert Comment

by:Dinq
ID: 12090307
On station 2 make sure you have turned on Remote Access.

RightClick My Computer->Properties->Remote
Check - "Allow Users to connect remotely to this computer"

Also check firewall on Station 2 to make sure you can get into it from the network.

The Remote service that XP uses should all be coming in on the same port, but if you have the IP address, that's how things get routed to the right PC.

G'Luck

Dinq

PS: You could also take remote control of station 1, and then use station 1 to take control of station 2.  Not ideal, and it's a bit of a slower way since it uses so much more resources along the "daisy chain" of stations, but it does work.
0
 

Expert Comment

by:Dinq
ID: 12090317
Additionally, if you are talking about a truly remote access situation, like the 5 PCs are at work and you are trying to control them from home, then you will have to be more creative on your company's firewall.

You will have to forward port 3389 requests based on destination IP address.

EX: 5 PCs on an internal network behind the company firewall might have IPs like
192.168.10.1
192.168.10.2
192.168.10.3
192.168.10.4 and
192.168.10.5

Your firewall will have to be set up to pass the XP Remote traffic based on port number AND destination IP address, just opening the port wide open won't do it because it won't know to which machine to send the XP Remote traffic.

If this is the case, post details and I'll try to be more specific.

G'Luck

Dinq
0
 

Expert Comment

by:sheziasn
ID: 12090824
i think this question should have been posted in the "network" section

regards,
0
 
LVL 10

Expert Comment

by:jayca
ID: 12092225
You need to dload the Sever 2003 TS client, it allows you to have up to 8 open sessions and it seperates them on tabs, you can switch between windows very quickly and is what will need.
0
 

Author Comment

by:moranassoc
ID: 12092547
i believe my inquiry is specific to the ms xp remote feature. though, i am not an IT person so perhaps this type of issue pertains to all types of remote access software, thus posted in the network section.

nevetheless, i opened port 3389 for several ip addresses and this does not work.

sorry, but i made an error in describing the setup... the network is peer to peer only, there is no server. we also do not have a single firewall for all the stations. just one dsl modem, one router to which all the stations are connected.

the other stations are configured to allow remote access since i had been using the "daisy chain" (as described above) method of accessing the other stations for a few months now... its just too slow though and i do not want to allow others to access my station to enable them to access their's, thus, i posted my initial inquiry.

i hope the additional clarification on the setup will be of help. i didn't realize this issue would be so complex.

tx
0
 
LVL 2

Expert Comment

by:Maliy
ID: 12103329
if you are trying to access the 5 computers in your workgroup within the workgroup then you don't need to open any ports or do anything at all.  All you do is go to your remote access type in the other computer name or the internal ip and you will be fine.  If you are trying to access the computers from the outside thats a different story, you will need to change the settings on remote feature in every computer to a diff port, all of them have to be different so your computer one can be 3389 computer two 3390 etc.. and then when you access it from outside you have to specify the external ip of your office and the port number of that computer, that will get you in from the outside to your inside workgroup.
0
 

Author Comment

by:moranassoc
ID: 12105409
As mentioned in my initial question, opened port 3390 and assigned station 2 to this port and still unable to access.
0
 
LVL 2

Expert Comment

by:Maliy
ID: 12105826
are u connecting from within the network or outside the network?
0
 

Author Comment

by:moranassoc
ID: 12106186
outside.
0
 
LVL 2

Expert Comment

by:Maliy
ID: 12106704
ok what you will have to do is connect to your ouside ip and then use ":" and the port number.  So if you r connecting from your house to your office network its gonna be something like this:   204.155.24.44:3390 don't confuse it with internal IP u have to use external and by putting the port it will redirect to right computer on the network.  Take a look here http://www.petri.co.il/use_rdp_client_to_connect_to_a_different_port.htm
0
 

Author Comment

by:moranassoc
ID: 12106766
I originally did what you instruct above (from original question: -> I tried opening port 3390 for station 2 (providing the internal ip address of station 2) but  I am unable to connect to the station.)

and this is where my problem occurs. I have already configured for a different port and used the correct external ip plus port (as in your example), but continue to receive the prompt mentioned in my orig. question.


0
 
LVL 2

Expert Comment

by:Maliy
ID: 12106828
Few things you can try, from your office try using the internal ip and port number to connect to other machines within the workgroup.  If that doesn't work try assigning a diff port like 3345?
Let me summerize the procedures
first go on station 2 and change the RDP listening port look how to do it here http://www.petri.co.il/change_terminal_server_listening_port.htm
then open that port for that internal ip in your router
then try internal ip when you are in the office with ":" and port number if that works try external with ":" and port number
0
 

Expert Comment

by:Dinq
ID: 12106841
Mailiy is on the right track, and yes, thanks for more info on the setup.

Your DSL modem/router will have an outside ip.

You should use this IP each time to connect to your internal machines, just like Maliy says, but with the different port numbers associated.

You need to go one step further though, and instead of just "opening up" port 3390 for station 2, you need to configure your router to do "port forwarding" to station 2.

Check your router user manual to figure that out, but it should be fairly simple.

What you will end up with is 5 different ports for 5 different stations, and your connections from outside to inside will look something like this:

123.12.23.34:3389 (using your dsl outside ip and port 3389 points to station 1)
123.12.23.34:3390 (using your dsl outside ip and port 3390 points to station 2)
123.12.23.34:3391 (using your dsl outside ip and port 3391 points to station 3)
123.12.23.34:3392 (using your dsl outside ip and port 3392 points to station 4)
123.12.23.34:3393 (using your dsl outside ip and port 3393 points to station 5)

What you're really doing from your house is connecting to your router, and you have to set your router up to be smart enough to route your traffic to the right machine on the work network.

So to recap, 3 quick steps:
1: configure port forwarding on 5 ports for your 5 workstations
2: make sure firewall will allow traffic on those 5 ports
3: use XP Remote like normal, but add the :port   part to your work's IP address

Hope this helps

Dinq

0
 

Author Comment

by:moranassoc
ID: 12106855
ok. i had simply use the router to direct that port to station 2. your instructions above seem to be more involved than what i have been doing. i will give it a try and see what happens.

tx
0
 
LVL 2

Expert Comment

by:Maliy
ID: 12106891
mora i think u might be forgetting the step of configuring each machine's RDP to a diff port from default port, its a step that involves registry editing check my post on top that link shows how to do it.
0
Complete Microsoft Windows PC® & Mac Backup

Backup and recovery solutions to protect all your PCs & Mac– on-premises or in remote locations. Acronis backs up entire PC or Mac with patented reliable disk imaging technology and you will be able to restore workstations to a new, dissimilar hardware in minutes.

 

Author Comment

by:moranassoc
ID: 12107030
from within the office, using both the internal ip and port does not work, though it works WITHOUT the port - e.g. 192.168.1.15.

isn't adding a port in the router "forwarding" tab/section sufficient? the download utility RDP 5.2 appears to change all of the ports to another port (e.g. from 3389 to XXXX).

If i do that, then i won't ge able to get on station 1 which is using port 3380.
0
 
LVL 2

Expert Comment

by:Maliy
ID: 12107095
U have to do the port forwarding to the internal ip thats one of the steps.  You also have to change ports in RDP of each machine its a must for your procedure to work.  Think about it if you connect to 123.12.11.15:3380 your router will forward to the right machine but the Machine RDP is still set to listen the default port and it doesn't understand why are you forwarding to a different port.  The machine has to be listening to the right port in order for connection to work.

You have to do this:

Run Regedit and go to this key:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\
Control\Terminal Server\WinStations\RDP-Tcp  

Find the "PortNumber" subkey and notice the value of 00000D3D, hex for (3389). Modify the port number in Hex and save the new value. ( you can switch to decimal to clearly see the number)

Try it and let me know
0
 

Author Comment

by:moranassoc
ID: 12107102
yes, maily, i believe that is what the problem may be. i am giving that a try right now and hopefully that will resolve the problem.
tx
0
 

Author Comment

by:moranassoc
ID: 12107222
well, i tried everything mentioned above. i changed the reg key to the new port. i tried using 3390, 3345, 3350 just to see if 3390 was the problem. for each change, i made all of the corresponding changes - port forwarding and TS port when accessing. still unable to access.

if i use 3389 though, i can access station 2... which of course, means, i am unable to access station 1.
0
 
LVL 2

Expert Comment

by:Maliy
ID: 12107722
It didn't work internaly and externaly? are you using DHCP for those 5 machines? or u manually asign them ip? are they all winxp?
0
 

Author Comment

by:moranassoc
ID: 12107939
it didn't work internally when i used the port as part of the computer name -> e.g. 192.168.1.1:3390.

Using just the internal IP worked.

Externally, neither works.

the external ip is assigned. internal, is not manually assigned. both machines are on winxp.

i had been accessing remotely station 2 previously since it was my primary computer. i added a new station (#1) and designated it as my primary computer and now accessing it remotely. my problem arose since the user of #2 requested permission to access his station remotely.
0
 
LVL 2

Expert Comment

by:Maliy
ID: 12108105
are u certain that you got the right internal ips for each machine? can you ping them?
0
 

Author Comment

by:moranassoc
ID: 12108272
i am positive i have the correct internal ip since i used it to remotely access #2.
0
 
LVL 2

Expert Comment

by:hattmardy
ID: 12115120
Still sounds like you haven't changed the Remote Desktop listening port. There are 2 ways around this. As mentioned previously you can change the registry key for the RDP  port http://www.petri.co.il/change_terminal_server_listening_port.htm.
Another way around it is if your router has an option to forward an outside port to a different inside port. In your router's port forwarding options, do you have the option to specify an external port and an internal port? If so you can set up all 5 machines like this:

Local IP                         External Port          Internal Port
192.168.1.1                           3385                       3389
192.168.1.2                           3386                       3389
192.168.1.3                           3387                       3389
192.168.1.4                           3388                       3389
192.168.1.5                           3389                       3389

Does this make sense?
0
 
LVL 2

Expert Comment

by:hattmardy
ID: 12115136
BTW, if you want to connect to 192.168.1.1 and your outside ip is 66.88.99.44, in the remote desktop client you would type 66.88.99.44:3385
0
 

Expert Comment

by:Dinq
ID: 12118061
Ok. I'm a bit more clear on the situation now.

hattmardy hit the nail on the head.  If this doesn't work, I'm unsure of the answer.

Good call hattmardy!

(I was oversimplifying it in my head cuz I'm on a secure tunnel VPN from work-to-home all the time)

Sorry.

Dinq
0
 

Author Comment

by:moranassoc
ID: 12130260
My router does not have the option of forwarding from an outside port to an inside port.

I changed the listening port per the instructions provided in the link by going to the registry and changed the corresponding ports accordingly.

i'm not really sure what else to do this at this point.

tx for all of your assistance.
0
 
LVL 2

Expert Comment

by:Maliy
ID: 12133118
what kind of router you have?
0
 

Author Comment

by:moranassoc
ID: 12133574
Linksys BEFSR11
0
 
LVL 2

Accepted Solution

by:
Maliy earned 500 total points
ID: 12134273
the registry edit should be fine for this purpose, u don't need the external to internal port forwarding.  The only thing i could think off is that something in the router u didn't setup properly.  Double check to make sure all of your computers internal ip's match the list on the router that you are forwarding too.  Do Start---run---cmd and type ipconfig /all take a look at the ip of that computer and make sure that you specify the right port for that ip in both registry and router.  Then restart that computer and also restart the router and try connecting again.  Also i suggest for your purpose is that u do not use DHCP (automatic assigning of ips from the router to your 5 machines)  I suggest u go into network properties (right click on my network places ---- properties----right click on local area connetion click properties----TCP/IP settings) and configure ip manualy so that way u know for sure that thats the ip of the computer.  If your router ip is 192.168.1.1 you can make the ip for the computer 192.168.1.10 and make sure to have 192.168.1.1 as ur default gateway and DNS.
0
 

Author Comment

by:moranassoc
ID: 12135368
tx for the detailed instxns. i will give it a try today.
0
 

Author Comment

by:moranassoc
ID: 12176933
i think rebooting was required after the registry change of the port. i'm now able to access. thaks very much for all of your help. i was ready to give up and sign everyone up for gotomypc.
0

Featured Post

Highfive + Dolby Voice = No More Audio Complaints!

Poor audio quality is one of the top reasons people don’t use video conferencing. Get the crispest, clearest audio powered by Dolby Voice in every meeting. Highfive and Dolby Voice deliver the best video conferencing and audio experience for every meeting and every room.

Join & Write a Comment

This article shows how to convert a multi-page PDF file into multiple image files, with one image file created for each page of the PDF. It does this by utilizing an excellent, free software package called GraphicsMagick. The solution is amazingly s…
A high-level exploration of how our ever-increasing access to information has changed the way we do our jobs.
This video demonstrates basic masking and how to edit the mask to reveal the desired image.
The viewer will learn how to successfully create a multiboot device using the SARDU utility on Windows 7. Start the SARDU utility: Change the image directory to wherever you store your ISOs, this will prevent you from having 2 copies of an ISO wit…

706 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

21 Experts available now in Live!

Get 1:1 Help Now