Error: Cannot find Master-Browser and Unknown Node Type

I installed Netgear 814 route to daughter's xp desktop and xp laptop and networking perfectly, including print/file sharing.  Desktop connected to router, laptop is wireless.  

I also installed Netgear 814 router to my own xp desktop and xp laptop.  Can access internet but cannot network.  Desktop says:  Browser-master not found--you may not have access......    The laptop says it has become master-browser.  Laptop can view itself and desktop.  The daughter's network is example only as are one mile apart so, no conflicts, etc.

Doing ipconfig /all on my daughters two xp Pc's and mine--the only different settings in the four is that my desktop shows node type as "unknown"--the others showed "hybrid".

When I went into registry, there was no node type entry listing at all.  I then added the Node Type per MS instructions, using "8" for hybrid.  None of the PC's use Wins proxy.

Despite adding the Node type, ipconfig /all still shows "Unknown". Configured NetBios over tcp and browser started. No firewall.

Is Master-Browser message on desktop related to the node message?   How do I get my PC to accept node type and solve the browser problem?
Pmiller9757Asked:
Who is Participating?
 
ndy78Connect With a Mentor Commented:
Try to manually map the ip adresses to netbios names using the windows\system32\drivers\etc\hosts file.

ie:
127.0.0.1 localhost
192.168.0.1 myPC

Type nbtstat -a and look for an entry that looks like this:
..__MSBROWSE__.<01>  GROUP       Registered

this tells you who is the master browser.

Type nbtstat -c to see what is in the browser cache.
Then ping (computer) or \\(computer) and see what has been resolved.
Try nbtstat -R to reload the cache.

0
 
adamdrayerCommented:
quick note:

"%system32%\drivers\etc\hosts" statically maps DNS hostnames and/or FQDNs.  

Depending on the Node Type, browsing usually requires NetBIOS name resolution as you have mentioned.  Static NetBIOS mappings are done in "%system32%\drivers|etc\lmhosts"
0
Cloud Class® Course: Microsoft Windows 7 Basic

This introductory course to Windows 7 environment will teach you about working with the Windows operating system. You will learn about basic functions including start menu; the desktop; managing files, folders, and libraries.

 
ndy78Commented:
quick answer:

windows doesn't care where you put netbios computer name mappings as far as you don't use dns names in a lmhosts file. But, of course, you are perfectly right that the lmhosts file is the destined place to do these changes.
0
 
ndy78Commented:
You can select the node type manually by changing the registry. Could you check what stands in there and post it? I suggest using 1 for broadcast-node.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Netbt\Parameters

Value Type: REG_DWORD - Number
Valid Range: 1,2,4,8 (b-node, p-node, m-node, h-node)
Default: 1 or 8 based on the WINS server configuration

1 = b-node (broadcasts), 2 = p-node (point-to- point name queries to a WINS server), 4 = m-node (broadcast then query name server), and 8 = h-node (query name server, then broadcast). If DNS is enabled (which also enabled LMHOSTS in Windows 95), name resolution will also follow the mode defined by this parameter. This value can also be configured using DHCP.

Also check what adamdrayer suggested:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Netbt\Parameters\

what value has EnableProxy?

I suggest switching it between 0 and 1 and see it is helping you on that matter.

Andy.
0
 
adamdrayerCommented:

>>windows doesn't care where you put netbios computer name mappings
"NetBIOS" mappings are in LMHOSTS.  In my experience, computer browsing does not usually work without WINS or LMHOSTS- regardless of whether you have DNS and HOSTS files configured.

NetBIOS over TCP/IP Name Resolution and WINS
http://support.microsoft.com/default.aspx?scid=http://support.microsoft.com:80/support/kb/articles/Q119/4/93.asp&NoWebContent=1
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.