Mount USB Memory Stick in Fedora Core 2

Hello,

I've been searching all over the place and can't find a way to mount my USB Memory sticks.  I have one of those memory stick readers that handles more than one style of stick mounted in a floppy bay.  When I issue a ca /proc/scs/sci device I see that it is listed, but when I perform an fdisk -l /dev/sd? I don't see the drives there.  Any help would be greatly appreciated.

[root@localhost root]# cat /proc/scsi/scsi
Attached devices:
Host: scsi0 Channel: 00 Id: 00 Lun: 00
  Vendor: ATA      Model: Maxtor 6Y120M0   Rev: YAR5
  Type:   Direct-Access                    ANSI SCSI revision: 05
Host: scsi2 Channel: 00 Id: 00 Lun: 00
  Vendor: iSAVE    Model: USB Storage-SMC  Rev: 304B
  Type:   Direct-Access                    ANSI SCSI revision: 02
[root@localhost root]#

aaeandceeAsked:
Who is Participating?
 
jlevieConnect With a Mentor Commented:
I understand now. What you have are Compact Flash cards and a USB flash reader. What make/model reader and what cameras?
0
 
jlevieCommented:
Do you see something along the lines of:

hub.c: new USB device 10:18.0-1, assigned address 2
scsi1 : SCSI emulation for USB Mass Storage devices
  Vendor: NEUROS    Model: dig. audio comp.  Rev: 1.00
  Type:   Direct-Access                      ANSI SCSI revision: 02
Attached scsi removable disk sda at scsi1, channel 0, id 0, lun 0
SCSI device sda: 39070048 512-byte hdwr sectors (20004 MB)
sda: test WP failed, assume Write Enabled
 /dev/scsi/host1/bus0/target0/lun0: p1
WARNING: USB Mass Storage data integrity not assured
USB Mass Storage device found at 2

in the output of dmesg after you insert the memory stick? If the device is recognized as a storage device you'll see the SCSI emulation device specified (/dev/sda in this example). If the memory stick emulates a DOS file system (typical) you could mount it with something similar to:

mkdir /mnt/mem-stick
mount -t vfat -o umask=0 /dev/sda1 /mnt/mem-stick

or add:

/dev/sda1 /mnt/mem-stick vfat user,noauto,umask=0    0 0

to /etc/fstab to allow ordinary users to mount the device (e.g., mount /mnt/mem-stick).
0
 
aaeandceeAuthor Commented:
Hi,
When I execute the dmesg I get the following:

Initializing USB Mass Storage driver...
scsi2 : SCSI emulation for USB Mass Storage devices
  Vendor: iSAVE     Model: USB Storage-SMC   Rev: 304B
  Type:   Direct-Access                      ANSI SCSI revision: 02
Attached scsi removable disk sdb at scsi2, channel 0, id 0, lun 0
USB Mass Storage device found at 3
usbcore: registered new driver usb-storage
USB Mass Storage support registered.

I am assuming that it is on sdb, but when I execute the mount command all I get is:

mount -t vfat -o unmask=0 /dev/sdb /mnt/usb1
mount: No medium found

I have treid sdb1 through 4, but nothing.

0
Cloud Class® Course: C++ 11 Fundamentals

This course will introduce you to C++ 11 and teach you about syntax fundamentals.

 
jlevieCommented:
Can you do a 'mkdosfs /dev/sdb1'? Maybe it just doesn't have a file system on the device.

If that doesn't work I'd consider the possibility that your stick reader or the memory stick isn't Linux compatible. The question seems to indicate that these are USB sticks. Do they work via a USB cable (not using the adapter)?
0
 
aaeandceeAuthor Commented:
I was able to copy the pictures over having the digital camera connected to a USB port, but that kills the batteries.  I also have more than one camera, and the each use a different style of memory stick.

I was really hoping to get this device working, as Linux does detect it as a second SCSI interface.
0
 
aaeandceeAuthor Commented:
My flash reader is an iSave, but I am not about which model.  It can handle the Compact Flash, Smart Media, MMC and Memory Stick.   The manual for it references  the following for installation:

My camera is a Nikon Coolpix 3200, which I can get to recognize just fine via the USB.

/*** Installation guide for Linux ***/

 This document was modified from "http://www.linux-usb.org/USB-guide/book1.html" which was written by Brad Hards.

 System Requirement:

1. kernel versions 2.2.7 and later contain the USB code.

Install Card Reader step by step:

 1. configure USB into kernel. Use of "make menuconfig" is recommended.
 Under "USB support", you need to select "Support for USB". You also need to
 select either UHCI (Intel PIIX4, VIA, ...) support, UHCI Alternate Driver (JE) support
 or OHCI-HCD (Compaq, iMacs, OPTi, SiS, ALi, ...) support. Which one you select is
 dependent on what kind of motherboard or adapter you have.

2. select "USB Mass Storage support"

3. select "Preliminary USB Device Filesystem"

4. select "SCSI support"

5. selct "SCSI disk support"

6. select "/proc support"

7. Rebuild the kernel and the modules (if you configured to build as modules),
 and install the new kernel and the new modules. Reboot the system.
 If you are using modules, you need to load the following modules:
   a. usbcore.o
   b. usb-uhci.o, uhci.o or usb-ohci.o
   c. usb-storage.o


   Inspect the kernel logs. If there isn't anything that could be USB related,
   likely causes are use of the wrong driver (UHCI when you needed OHCI or
   OHCI when you needed UHCI), not physically installing the hardware,
   a BIOS configuration that disables USB or stuffing up the configuration or
   installation of the kernel.

8. Use the mount command: mount -t usbdevfs none /proc/bus/usb.
   Note that the 'none' keyword is arbitrary.

   If you do not want to have to mount the filesystem each time you reboot the system,
   you can add the following to /etc/fstab after the /proc entry.

   none            /proc/bus/usb             usbdevfs        defaults   0   0

9. Edit /etc/fstab
   The exact syntax depends on the Card Reader. The best way is to make suitable entries
   in /etc/fstab. The suitable entries for Card Reader would be:

   /dev/sda    /mnt/SMC       auto            noauto,user 0   0
   /dev/sdb    /mnt/CFC       auto            noauto,user 0   0
   /dev/sdc    /mnt/SDC       auto            noauto,user 0   0
   /dev/sdd    /mnt/MSC       auto            noauto,user 0   0

10. Create matching mount points in the actual filesystem:

   mkdir /mnt/SMC
   mkdir /mnt/CFC
   mkdir /mnt/SDC
   mkdir /mnt/MSC

 11. Mount Card Reader:

   mount /dev/sda
   mount /dev/sdb
   mount /dev/sdc
   mount /dev/sdd

 I brought up Xconfig, but couldn't find references to most of the items above.
0
 
aaeandceeAuthor Commented:
I was able to resolve the issue.  When recompiling the kernel one must choose the SCSI option to probe the LUNs.  After doing this my various flash cards were detected.
0
 
jlevieCommented:
Okay, that makes sense. The flash reader is identifing itself as a mass storage device and the flash cards, when inserted, show up as LUN's of the device.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.