using xcopy and \exclude

well i thought this was working but i just saw a bunch of files from 'system volume information' scrolling across my screen as they copied so i guess not.  i saw a thread that seems to imply i need to use 8.3 style folder names but i saw a reference on the ms site saying it will use an absolute reference for a folder.  altho i would like to use relative names so this will work on any drive.

i have a batch file that is copying my c: drive to another drive for temporary backup.  i have created an exclude list of things to NOT copy.  it seems the exclude is having problems.  any ideas on what i am doing wrong?  thanks.  jim

*************************
bakc is in c:\bin   so is xf.txt

bakc.bat  -->>  xcopy c:\* n:\NewFolderc\   /e /s /y /d /c /i /h /exclude:xf.txt

xf.txt (below)
zgpt*
\recycler
\windows
\winxp
\temp
"\system volume information"
"system volume information"
pagefile.sys
hyb*.sys
\wutemp\
\i386
LVL 1
jsturtzAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

mrwad99Commented:
A few points I noticed:

You have the switches: /e /s

  /S           Copies directories and subdirectories except empty ones.
  /E           Copies directories and subdirectories, including empty ones.

Now, one or the other is best here, but not both :)

Also /D

  /D:m-d-y     Copies files changed on or after the specified date.
               If no date is given, copies only those files whose
               source time is newer than the destination time.

I don't think you need this really.

>> "\system volume information"

Should be

"\system volume information\"

("/EXCLUDE:file1[+file2][+file3]...
               Specifies a list of files containing strings.  When any of the
               strings match any part of the absolute path of the file to be
               copied, that file will be excluded from being copied.  For
               example, specifying a string like \obj\ or .obj will exclude
               all files underneath the directory obj or all files with the
               .obj extension respectively."

Those changes should bring some improvement.

HTT
0
cupawntaeCommented:
You have two main problems here:

1 - the strings are not wildcard patterns so hib*.sys is not going to work - you'll need to mention each file by name for this kind of pattern. For the simpler "something beginning with xxxx" pattern, just leave out the '*' - take zgpt* for example: the line should simply be:

zgpt

(no '*')

2 (and this is the important one) - you don't need (and shouldn't use) quotes - so "\system volume information" should be:

\System Volume Information

(no quotes). You can put in the second backslash as suggested above but all this will do is make sure it doesn't accidentally exclude files called something like "\mydir\system volume informations" - this won't solve your problem.

Basically for each exclude to work, the string has to be part of the full filename, verbatim...

Hope that helps,

CupawnTae
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
jsturtzAuthor Commented:
mrwad99
i tried using "\system volume information\" twice, as opposed to CupawnTae's suggestion of \System Volume Information.  the quotes marks interfere with the exclusion.

i again tried the /d option and confirmed my reasoning for it.  w/o the /d the entire directory is copied over everytime one uses xcopy, with the /d then only changed stuff since last time get copied.  that is the behavior i am looking for.

thanks to both of you for your replies.

give the points to CupawnTae
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Programming

From novice to tech pro — start learning today.