Solved

unable to access owa externally

Posted on 2004-09-19
2
353 Views
Last Modified: 2008-02-20
I am able to access email through my owa client sitting on my local network but only by the local ip address.  Not sure why, but I can't access the site by name nor can I access the site externally by public IP.  I have checked everything. My external DNS records are correct, I can resolve the name to the correct ip address and my firewall is open on port 443 as needed.  I'm not an IIS person, but everything is pointing to it as the problem.  How does IIS advertise itself?  How does the firewall know that https requests need to go to the exchange server?
0
Comment
Question by:sunny10
2 Comments
 
LVL 104

Accepted Solution

by:
Sembee earned 125 total points
ID: 12102410
IIS doesn't annouce  itself, you have to send the traffic to it.

First - the internal and external DNS records need to be different.
Internally you need your clients to look at the internal IP address of the Exchagne server. This is achieved by adjustign the DNS as required.
If you are using a generic name for OWA (mail.domain.com for example) but the server is called something else (server1.domain.com) then add an additional entry in to your local DNS for mail.domain.com and point it at the IP address of the Exchange/OWA server.

Externally the clients need to be pointing at the external IP address of your connection. If you have mutiple IP addresses then it needs to be the one assigned to the Exchange/OWA server.

This is known as split DNS.

Confirm that it is working as you like internally, and then move forwards to get external to work.

Next. Your firewall.
You are probably using NAT/Port Forwarding. Configure the firewall to forward requests on port 443 received on the relevant external IP address to the internal IP address of your Exchange/OWA server.
You haven't said which firewall you are using, but if you have already setup forwarding for port 25 (SMTP) then I would just copy the configuration and change the port to 443.

Simon.
0
 

Author Comment

by:sunny10
ID: 12122738
Your line of questioning got me started on the right track, when I went back and checked the router I noticed that the port forwarding had been set up incorrectly.  Once I fixed the IP address everything worked.  Thanks for your help.
0

Featured Post

How to improve team productivity

Quip adds documents, spreadsheets, and tasklists to your Slack experience
- Elevate ideas to Quip docs
- Share Quip docs in Slack
- Get notified of changes to your docs
- Available on iOS/Android/Desktop/Web
- Online/Offline

Join & Write a Comment

Suggested Solutions

Disabling the Directory Sync Service Account in Office 365 will stop directory synchronization from working.
Not sure what the best email signature size is? Are you worried about email signature image size? Follow this best practice guide.
In this video we show how to create a Contact in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >> Contact ta…
To add imagery to an HTML email signature, you have two options available to you. You can either add a logo/image by embedding it directly into the signature or hosting it externally and linking to it. The vast majority of email clients display l…

705 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now