Solved

PIX501 HTTPS Port redirect

Posted on 2004-09-20
14
246 Views
Last Modified: 2010-04-09
Hello,
I want to alllows users to view Outlook Web Access from any external host over https.

My outlook web acccess is on internal host 10.0.0.10, my PIX inside interface is 10.0.0.250

I've using access-list, static translation and groups but I can't seem to figure it out.

Pleas help
0
Comment
Question by:Flexology
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 8
  • 5
14 Comments
 
LVL 79

Expert Comment

by:lrmoore
ID: 12100891
Are you using the interface IP?
You must disable http on the pix
clear http  <--Removes all HTTP hosts and disables the server.

This will prevent you from ever using the PDM GUI

Else, post your config and I can troubleshoot for you.
0
 

Author Comment

by:Flexology
ID: 12103764
I like using the PDM. Can I not keep it and still use redirects e.g.

Outside World > PIX501 > Internal Network
0
 

Author Comment

by:Flexology
ID: 12104036
I've tried..
static (inside, outside) tcp interface 443 10.0.0.10 443

and

static (outside, inside) tcp interface 443 10.0.0.10 443
0
Now Available: Firebox Cloud for AWS and FireboxV

Firebox Cloud brings the protection of WatchGuard’s leading Firebox UTM appliances to public cloud environments. It enables organizations to extend their security perimeter to protect business-critical assets in Amazon Web Services (AWS).

 
LVL 79

Expert Comment

by:lrmoore
ID: 12104147
>Can I not keep it and still use redirects e.g.

Absolutely not! As long as it is enabled, all interfaces will "listen" on port 443, so you can't redirect it to another host and still use it on the PIX.

The correct command would be:
static (inside,outside) tcp interface 443 10.0.0.10 443

0
 

Author Comment

by:Flexology
ID: 12149797
Sorry for the delay in replying. I did

static (inside,outside) tcp interface 443 10.0.0.10 443
clear http

But still no joy....
0
 

Author Comment

by:Flexology
ID: 12149800
Sorry other way round

clear http
static (inside,outside) tcp interface 443 10.0.0.10 443
0
 
LVL 2

Expert Comment

by:parbul
ID: 12210570
Don´t forget

the default router in your web server
the  clear  xlate  command  (if you also have others nat o global commands)

Can you wirte the access-list what you configured ?

0
 

Author Comment

by:Flexology
ID: 12221135
No laughing....... I've xxxx'd out the bits that I don't want everyone to see.PIX Version 6.3(3)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password xxxx encrypted
passwd xxx encrypted
hostname fw1
domain-name xxxx.local
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol pptp 1723
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
name 10.0.0.11 MARGE
name 10.0.0.10 HOMER
access-list inside_outbound_nat0_acl permit ip any 10.0.0.144 255.255.255.240
access-list inside_outbound_nat0_acl permit ip interface inside interface outside
access-list outside_cryptomap_20 permit ip interface inside interface outside
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside dhcp setroute
ip address inside 10.0.0.250 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool VPN 10.0.0.150-10.0.0.155
pdm location 10.0.0.144 255.255.255.240 outside
pdm location 192.168.5.2 255.255.255.255 outside
pdm location HOMER 255.255.255.255 inside
pdm location 10.0.0.0 255.255.255.255 inside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_outbound_nat0_acl
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) tcp interface https HOMER https netmask 255.255.255.255 0 0
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
sysopt connection permit-pptp
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto map outside_map 20 ipsec-isakmp
crypto map outside_map 20 match address outside_cryptomap_20
crypto map outside_map 20 set peer 213.78.34.158
crypto map outside_map 20 set transform-set ESP-3DES-MD5
crypto map outside_map interface outside
isakmp enable outside
isakmp key ******** address xxxxxxx netmask 255.255.255.255 no-xauth no-config-mode
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash md5
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
telnet 10.0.0.0 255.255.255.0 inside
telnet timeout 5
ssh timeout 5
console timeout 0
vpdn group PPTP-VPDN-GROUP accept dialin pptp
vpdn group PPTP-VPDN-GROUP ppp authentication pap
vpdn group PPTP-VPDN-GROUP ppp authentication chap
vpdn group PPTP-VPDN-GROUP ppp authentication mschap
vpdn group PPTP-VPDN-GROUP ppp encryption mppe auto
vpdn group PPTP-VPDN-GROUP client configuration address local VPN
vpdn group PPTP-VPDN-GROUP client configuration dns HOMER
vpdn group PPTP-VPDN-GROUP client configuration wins HOMER
vpdn group PPTP-VPDN-GROUP pptp echo 60
vpdn group PPTP-VPDN-GROUP client authentication local
vpdn username xxxxx password xxxxxx
vpdn enable outside
terminal width 80
Cryptochecksum:xxxxx
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 12221237
Have you tried:

access-list outside_in permit tcp any host interface outside eq https
access-group outside_in in interface outside
0
 

Author Comment

by:Flexology
ID: 12221344
Just tried it and got...

ERROR: invalid IP address interface
Usage:  [no] access-list compiled
[no] access-list deny-flow-max <n>
[no] access-list alert-interval <secs>
[no] access-list <id> compiled
[no] access-list <id> [line <line-num>] remark <text>
[no] access-list <id> [line <line-num>] deny|permit
        <protocol>|object-group <protocol_obj_grp_id>
        <sip> <smask> | interface <if_name> | object-group <network_obj_grp_id>
        [<operator> <port> [<port>] | object-group <service_obj_grp_id>]
        <dip> <dmask> | interface <if_name> | object-group <network_obj_grp_id>
        [<operator> <port> [<port>] | object-group <service_obj_grp_id>]
        [log [disable|default] | [<level>] [interval <secs>]]
[no] access-list <id> [line <line-num>] deny|permit icmp
        <sip> <smask> | interface <if_name> | object-group <network_obj_grp_id>
        <dip> <dmask> | interface <if_name> | object-group <network_obj_grp_id>
        [<icmp_type> | object-group <icmp_type_obj_grp_id>]
        [log [disable|default] | [<level>] [interval <secs>]]
Restricted ACLs for route-map use:
[no] access-list <id> deny|permit {any | <prefix> <mask> | host <address>}
0
 

Author Comment

by:Flexology
ID: 12221353
access-group outside_in in interface outside gave me.....

ERROR: access-list <outside_in> does not exist
Usage:  [no] access-group <access-list> in interface <if_name> [per-user-overrid
e]
0
 
LVL 79

Accepted Solution

by:
lrmoore earned 500 total points
ID: 12221373
My bad. Don't need the keyword "host"

PIX2(config)# access-list outside_in permit tcp any interface outside eq https
PIX2(config)# access-group outside_in in interface outside
0
 

Author Comment

by:Flexology
ID: 12221446
Nice Work......... Thanks. Spend the points wisely
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 12221506
Thanks!
0

Featured Post

Surfing Is Meant To Be Done Outdoors

Featuring its rugged IP67 compliant exterior and delivering broad, fast, and reliable Wi-Fi coverage, the AP322 is the ideal solution for the outdoors. Manage this AP with either a Firebox as a gateway controller, or with the Wi-Fi Cloud for an expanded set of management features

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Cisco ASA 5512 LAN Config 16 103
iptables ubuntu BLOCK all 2 90
cannot send E-mails to one company 15 123
Windows ADHow to restrict port 6881 bit Torrent 3 20
If you are like regular user of computer nowadays, a good bet that your home computer is on right now, all exposed to world of Internet to be exploited by somebody you do not know and you never will. Internet security issues has been getting worse d…
To setup a SonicWALL for policy based routing to be used with the Websense Content Gateway there are several steps that need to be completed. Below is a rough guide for accomplishing this. One thing of note is this guide is intended to assist in the…
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial
Are you ready to implement Active Directory best practices without reading 300+ pages? You're in luck. In this webinar hosted by Skyport Systems, you gain insight into Microsoft's latest comprehensive guide, with tips on the best and easiest way…

756 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question