Declared Package Mismatch

I have a jsp calling some java classes, and am having problems with the package import and declaration statements.  I'm using Tomcat and developing with Eclipse.  Here's my directory structure...

SubscriptionControlService       <-- project directory
---src/classes/java                  <--- Source java files here
---SCS                                   <-- html,jsp files at this level  (This is my webroot)
---SCS/WEB-INF/classes/java   <-- compiled class files automatically placed here

I am having two reported problems - one in my .java file and one in my .jsp file, but suspect they are reflections of the same problem.

Here's the package statement at the top of the java file...


The error reported is...  "the declared package does not match the expected package."

The imports at top of INDEX.jsp are...

   <%@ page import="*" %>
   <%@ page import="java.util.ArrayList,java.util.Iterator,java.util.List,java.lang.*" %>

The reported error for the first import is... "The import classes cannot be resolved"

Can someone explain why I'm getting these errors?

Who is Participating?
TimYatesConnect With a Mentor Commented:
> java tmp

You need to do:

C:\Eclipse Workspace\SCS\src\>java scsclass.tmp
<%@ page import="java.*" %>

Assuming your classes have:

    package java ;

at the top of their source files...

if not, You may need to add it in...
> Here's the package statement at the top of the java file...
>   package;


Hmmmm...  That should be

    package java ;

and as I said, just put the classes in WEB-INF/classes/java (as you are doing), and then do the page import as I said in the last comment :-)
Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

LarryAndroAuthor Commented:
In my jsp, I changed...

   <%@ page import="*" %>
   <%@ page import="java.util.ArrayList,java.util.Iterator,java.util.List,java.lang.*" %>


   <%@ page import="java.*" %>
   <%@ page import="java.util.ArrayList,java.util.Iterator,java.util.List,java.lang.*" %>

and the reported error disappeared.  But, now aren't I importing everything in Java's java subdirectory instead of my own java folder?

No matter whether the above is OK or not, I really don't like my choice of 'java' as a folder name.  So, I renamed it 'scsclass.'  The be consistent, I not have...

   <%@ page import="scsclass.*" %>
   <%@ page import="java.util.ArrayList,java.util.Iterator,java.util.List,java.lang.*" %>

in my jsp.  And, in my java source I have...

   package scsclass;

No errors occur in my java source file now.  But, I do get the following jsp error...

   The import scsclass cannot be resolved.

What do you suggest now?  Was my changing 'java' to 'scsclass' a good idea, or should I change back?

> What do you suggest now?  Was my changing 'java' to 'scsclass' a good idea, or should I change back?

Yes, it will make your code less confusing...

> aren't I importing everything in Java's java subdirectory instead of my own java folder?

You would be importing bot, but as there aren't any classes in Suns "java.*" package, you would only be importing your own classes (but it would look confusing)

> The import scsclass cannot be resolved.

You have copied your classes to:


yeah?  Try restarting tomcat...
LarryAndroAuthor Commented:
After changes, I have my original set of reported errors back.  To reduce miscommunication, here's my current setup and reported errors...

File structure...

src/scsclass                  <-- java source files
SCS                           <-- htm,jsp files
SCS/WEB-INF/classes/scsclass  <-- compiled class files here

Here's my jsp import...    <%@ page import="scsclass.*" %>
And error...               the import scsclass cannot be resolved

Here's my java package...  package scsclass;
And error...               the declared package does not match the expected package

I stopped Tomcat, stopped Eclipse, and then restarted Eclipse.  That's when I get the above errors which are reported by Eclipse.  I've never gotten to the point of starting a browser and using Tomcat server, and invoking index.jsp.  
LarryAndroAuthor Commented:
No comment from TimYates for awhile.  Anyone else around that could help me?  (I'll split points.)
Does it work when you just run tomcat (not in eclipse)?

Sounds like it could be an Eclipse classpath/packaging/project setup problem...
Try to remove cache file of Tomcat

Looking for folder like this and remove all those files and sub directory
LarryAndroAuthor Commented:
Increasing points to 500, as I think that's fair.  

TimYates suggested I try Tomcat.  When I do, when I enter http://localhost:8080/SCS/index.jsp in my browser, I get a HTTP 500 error as follows ...

type Exception report


description The server encountered an internal error () that prevented it from fulfilling this request.


org.apache.jasper.JasperException: Unable to compile class for JSP

An error occurred at line: 34 in the jsp file: /index.jsp

Generated servlet error:
    [javac] Compiling 1 source file

C:\Tomcat\work\Catalina\localhost\SCS\org\apache\jsp\ package scsclass does not exist
import scsclass.*;
C:\Tomcat\work\Catalina\localhost\SCS\org\apache\jsp\ cannot resolve symbol
symbol  : class SCSDAL
location: class org.apache.jsp.index_jsp
            SCSDAL dal=new SCSDAL("");

sompol_kiatkamolchai, I deleted the %TOMCAT_HOME%\work\Catalina\localhost files\SCS before trying Tomcat.  

(I am quitting for tonight, and will read this problem for replies in the morning.)
sompol_kiatkamolchaiConnect With a Mentor Commented:
Are you sure you have this?


If so, you may delete it and re-compile it again and to make sure that you have an update version of class.

One question, before you getting this error, what have you done? Did you involve in moving package of class?
And are you sure that


    package scsclass ;

at the top of it?
LarryAndroAuthor Commented:
Sompol...  you were right; I had classes under WEB-INF/classes/ instead of WEB-INF/classes/scsclass.
                (I had my output folder set wrong in the project parameters.  Fixed now.  Problems remain.)

TimYates...  Yes, has 'package scsclass;' at the top.


I just discovered that I have a very basic problem...  I can't compile java programs!  I haven't had this problem before. So, I think my classpath has become corrupted.  However, when I set the classpath the problem remains.  (I'm not sure I understand classpath.)  If you guys will help me thru this issue, I suspect my other issues will be resolved also.  (But, should you think I'm sidetracking the troubleshooting process, let me know.)

Before describing my "basic problem", here some background that was asked for.  On my project, I was using Eclipse and these java files were working fine.  Then, I was told to switch to BEA Weblogic Workshop (WLW), which I did, after which the java classes worked also.  Then, I was told to convert back to Eclipse.  (Arrrgh!!!)    So, I created a new Eclipse project and imported the resources into Eclipse.  That's when the problems with previously running java classes occurred.

Here's my "basic problem"...

Here's the simplest ever java file,, which I created in my C:\Eclipse Workspace\SCS\src\scsclass source folder...

   package scsclass;
   public class tmp
       public static void main(String[] args)


It has a main, but does nothing.  And, it seems to compile OK.  But, when I try to run it, I get the following error.

   C:\Eclipse Workspace\SCS\src\scsclass>java tmp

   Exception in thread "main" java.lang.NoClassDefFoundError: tmp (wrong name: scsclass/tmp)
        at java.lang.ClassLoader.defineClass0(Native Method)
        at java.lang.ClassLoader.defineClass(Unknown Source)
        at Source)
        at Source)
        at$100(Unknown Source)
        at$ Source)
        at Method)
        at Source)
        at java.lang.ClassLoader.loadClass(Unknown Source)
        at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
        at java.lang.ClassLoader.loadClass(Unknown Source)
        at java.lang.ClassLoader.loadClassInternal(Unknown Source)

Here's my classpath...


Which I reset to...

   CLASSPATH=.;C:\Eclipse Workspace\SCS\webroot\WEB-INF\classes\scsclass;C:\Eclipse

After which I get the same error.  What should my classpath be?

LarryAndroAuthor Commented:
The 'java scsclass.tmp' approach you suggested worked, and I could run tmp.class.  But, I still have some compilation problems.  TimYates, out of fairness to you, I think I should comprehensively review my java compilation environment before taking more of your time.  Obviously, something is hosed down!  I'll be back shortly.  
LarryAndroAuthor Commented:
I'm closing this call down.  My problem is not solved, but I'm confident it is related to my Java installation, classpath, etc.  Thanks TimYates for helping me, and also sompol.  (I think I wasted your time.)  When I get my installation working, (and I've been sidetracked by other matters), if I still have problems I will start another call.  Thank you...
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.