Solved

PIX 501 VPN with VPN CLIENT 4.0.3 ISSUE!

Posted on 2004-09-20
6
202 Views
Last Modified: 2013-11-16
After establishing VPN connection I CANNOT connect nor access private site of my LAN or ping my server behind the pix 501 device.  I can connect to the VPN and receive an IP address assigned from my vpn pool.  How can i get the local LAN or server remote vpn access to work from my dial-up connection? Is there something wrong with my pix config below?

Any help greatly appreciated, please see my current config below:
Thanks!

Current Pix configuration:
================
Password: *******
home# show config
: Saved
: Written by enable_15 at 10:52:49.353 PDT Sun Sep 19 2004
PIX Version 6.3(1)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password xxxxxxxxxxxxxxxxxxxxxxxxx
passwd xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
hostname home
domain-name ciscopix.com
clock timezone PST -8
clock summer-time PDT recurring
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol ils 389
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
names
access-list inside_outbound_nat0_acl permit ip 192.168.0.0 255.255.255.0 192.168.1.0 255.255.255.0
access-list split permit ip 192.168.0.0 255.255.255.0 any
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside 69.107.255.x 255.255.255.x
ip address inside 192.168.5.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool VPN-IP-POOL 192.168.1.1-192.168.1.254
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
route outside 0.0.0.0 0.0.0.0 69.107.x.x 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
http server enable
http x.x.x.x x.x.x.x inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
isakmp enable outside
isakmp nat-traversal 20
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash md5
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
vpngroup MYVPN address-pool VPN-IP-POOL
vpngroup MYVPN dns-server 192.x.x.x 206.13.30.12
vpngroup MYVPN wins-server 192.168.x.x
vpngroup MYVPN default-domain xxxxxx.local
vpngroup MYVPN split-tunnel split
vpngroup MYVPN idle-time 1800
vpngroup MYVPN password ********
telnet timeout 5
ssh timeout 5
console timeout 0
terminal width 80
Cryptochecksum:xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
home#
0
Comment
Question by:netgt
  • 3
  • 3
6 Comments
 
LVL 79

Expert Comment

by:lrmoore
ID: 12107757
Given:
>ip address inside 192.168.5.1 255.255.255.0

You need to change your nat_0 acl:
From this:

>access-list inside_outbound_nat0_acl permit ip 192.168.0.0 255.255.255.0 192.168.1.0 255.255.255.0

to this:
access-list inside_outbound_nat0_acl permit ip 192.168.5.0 255.255.255.0 192.168.1.0 255.255.255.0
                                                                                ^

Also, make sure your home LAN is not 192.168.1.x ..
0
 

Author Comment

by:netgt
ID: 12107884
lrmoore,

Thanks very much for your suggestion, but originaly i had it setup as you mentioned and i just recently changed from 5 to ->0 instead (access-list inside_outbound_nat0_acl permit ip 192.168.5.0 255.255.255.0 192.168.1.0 255.255.255.0) Even then i would have the same issue. I can change it again and will post my test results in an hour.
Thanks!
0
 
LVL 79

Assisted Solution

by:lrmoore
lrmoore earned 500 total points
ID: 12107902
Also check your split-tunnel acl:
access-list split permit ip 192.168.0.0 255.255.255.0 any

should be
access-list split permit ip 192.168.5.0 255.255.255.0 any
                                                ^
0
PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

 

Author Comment

by:netgt
ID: 12109345
Both lines have been added to my config and binded to nat 0, now when i connect via vpn i can ping my LAN  but cannot access local shares and etc.. Any suggestions?
Thanks
0
 
LVL 79

Accepted Solution

by:
lrmoore earned 500 total points
ID: 12111478
If you can ping everything you should be able to access everything. Now you may have a name resolution, permissions issue. What OS on your VPN client? What are you trying to access? Domain? Workgroup?
0
 

Author Comment

by:netgt
ID: 12119041
lrmoore, i figure out my problem and Thank you for your help! My problem was in the assigned dns to my vpn client because i changed server ip address.
im going to close out this questions and assign 500 points to your help suggestions & efforts!
0

Featured Post

Control application downtime with dependency maps

Visualize the interdependencies between application components better with Applications Manager's automated application discovery and dependency mapping feature. Resolve performance issues faster by quickly isolating problematic components.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If you are like regular user of computer nowadays, a good bet that your home computer is on right now, all exposed to world of Internet to be exploited by somebody you do not know and you never will. Internet security issues has been getting worse d…
Use of TCL script on Cisco devices:  - create file and merge it with running configuration to apply configuration changes
Both in life and business – not all partnerships are created equal. As the demand for cloud services increases, so do the number of self-proclaimed cloud partners. Asking the right questions up front in the partnership, will enable both parties …
As a trusted technology advisor to your customers you are likely getting the daily question of, ‘should I put this in the cloud?’ As customer demands for cloud services increases, companies will see a shift from traditional buying patterns to new…

867 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

22 Experts available now in Live!

Get 1:1 Help Now