Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Routrer 2500/ DSL configuration

Posted on 2004-09-20
14
Medium Priority
?
592 Views
Last Modified: 2012-06-27
Can  router 2500 be configured for DSL, If yes, how  
0
Comment
Question by:fuad2
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 4
  • 2
  • +1
14 Comments
 
LVL 43

Expert Comment

by:JFrederick29
ID: 12107773
As long as you have a DSL modem in front of the router and a 2514 router with two ethernet interfaces.  The DSL modem hands off an ethernet connection which connects to one of the ethernet interfaces on the 2514.  The other ethernet interface of the 2514 will connect to your LAN.  You then need to setup the IP addressing, NAT, and a default route to your ISP.

interface ethernet0
ip address dhcp <---interface connected to DSL modem
ip nat outside

interface ethernet1
ip address 192.168.0.1 255.255.255.0
ip nat inside

ip nat inside source list 1 interface ethernet0 overload

access-list 1 permit 192.168.0.0 0.0.0.255

ip route 0.0.0.0 0.0.0.0 ethernet0 <---or specify ISP router
0
 

Author Comment

by:fuad2
ID: 12114043
Hi JFrederick

Is rourter 2514 same as router 2500?  I have done some basic router configuration but not for DSL.  If I wanted to have four computers connected to my DSL, how do I configure for all four. I really appreciate if you explain me in detail with example

Thanks

Fuad2
0
 
LVL 11

Expert Comment

by:PennGwyn
ID: 12114179
2500 is a whole family of routers.  2514 is the model with two Ethernet interfaces.  There are a variety of other models.

You can probably find the actual model number on a label on the back of the router, or in the banner which displays when you connect to the console port.

0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 43

Accepted Solution

by:
JFrederick29 earned 1200 total points
ID: 12117825
Bottom line is you need a router with two ethernet interfaces, on the 2500 series routers they are labeled "AUI 0" and AUI 1".  You can also do a "show version" in the router to display the model.
0
 

Author Comment

by:fuad2
ID: 12138919
Hi

My problem is not to find out the model of my router, but a full configuration so that my four computers can login and  have access to my DSL modem.

Fuad2
0
 
LVL 43

Expert Comment

by:JFrederick29
ID: 12138941
We understand what you are asking but as stated previously it does matter what model of router you have.  If it is a 2501, it won't work unless you have two of them and a crossed serial cable.  If you have a 2514 router with two ethernet interfaces, my first post lays out all the necessary commands to configure the router.

What model router do you have?
0
 
LVL 1

Expert Comment

by:jverdera
ID: 12141439
fuad2,

enter into enable mode in the router and enter the following command.

cisco2501#sh version

Then the following output should  appear:

Cisco Internetwork Operating System Software
IOS (tm) 2500 Software (C2500-I-L), Version 12.2(5), RELEASE SOFTWARE (fc1)
Copyright (c) 1986-2001 by cisco Systems, Inc.
Compiled Wed 12-Sep-01 09:45 by pwade
Image text-base: 0x030482A8, data-base: 0x00001000

ROM: System Bootstrap, Version 5.2(8a), RELEASE SOFTWARE
BOOTLDR: 3000 Bootstrap Software (IGS-RXBOOT), Version 10.2(8a), RELEASE SOFTWARE (fc1)

cisco2501 uptime is 45 minutes
System returned to ROM by reload
System image file is "flash:/c2500-i-l.122-5.bin"

cisco 2500 (68030) processor (revision D) with 8192K/2048K bytes of memory.
Processor board ID 03250319, with hardware revision 00000000
Bridging software.
X.25 software, Version 3.0.0.
1 Ethernet/IEEE 802.3 interface(s) *******************
2 Serial network interface(s) ***********************
32K bytes of non-volatile configuration memory.
16384K bytes of processor board System flash (Read ONLY)

Configuration register is 0x2102

The lines with the asterisks tell you how many interfaces you have.

What do you want to do?
a) Connect the Cisco router to a DSL Router
b) Use the Cisco router to connect to your DSL line?

If you're answer is b, forget about it since the Cisco 2500 series doesn't support DSL connections.
You would have to buy another router such as the 2600 MX series or a 1700 series with DSL cappabilities (1721).

Let me know your output from the sh version in order to give you further help.
0
 

Author Comment

by:fuad2
ID: 12144790
Hi

 I am away from my router, anyhow, I have two 2500 routers.  I believe router 2500 comes  with only one ethernet interface and two serial ports.  

Thanks

Fuad2
0
 
LVL 1

Expert Comment

by:jverdera
ID: 12145986
You have then two 2501 routers, indeed. Therefore it is not possible to configure them for DSL access.
0
 
LVL 43

Expert Comment

by:JFrederick29
ID: 12147018
If you want to go to the trouble, you can configure the 2501's back to back using a crossover serial cable between them, this will essentially provide you with two ethernet networks.  One for the DSL modem, the other for the internal LAN.

Do you have a serial cross over cable?
0
 

Author Comment

by:fuad2
ID: 12162442
I have verified my two 2511 routers. The two routers each has only one ethernet and two serial interfaces.  I can get cross over cable if the configuration is not very complicated.

Thanks

Fuad2
0
 
LVL 43

Expert Comment

by:JFrederick29
ID: 12162591
It's a lot more complicated than getting a 2514 with two built in interfaces.  You'll also get better performance out of a 2514 instead of routing through two routers.
0

Featured Post

Manage your data center from practically anywhere

The KN8164V features HD resolution of 1920 x 1200, FIPS 140-2 with level 1 security standards and virtual media transmissions at twice the speed. Built for reliability, the KN series provides local console and remote over IP access, ensuring 24/7 availability to all servers.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I recently attended Cisco Live! in Las Vegas, a conference that boasted over 28,000 techies in attendance, and a week of hands-on learning hosted by a solid partner with which Concerto goes to market.  Every year, Cisco displays cutting-edge technol…
Shadow IT is coming out of the shadows as more businesses are choosing cloud-based applications. It is now a multi-cloud world for most organizations. Simultaneously, most businesses have yet to consolidate with one cloud provider or define an offic…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

670 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question