[Webinar] Streamline your web hosting managementRegister Today

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1467
  • Last Modified:

Hanging logins and errors in drive mapping

I am having connectivity issues with Novell. I am running Netware 5.1 sp5, 4.9 and 4.83 sp2 client with the majority of my workstations running 2000 or XP. I have a few running 98. I have workstations that can log on to the server no problem. Others experience a hanging log in box listing the mapped drives but never authenicating or logging in...freezes and you have to reboot....and the same problem continues.  Others will map partially--not all drives are mapped according to login scripts. I didin't have this problem until I updated some of my labs to XP from 2000 and some from 98 to 2000. ( I have approximately 225 computers with approximately 80% running either 2000 or XP.) I have 250+ connection licenses.
It is drivng me insane. Seems to get worse as the day goes on as users are added.Can't tell if it is connectivity across my network or a server or client problem. I have to solve this so instruction can continue at my district. My elementary teachers are ready to kill me....if I don't fix this...and quick.

lhzeigler
0
lhzeigler
Asked:
lhzeigler
  • 8
  • 8
  • 8
  • +3
1 Solution
 
jwiersmaCommented:
Some troubleshooting tips:

Did you test with client32 4.9 SP2 ?

You could run a sniffer on the pc with problems; use Ethereal (free sniffer), download it from http://www.ethereal.com/, install it on the pc and run it during a login action. You should see what packets there are on the network and maybe see the problem.

Also have you see this TID: http://support.novell.com/cgi-bin/search/searchtid.cgi?/10087705.htm
0
 
ShineOnCommented:
Is there any pattern of consistency between those that have problems and those that do not?

On the ones that do have problems, try this:

1) Right-click the red N in the system tray and select Novell Client Properties.

2)  In the Advanced Login tab, scroll to NMAS Authentication, and set it to Off.

3)  In the Advanced Settings tab, scroll to UNC Path Filter and make sure it is set to On.

Click OK to save the change(s)

Then, disable all unnecessary Windows services (see the Black Viper list for tips)

Then, in Windows Explorer, Tools, Folder Options, View tab, uncheck "Automatically search for folders and printers" and "Use simple file sharing."

Click "Apply" and then click "Apply to all folders"
0
 
PsiCopCommented:
All good advice.

Is there any pattern? That is, is the problem limited to 98 machines, or 2K machines?
0
Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

 
lhzeiglerAuthor Commented:
Problem is limited to 2k or XP machines but I have to go to another building to check on the 98s....but do not have any reported.

Running 4.9 SP2 on the XPs and 2k machines

NMAS authentication is off

UNC is off.

0
 
ShineOnCommented:
Turn UNC on.  That speeds up login and mapping a lot.  It could be appearing to hang...
0
 
PsiCopCommented:
Yeah....turning on UNC should help.

Are you a mixed IPX/IP environment? That is, do you support both IPX and IP on the server and *also* bind both protocols to the clients? If so, don't do that. Pick one, preferably IP, and make all the clients use that (doesn't matter if the server continue to host the other - the issue is that you don't want the clients having both bound)
0
 
lhzeiglerAuthor Commented:
No change with UNC on.
0
 
lhzeiglerAuthor Commented:
Not sure if I've answered your question but -The previous techy set up all workstation with IP and IPX protocols in network neighborhood. Can I uninstall IPX if they are already configured for netware clients and windows clients?  I have been setting the protocol preferences to IP in the client configuration.


.....also do I have to be running SLP on the Netware server if I am using a Win2k for DHCP?
0
 
ShineOnCommented:
SLP and DHCP are totally different animals.  SLP is Service Location Protocol.  It tells clients where to find services.  DHCP is Dynamic Host Configuration Protocol.  It gives out IP addresses and tells clients where to find certain types of servers.  Yes, you need to run SLP in a true, pure-IP environment.

NetWare has a DHCP server that is much more standards-compliant than Win2K's.

To drop IPX, you don't have to uninstall it.  You can simply unbind it from the NetWare client, from the "My Netwrok Places" properties, in the NWLINK IPX whatever-it's-called protocol properties.
0
 
ShineOnCommented:
Also, the Windoze DHCP server doesn't want acknowledge SLP as a valid IP service to present to a client.  You have to jump through hoops to make it send the address of the SLPDA server.  It is not available to the DHCP MMC snapin.  

In the NetWare DHCP server config, you can send the client settings for any service that has a DHCP service number.
0
 
PsiCopCommented:
I agree - there's no reason to be using the Windoze DHCP server, it'll just cause you headaches because it breaks standards. Every NetWare since v5.0 has included a DHCP server, you should look into it.

Its a Bad Idea (tm) to have *both* IPX and IP bound on the client if the server environment also supports both. What can happen is the client becomes "confused" about which protocol to use for NCP (NetWare Core Protocol) communications, which can lead to timeouts and odd client behavior. If the previous admin made this mistake, then they probably didn't know what they were doing, so watch out for all the other mistakes they made. Don't you just love it when you inherit an incompetently-administerted environment.

You can, as ShineOn suggested, just remove IPX/SPX from the list of protocols on the workstation.
0
 
lhzeiglerAuthor Commented:
Thanks will remove the IPX/SPX from the list. However, I am still wrestling with my orginal problem---problem now happening all over with all OS and clients...and gets worse as times marches on. THen I can reboot server and starts working as it is supposed to but as time marches on --30 minutes--then it is hanging boxes, not mapping correctly, can't save to directories, use software applications or open file on server--freezes.

SLP is a automatic loaded module on the server when rebooted....any reason it would stop running outside of me just unloading at command line?

Network issue?  NIC Card maybe. Existing NIC card on board and server about 8 years old.
Any suggestions along these lines.
0
 
PsiCopCommented:
OK, that's important - the issue affects all clients, regardless of OS. The fact that it seems to go away with a server reboot is also very important.

SLP.NLM generally loads automatically, as part of binding NCP to TCP/IP, on NetWare v5.x and above. However, SLPDA.NLM, the Directory Agent, does NOT load automatically in NetWare v5.x. But that would not cause the problems you're seeing.

It would be interesting to know if clients from which IPX had been removed continue to experience the problem.

But before we get into that, your mention of the server reboot addressing the issue, temporarily, causes me to wonder if your server has adequate RAM for its workload. If you don't have it loaded already, load the NetWare Console Monitor by, at the server's console prompt, entering --> LOAD MONITOR

Then select System Resources on the resultant menu.

What are the percentages for each category of memory when the problem is happening? "Cache Buffer Memory" should not be below 50%.
0
 
PsiCopCommented:
Your concern about a NIC going bad is also a possibility - the same is true for a bad Ethernet switch port. Hardware communications problems like that may show up in Monitor as well.

Back on the Monitor main menu, select LAN/WAN Drivers. Press <TAB> to switch to the stats screen. When the problem is happening, look for error counters incrementing (error counters generally have the word "failed" in their description). Most or all of the error counters should be 0 under normal circumstances (depends on if you have a switched or shared environment).
0
 
lhzeiglerAuthor Commented:
Ok, sounds good PsiCop.  The only possible 'load' changes I've created since everything was working fine-is update existing ws to 2k or XP depending on hardware/system configs.  I have not added any more workstatins or increased users or applications.

I will investigae the RAM issue (every slot is full) ....and LAN/WAN driver stats...I've looked at these but not sure how to interpret them . Did notice today when I tried dsrepair---error with time issues...??Sympton of loss of nw connectivity maybe?  Will check out swtiches also-have older Cisco switches-3 in the stack--will check out the one with the server on it.

Clients without IPX are still affected as well as those that have UNC on. I used Ethereal some in past to detect unwanted traffic on network but to good at interpreting results.

Let you know tomorrow...hopefully. I am also the principal of the 7-12 in a small rural district as well as the tech person for the district.
0
 
PsiCopCommented:
Um.....OK, time issues reported by DSREPAIR are not a good thing. NetWare goes to a lot of effort to keep track of time (using standard NTP, or Network Time Protocol). Time is important because that's how NDS deals with changes to the Directory - everything is timestamped, so operations can be completed in the proper order.

You must have a mutli-server environment, or your server is in communication with other NetWare servers in the school district/LEA/whatever your state calls it. If you were in a single-server environment, the NetWare server would not be concerned with time sync with other servers.

Checking the switch port will probably be as simple as moving the server's connection to another port. If the problem is happening when you do that and the issues persist, then you've eliminated the switch port as the culprit.

Exact output from DSREPAIR would probably be helpful. Specifically, the results of "Report Synchronization Status" and also the "Time Synchronization" menu item. Cut-n-paste those results here if you can.

I sympathize with your plight as a principal in a rural middle-high school. I consulted in the K-12 field in NC for over 5 years, I've been to many a network held together with bailing wire and gummi worms stolen from the 2nd grade lunch room. Does your district central office not have any support resources for you? Your state's Education department?
0
 
DSPooleCommented:
personally, I'd host DHCP on a NetWare server because it has extensions to push SLP out to the workstations - I don't know if Windows DHCP will do that.

You mention this started to happen the moment you started going Win2K/XP - Are you fully patched on those OS platforms and if running SP2 for XP, did you disable the personal firewall?

"What can happen is the client becomes "confused" about which protocol to use for NCP (NetWare Core Protocol) communications, which can lead to timeouts and odd client behavior."

Can you say "Preferred Network Protocol"?  It's in the client, you can tell it to use IP over IPX even if both are available, it will only switch to the other protocol if the preferred protocol fails for any reason.  Once attached using one protocol, it will stick to the server using that protocol until a reboot is issued at the workstation ;)

0
 
ShineOnCommented:
Windoze DHCP can push SLP but you have to jump through hoops to define it.  If you do a search of EE you should find a couple of PAQs on how to do it.
0
 
PsiCopCommented:
"Can you say "Preferred Network Protocol"?  It's in the client, you can tell it to use IP over IPX even if both are available, it will only switch to the other protocol if the preferred protocol fails for any reason"

Yes, I can. In my experience, it has not been entirely reliable.
0
 
ShineOnCommented:
My experience with IP and IPX bound to the client at the same time:

If there is only one local server advertising as a login server and it has both protocols bound, and the client has both protocols bound, it will attempt to connect using the preferred protocol.  When something happens to make a reconnect required, it would reconnect with the other protocol, resulting in lost mappings and printers.  This happened frequently as recently as last year, using the 4.83 client on XP or Win2K (through several SP and post-SP patch levels.)

I never had this problem - I repeat - Never had this problem on Win98.  I would not be surprised if WinNT had or did not have this problem but could not say from experience.

Maybe it's fixed in the 4.9 client.  Maybe not.  Once burned, twice shy.
0
 
PsiCopCommented:
"Once burned, twice shy."

I'm the same way, for the same reason. Mebbe they got it fixed now.  I'd rather stick with a single-protocol environment - makes troubleshoot a LOT easier.
0
 
lhzeiglerAuthor Commented:
I would like to say sorry its been awhile but alot has been happening and I've been limping along just rebooting when absolutely necessary---problems continue as reported in orginial posting. I've tried serveral suggests. Running only IP no IPX....
no Errors in DSREPAIR OR VREPAIR
I replaced a 3 com switch that was flip flopping on its ip address. Check NIC card on server with loop back cable....and its good.

However, problem still continues

--------------Here is some info_______________what do you think of my next plan of attack?
Login Box Dialogue 9-24-2004
JOEY
LOGIN-LGNWNT32.DLL-890: The specified server is unknown.
Your current context is SCHOOL
User: admin Context: SCHOOL
Your current tree is: KISD
You are attached to server JOEY.
LOGIN-LGNWNT32.DLL-430: The following drive mapping operation could not be completed.
    [ROOT G:=JOEY_DATA:]
The error code was 8804.
Drives A,C map to a local disk.
Drive F: is not defined.
Drive H: is not defined.
Drive R maps to a local disk.
      -----   Search Drives   -----
S1: = C:\WINDOWS\system32
S2: = C:\WINDOWS
S3: = C:\WINDOWS\System32\Wbem
S4: = C:\Program Files\ATI Technologies\ATI Control Panel
S5: = C:\WINDOWS\system32\nls
S6: = C:\WINDOWS\system32\nls\ENGLISH
S7: = C:\PROGRA~1\COMMON~1\Odbc\FILEMA~1

VOL$LOG.ERR on Data  Volume

Volume SYS mounted on Tuesday, September 21, 2004   5:30:52 pm.

Volume SYS mounted on Tuesday, September 21, 2004   6:37:57 pm.
Volume mount had the following errors that were fixed:
Problem with file CONSOLE.LOG, length extended.
Problem with file CONSOLE.LOG,  old length = 0, new length = 65536
Problem with file _SWAP_.MEM, length extended.
Problem with file _SWAP_.MEM,  old length = 0, new length = 2097152

Volume SYS mounted on Thursday, September 23, 2004   9:04:20 am.
Volume mount had the following errors that were fixed:
Problem with file _SWAP_.MEM, length extended.
Problem with file _SWAP_.MEM,  old length = 0, new length = 2097152

Volume SYS mounted on Friday, September 24, 2004   9:21:01 am.
Volume mount had the following errors that were fixed:
Problem with file _SWAP_.MEM, length extended.
Problem with file _SWAP_.MEM,  old length = 0, new length = 2097152



DSREPAIR LOG-After replacing switch but still having same issues:

NetWare 5.00 Directory Services Repair 85.19 , DS 8.82
Log file for server ".JOEY.SCHOOL" in tree "KISD"
Repairing Local Database
Start:  Wednesday, September 22, 2004   5:07:49 pm Local Time

Structure and Index Check
Repair Trees - Scan Values
Repair Trees - Sorting Values
Repair Trees - Scan Entries
Repair Trees - Sorting Entries
Repair Trees - Check Values
Repair Trees - Check Entries
Total Objects in Database:        761
Total Objects in Schema  :        577
Total External References:          1
Total Objects in Replicas:        165
Schema Check

Repairing objects in a replica
Start:  Wednesday, September 22, 2004   5:07:51 pm Local Time
[1 of 1] Master     : T=KISD
Total Objects = 165, UNKNOWN class objects = 0, Total Values = 10095
Finish:  Wednesday, September 22, 2004   5:07:52 pm Local Time
Total repair time: 0:00:03
Checking mail directories
Checking stream syntax files
Repair process completed, total errors found = 0

Prior getting the following type of errors on containers-objects,etc.

ERROR: Modification time was incorrect, it has been updated
Object ID: 000080D0, DN: CN=JrHigh Computers.OU=Students.O=SCHOOL.T=KISD


I do not have any DS errors showing in DSRepair at this time.


I do have this error in NWADMIN log associated with licenses.

Severity=1 Locus=14 Class=2
POLICY MANAGER-{5.00-035
]:-Update connection license failed. Error # C00010001

If I look this up on the Novell support website I get the following TID 10017869 and going to follows those steps if you all think it is a good idea.

Also I suspect my Novel client 4.9 and 4.9sp2 could also be the problem---they have patches to this service pack as of yesterday…..

Advise please….
0
 
ShineOnCommented:
A John Kerry 3Com switch, eh? ;^)

Politics aside, do you have more than one NetWare server in the network segment, or is it just JOEY?
Do you have NO_DEFAULT at the top of the login script?
Can you post the text of the login script?


>> LOGIN-LGNWNT32.DLL-890: The specified server is unknown.

Do you have a preferred server indicated in the client properties?   Is it the same server as the one authenticated to (JOEY)?

>>LOGIN-LGNWNT32.DLL-430: The following drive mapping operation could not be completed.
>>    [ROOT G:=JOEY_DATA:]

Is JOEY_DATA a directory map object, a volume object, or a volume name?  Since you have no dots or context, I'll assume volume name at this point.  8804 could mean a corrupt volume object ID in eDirectory/NDS. I don't recommend you try the fix until you've eliminated other possibilities.  This is the fix, from TID 10064391:

1. Delete the volume in question using NWAdmin.  
2. Wait for obituary to clear for the object.  
3. Run DSRepair | Advanced Options | Check Volume Objects and Trustees.
Note: This will repair the problem and recreate the volume objects.  
Note: Users home directories may not remain intact.
Note: Print Queues associated with this volume object will need to be recreated

If it is a Directory Map object, you shouldn't use the colon unless it maps to the root of a volume.  Looking at your VOL$LOG.ERR, it appears it might be a Directory Map object, pointing to somewhere on SYS: vol.  If so, that could be your problem.  Best practices dictate that user data should NEVER be stored on SYS:  If SYS: gets too full, it WILL cause all sorts of problems, including the server locking up or abending.

Let's tackle the license issue separately.  If the other problems are causing the license issue, it would be a waste of effort and may cause more harm than good trying to fix it now.
0
 
DSPooleCommented:
it's a hellavu lot easier to deploy SLP via NetWare-supplied DHCP than via Windows-supplied DHCP:

1)  Launch Novell DNS/DHCP Management Console
2)  Select the DHCP Service tab
3)  Select your Subnet you want to work with
4)  Select the Other DHCP Options tab on the screen to the right
5)  Press the Modify... button
6)  The Directory Agent is listed under the Option Name and the Code is 78, the Service Scope is also listed by name and is Code 79
7)  NDS Servers is Code 85, NDS Tree Name is 86 and NDS Context is 87
8)  Use the Add>> button and add the options and edit their values to what is on your network.
9)  Save the changes and give NDS time to replicate
10)  from the NetWare server UNLOAD DHCPSRVR then reload it with DHCPSRVR -d1 (for the debug screen).

btw:  Login -430 errors:
http://support.novell.com/cgi-bin/search/searchtid.cgi?/10019026.htm

login -890 errors:
http://support.novell.com/cgi-bin/search/searchtid.cgi?/10090180.htm
0
 
lhzeiglerAuthor Commented:
Yep-it is a John Kerry switch and did flip flop.;)

I have only one server -JOEY
ROCKY is a 'folder' on JOEY--used to be a second server---techy just pulled its contents into a folder on JOEY.
PS:I inherited this setup.

No I don't have NO_DEFAULT at top of login script.....should I?

JOEY_DATA is a volume. I have two volumes DATA and SYS. G maps to the root of DATA volume.

Will try to post my login scripts later today.




0
 
ShineOnCommented:
lhzeigler - it's been 5 months - is your problem resolved?  What was the fix?

Please come back and let us know.
0
 
lhzeiglerAuthor Commented:
Patched all clients with new patch for 4.9 and updated Netware server to 6.0
0
 
Computer101Commented:
PAQed with points refunded (500)

Computer101
EE Admin
0

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

  • 8
  • 8
  • 8
  • +3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now