Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 223
  • Last Modified:

Application wont work - just installed CFMX

I just installed CFMX and my calendar application wont let people log in.  It works just fine in my development server. I know the code is correct - am I missing a folder permission that is needed.  
I am using IIS - not 6
and Coldfusion MX

Thanks!
0
ahillman
Asked:
ahillman
  • 6
  • 3
1 Solution
 
anandkpCommented:
Did u migrate all the settings from the development server ... including those on IIS ?
0
 
ahillmanAuthor Commented:
It was just using the CFMX server not IIS for development.  This is the first time with IIS install.  All pages are viewable - do I need a virtual directory for the application folder?
0
 
ahillmanAuthor Commented:
Seems to work fine when using the Server IP address - but not when using the FQDN(URL).  We did create a virtual directory and the site is all together so the site works great.
0
Easily Design & Build Your Next Website

Squarespace’s all-in-one platform gives you everything you need to express yourself creatively online, whether it is with a domain, website, or online store. Get started with your free trial today, and when ready, take 10% off your first purchase with offer code 'EXPERTS'.

 
shooksmCommented:
If you are using a CFAPPLICATION tag, try setting the attribute setDomainCookies="yes"
0
 
ahillmanAuthor Commented:
That didn't work - but thanks - I seem to be having a bigger issue now - getting a folders permission problem with needing to login into the site - thought this was cleared up but apparently not.  Any experience with this?
0
 
shooksmCommented:
If you don't need folder/file level permissions then make sure IIS is setup with anonymous authentication.  That would be under the Directory Security tab on the properties of your web server.  Click on the edit button in the Anonymous Access section.  Make sure your IUSR account has the appropriate access to the files and folders in question as this is the account IIS uses when in Anonymous Authentication.
0
 
ahillmanAuthor Commented:
I have prob. looked at those setting about 100 times now.  :)  The anonymous authentication is set.  The IUSR_{servername} is the account used - but I can't be sure if the credentials are correct regarding password cause I can't see it.  The IUSR is a local account and it is in the Guest group.  This is the built in account for IIS.
0
 
shooksmCommented:
You don't need to login to the IUSR account, you should just need to verify that your files and folders give IUSR at least read rights.  Open up windows explorer on the server and highlight a folder or file that is prompting for authentication and verify IUSR has read rights to it.  Usually when you create files inside of wwwroot that IIS creates by default, the IUSR rights propagate down with each file/folder addition, but because you are using a virtual directory, there is a chance that the IUSR account was never setup with access to the directory that is outside of wwwroot.
0
 
ahillmanAuthor Commented:
well - i added the IUSR to the security of the website folder and that didn't pan out.  Under IIS I have the IUSR as the account to use and now adding the IUSR as a security member in the folder security - you would think that would work.  Nope - good idea though.  :)
0
 
ahillmanAuthor Commented:
The scripts access was not checked - got rid of the windows authentication - but I still can't get to my calendar application through a log in - I know the code works just fine - it is another permissions thing.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Get 10% Off Your First Squarespace Website

Ready to showcase your work, publish content or promote your business online? With Squarespace’s award-winning templates and 24/7 customer service, getting started is simple. Head to Squarespace.com and use offer code ‘EXPERTS’ to get 10% off your first purchase.

  • 6
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now