Solved

FP 2002 Server Extensions non-anonymous email

Posted on 2004-09-21
5
214 Views
Last Modified: 2013-12-24

I'm hosting a test version of our online site(which is hosted offsite) on a LAN webserver (IIS5, W2k).  I created a form and have the results emailed to myself.  It works great when it runs on the hosted site.  When i publish it to the local webserver, however, it bothers me for username, password, domainname on SUBMIT.  There is no place in the server extensions mail setup to speicfy smtp credentials, so I guess that since I don't allow anonymous email to pass-thru my exchange server, there is not much I can do.


Does anyone have any suggestions?  can you verify that FP02SE only supports anonymous smtp?
0
Comment
Question by:adamdrayer
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
5 Comments
 
LVL 29

Accepted Solution

by:
coreybryant earned 250 total points
ID: 12113707
Try re-installing the FP extensions.  It is not asking for the user name / password to the SMTP server.  It is a permissions issue on your folders if I can remember correctly.

-Corey
0
 
LVL 15

Author Comment

by:adamdrayer
ID: 12114004
no i'm pretty sure it's a exchange/credentials thing.  Had a similar problem with copiers. We bought 2 copiers that were both "compatible" with our system according to the salesman.  One of them could only send anonymous email.  This was no good, as our exchange server requires authentication.

Just to check tohugh, I tried re-installing the Server extensions.  No luck.  If i change the form to save results as a file on the webserver rather than email them, it works fine.
0
 
LVL 29

Expert Comment

by:coreybryant
ID: 12114193
Can you whitelist your server IP address?

-Corey
0
 
LVL 15

Author Comment

by:adamdrayer
ID: 12114956
I owe you an apology cb, it seems that exchange will use whatever credentials the user is logged in as during the web browsing.  Allow anonymous access meant that it was using the credentials for the IIS_user account which does not have a mailbox or the ability to send my on my server.  Changing anonymous access to use an account that has permission to send mail has fixed the problem.  I'll up the points and give you what you deserve
0
 
LVL 29

Expert Comment

by:coreybryant
ID: 12114997
No worries.   I have been known to be wrong before :)  I had been thru that issue a few times with some of my websites.  So i was not certain exaclt ywhat dialog box you might be getting.  Glad it is working now.

Good luck with it!

-Corey
0

Featured Post

The Ultimate Checklist to Optimize Your Website

Websites are getting bigger and complicated by the day. Video, images, custom fonts are all great for showcasing your product/service. But the price to pay in terms of reduced page load times and ultimately, decreased sales, can lead to some difficult decisions about what to cut.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In this short web based tutorial, I wanted to show users how they can still use the powers of FrontPage in conjunction with Expression Web 3.  Even though Microsoft eliminated the use of Web components, we can still use them with FrontPage and edit …
When setting up new project requests for our site, one of the most powerful tools our team has available to use is Axure (http://www.axure.com/). It’s a tool for creating software and web prototypes that can function and interact as if it were the a…
The purpose of this video is to demonstrate how to exclude a particular blog category from the main blog page. This is can be used when a category already has its own tab, or you simply want certain types of posts not to show up on the main blog. …
The purpose of this video is to demonstrate how to integrate Mailchimp with Facebook. This will be demonstrated using a Windows 8 PC. Mailchimp and Facebook will be used. Log into your Mailchimp account. : Click on your name. Go to Account Setti…

717 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question