Solved

Server 2003/Ecxchange 2003 Hangs at applying computer settings

Posted on 2004-09-21
11
405 Views
Last Modified: 2011-09-20
Just installed server 2003 and exchange 2003 on a new machine.  The machine now hangs at applying computer settings forover an hour.  Booting into safe mode and safe mode with networking works fine.  The only error I had in the event viewer was (Error: The Template Persistent Cache initialization failed for Application Pool 'DefaultAppPool' because of the following error: Could not create a Disk Cache Sub-directory for the Application Pool. The data may have additional error codes..)  I have followed Microsofts directions to change some of the folder permissions but still no luck.  Strangely enough even while in the stuck boot process I can still use another machine to hit Outlook Web Access on the broken box.  When in Web access I can view and send mail but I can not recieve any messages (they get bounced back to sender).  When I can log into the server I find that trying to access anything in network connections hangs explorer.exe . If anyone has any suggestions I would be greatly appreciative as my company email is down.
0
Comment
Question by:andyesper
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 3
  • 2
  • +1
11 Comments
 

Author Comment

by:andyesper
ID: 12118539
Now if I try to send an email to my account I get an undeliverable message that comes from the broken server.  So the emails are getting there they are just not making it to the mail boxes. Still takes over an hour to boot.
0
 
LVL 4

Expert Comment

by:mcsallad
ID: 12120752
Sounds like you have some major issues with your installation.
Are you running AD on the server too?

Have you applied the latest servicepack on the server and on exchange?
How is the network configured?
What are the error codes in the undeliverable messages?
Have you tried telnetting to port 25 on the server and see what answer you get?
0
 
LVL 4

Expert Comment

by:mcsallad
ID: 12120768
I guess you have tried this?

http://support.microsoft.com/?id=332097
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 4

Expert Comment

by:mcsallad
ID: 12120811
The knowledge base article missed one possibility.

Do the same as the above KB solution if you have certificate authority installed
for this directory:

systemroot\system32\CertSrv
0
 

Author Comment

by:andyesper
ID: 12122890
1. Yes, tried KB 332097 first thing.  Should NETWORK SERVICE for systemroot\system32\CertSrv have full control or only read, read & execute, list folder contents?  
1a. The last step of the above is to restart Exchang Information Store.  I can't do this because it won't stop.  

2.  I do not have an Active Directory service running.  Is this a problem?

3. Have not installed the latest service packs, see #4.

4. Cannot pull up web pages.  I can ping both inside and outside the network, but cannot open a web page.  

5. When I try to open the network settings control panel, it hangs.  Left it sitting overnight, never opened.

6. Rebooting the computer takes upward of 3 hours.  This seems to indicate a problem, but I would like to know with what.
0
 

Author Comment

by:andyesper
ID: 12122907
Yes, AD is running.
0
 

Author Comment

by:andyesper
ID: 12123012
I can connect via telnet to port 25 and send a message.  I sent it from my account to my account.  I recieved a message back in my inbox that the message had failed.  
0
 
LVL 104

Accepted Solution

by:
Sembee earned 500 total points
ID: 12125229
Is this server an Active Directory domain controller as well Exchange server? That can cause massive headaches with rebooting as AD takes longer to start than Exchange and Exchange cannot connect to AD for ages.

Also check your DNS settings. They should be pointing at an AD DC ONLY. If it is a DC itself then it should be pointing at itself. No External DNS settings anywhere.

Simon.
0
 

Author Comment

by:andyesper
ID: 12132806
Ok, I decided the orignal install was hosed and reformatted and started over.  The server is up and running  now, and reboots in 15 min, which is a big improvement over 3 hours.  AD and Exchange are playing nicely together.  
0
 
LVL 104

Expert Comment

by:Sembee
ID: 12135699
15 mins? Depends on the spec of the server I suppose but I usually get less than 10 from OK to CTRL-ALT-DEL. But if you are happy then that is all that matters.

Don't forget to close the question.

Simon.
0
 

Expert Comment

by:Johnnylight
ID: 14620992
Do you have APC powerchute installed?

I had this same problem with SBS2003.
Email worked, but Internet acess did not.
Log on hung at Applying Computer Settings.

The problem was with APC's powershute.
Supposedly the java in version 6 stopped working with Microsoft OS last week. The powershute APC services were causing the hang.

The solution is to boot to safe mode, and disable all APC services.
Reboot server and uninstall powerchute, or upgrade to powershute 7.
Hope this saves someone an all nighter.  I wish I knew this answer last week before a 16 hour debacle.

 
0

Featured Post

Complete VMware vSphere® ESX(i) & Hyper-V Backup

Capture your entire system, including the host, with patented disk imaging integrated with VMware VADP / Microsoft VSS and RCT. RTOs is as low as 15 seconds with Acronis Active Restore™. You can enjoy unlimited P2V/V2V migrations from any source (even from a different hypervisor)

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I've always wanted to allow a user to have a printer no matter where they login. The steps below will show you how to achieve just that. In this Article I'll show how to deploy printers automatically with group policy and then using security fil…
A quick step-by-step overview of installing and configuring Carbonite Server Backup.
There's a multitude of different network monitoring solutions out there, and you're probably wondering what makes NetCrunch so special. It's completely agentless, but does let you create an agent, if you desire. It offers powerful scalability …
In this video you will find out how to export Office 365 mailboxes using the built in eDiscovery tool. Bear in mind that although this method might be useful in some cases, using PST files as Office 365 backup is troublesome in a long run (more on t…

617 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question