Solved

Hard Coding a Port for NIS on Fedora Core2

Posted on 2004-09-21
6
302 Views
Last Modified: 2013-12-15
I want to run NIS between a mail server in my DMZ to a server on my trusted network which runs Fedora Core2.  My firewall requires a pin hold with a static port, but when I reboot my server the NIS turns up on another port.  Is there a way to hard set the NIS communication port on a Server running Fedora Core 2?
0
Comment
Question by:qcomm
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
6 Comments
 
LVL 17

Accepted Solution

by:
owensleftfoot earned 250 total points
ID: 12117223
0
 
LVL 2

Expert Comment

by:fulp02
ID: 12144689
Yes make a startup script an place it in your runlevel that you are using
delete the old NIS script or it may be something with ypserv in it
Anyways make the new script and use the
ypserv -p 500

now the nis server will run on that port

Heres a link if you need help http://www.linuxforum.com/man/ypserv.5.php
0
 

Author Comment

by:qcomm
ID: 12145168
this is a comment to the original question to make it more concise!

I am familiar with NIS and know the howto forward and backward, I will try rewriting the startup script and see if the startup script is the problem.  However, all attempts at this point to set the port have failed.  NIS will not start under two conditions at this point -- 1. if I enter the -p entry in the startup script, and 2. if I run the machine at init level 3.  I really would prefer to run the box at init level 3 rather than init level 5.

0
 
LVL 2

Assisted Solution

by:fulp02
fulp02 earned 250 total points
ID: 12153463
Aight 1 Make sure the RPC portmapper Is running with out it
I am pretty sure Nis Will crash every time , And in your startup after you verify
that the port mapper is runnin Put it at the very end to start so
say the your script was in roots home dir named "NisStart"
in that script there would be the command "ypserv -p 500"
Now copy this to Your run leve and Make it execute last

So I believe that you would do this
cp NisStart /etc/rc.d/rc3/S99NisStart give that a try and let me know how it works out
0

Featured Post

Back Up Your Microsoft Windows Server®

Back up all your Microsoft Windows Server – on-premises, in remote locations, in private and hybrid clouds. Your entire Windows Server will be backed up in one easy step with patented, block-level disk imaging. We achieve RTOs (recovery time objectives) as low as 15 seconds.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

SSH (Secure Shell) - Tips and Tricks As you all know SSH(Secure Shell) is a network protocol, which we use to access/transfer files securely between two networked devices. SSH was actually designed as a replacement for insecure protocols that sen…
Linux users are sometimes dumbfounded by the severe lack of documentation on a topic. Sometimes, the documentation is copious, but other times, you end up with some obscure "it varies depending on your distribution" over and over when searching for …
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

724 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question