• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 701
  • Last Modified:

Poor performance with VLANs

Ok, I have my fileserver on VLAN 2 ( 192.168.2.0).  And I have a few users on VLAN3 (192.168.3.0 )

The problem is, copying files from the fileserver is taking FOREVER since I implemented VLANs.
So I configured the switchport the fileserver was on, to be a member of both VLANs.  Didnt seem to help too much.  Any advice?
Thanks
0
dissolved
Asked:
dissolved
  • 7
  • 5
  • 2
1 Solution
 
dissolvedAuthor Commented:
Here's a sh run

newswitch#sh run
Building configuration...

Current configuration:
!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname newswitch
!
enable secret (removed)
!
!
!
!
!
!
spanning-tree vlan 1 hello-time 10
no spanning-tree vlan 1
ip subnet-zero
!
!
!
interface FastEthernet0/1
 port security max-mac-count 1
!
interface FastEthernet0/2         -Fileserver on this port
 switchport multi vlan 1,3
!
interface FastEthernet0/3         -VLAN 3 has most of my users
 switchport access vlan 3
!
interface FastEthernet0/4
 switchport access vlan 2
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
etc etc etc etc
0
 
lrmooreCommented:
Where is your L3 routing taking place between the subnets?
0
 
dissolvedAuthor Commented:
Port 24 is set up as the trunk port.  It goes to a 2600 series router
0
Efficient way to get backups off site to Azure

This user guide provides instructions on how to deploy and configure both a StoneFly Scale Out NAS Enterprise Cloud Drive virtual machine and Veeam Cloud Connect in the Microsoft Azure Cloud.

 
lrmooreCommented:
What's the speed of the trunk port on the router? Is your router setup properly?
Are you getting any error conditions on the trunk port? On the router interface? Use show interface fa 0/24, sho interface fa 0/x


0
 
dissolvedAuthor Commented:
Wait a minute, I know why it's slow.  The trunk port is only 10mb.  I forgot all about that lol.
Thanks lrmoore.

Here is the sh for that port
newswitch#sh int fa0/24
FastEthernet0/24 is up, line protocol is up
  Hardware is Fast Ethernet, address is 0030.1944.2d58 (bia 0030.1944.2d58)
  MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive not set
  Auto-duplex (Half), Auto Speed (10), 100BaseTX/FX
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:27, output 00:00:01, output hang never
  Last clearing of "show interface" counters never
  Queueing strategy: fifo
  Output queue 0/40, 0 drops; input queue 0/75, 0 drops
  5 minute input rate 7000 bits/sec, 4 packets/sec
  5 minute output rate 8000 bits/sec, 7 packets/sec
     12470391 packets input, 1496755807 bytes
     Received 101523 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 101420 multicast
     0 input packets with dribble condition detected
     15325599 packets output, 1760765330 bytes, 0 underruns
     0 output errors, 2099707 collisions, 3 interface resets
     0 babbles, 0 late collision, 1095196 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out
0
 
lrmooreCommented:
Yep. 10M/half duplex...
Half-duplex allows collisions
Collisions cause deferrals
defferals cause reduced performance..
     >  0 output errors, 2099707 collisions, 3 interface resets
     >   0 babbles, 0 late collision, 1095196 deferred

I didn't know it would even let you configure trunking on a half-duplex link....
Older versions of IOS required 100M full-duplex for trunking.
Learn something new every day!
0
 
dissolvedAuthor Commented:
Thanks man.
yea, with IOS 12.2T and newer, you can trunk the 2600.  Obviously not very well though! lmao
thanks again
0
 
lrmooreCommented:
The least you can do is set it to full-duplex...

Cheers!
0
 
dissolvedAuthor Commented:
lrmoore, to set up full duplex, I do a
int e0
full-duplex

Ok, I did it. Do I have to do the "full-duplex" command to my sub-interfaces as well?

Anyway performance is very slow now (slower than before).  Do my switchports have to be set at 10m/full duplex as well? Right now they are on auto sensing.

thanks for any advice!
0
 
lrmooreCommented:
>Do I have to do the "full-duplex" command to my sub-interfaces as well?

No, just the  major interface

>Do my switchports have to be set at 10m/full duplex as well?
Absolutely! The default behavior of a switch set to autosense drops to half-duplex if the connecting device does not send a negotiation packet. Anytime you hard-code an interface, be it a router, switch or NIC card, and the switch is set to auto, you can be sure that you will end up with a duplex mismatch... hard-setting the duplex turns off the negotiation packet.
0
 
dissolvedAuthor Commented:
thanks again
0
 
DHildebrandCommented:
Have you tried setting a default gateway on the switch?

ip default-gateway x.x.x.x
(from config mode)
0
 
dissolvedAuthor Commented:
this is a layer 2 switch. Would it work ? Can i even set a default gateway?
0
 
DHildebrandCommented:
I don't see why you would not be able to set a default gateway as long as there is a router in the mix. I would set the default gateway to the Cisco 2600 you mentioned in an earlier post. See if that helps you out.
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 7
  • 5
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now