Visual Basic RunTime Error 2114

We are getting a Visual Basic error on the Picture property of an Image control in an Access 2002 SP3 report on
Windows XP Professional SP1. The annoying thing is that its happening on only 3 machines while its NOT happening
on several other machines with the exact same version of XP and Access 2002. All machines have the same VBA
references checked.

The "Picture" in question is a small 136 KB TIF file on a network drive. The error message is "Microsoft Visual
Basic RunTime Error 2114. DATABASE name doesn't support the format of the file FILENAME.TIF or it is too large.
Try converting the file to BMP or GIF format."

I cannot find any information about this particular Error Code in msdn.microsoft.com or support.microsoft.com or in
Google. Could perhaps a malicious script be generating this error code? There is also an annoying problem on
these 3 machines where sometimes (not always!) one has to click command buttons twice instead of once to make them
run.

Any information anyone could provide would be very much appreciated. This is costing us a great deal of time and
frustration.

THANKS!

Kathryn
LVL 1
birsteinAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
shanesuebsahakarnConnect With a Mentor Commented:
Those machines might not have the TIF filter installed. Go to Add/Remove programs and click Change against Microsoft Office, and click Change. Check under Office Shared Features->Converters and Filters->Graphics Filters.

Is the Tag Image File Format (TIFF) one installed?
0
 
Data-ManConnect With a Mentor COOCommented:
I sounds like the filters aren't installed on the machines in question.  I think you have to install them as part of the office install.  You may want to check EE, I remember something about this a week or so ago.

Mike
0
 
Benjamin_LukConnect With a Mentor Commented:
When your table field is OLE object. And you insert the picture object from the table view instead of using ADODB.Stream to insert the binary data to the field, and you using ADODB.Stream to output the OLE object to your drive, then load the picture to your picture control, this will cause the problem.

Please use ADODB.Stream to load the picture to your table instead of insert it directly from table view.

P.s. you can create one to record the file type .

Hope this will help you.
0
Easily Design & Build Your Next Website

Squarespace’s all-in-one platform gives you everything you need to express yourself creatively online, whether it is with a domain, website, or online store. Get started with your free trial today, and when ready, take 10% off your first purchase with offer code 'EXPERTS'.

 
Alan WarrenConnect With a Mentor Applications DeveloperCommented:
Hi Kathryn,

As Mike said; this issue came up last saturday and was solved by will_scarlet7
http://www.experts-exchange.com/Databases/MS_Access/Q_21134398.html#12085089

Alan
1
 
Alan WarrenApplications DeveloperCommented:
ps...

totally agree with Benjamin_Luk in regard to storing images as Binary Large Objects (BLOBs), there are many benefits to this approach, the least of which is succesfull upsizing and the ability to include image data in action queries such as append, delete, update.
More info here:
  http://www26.brinkster.com/alzowze/blobs.asp

Alan
0
 
birsteinAuthor Commented:
Alan:

This is not the problem Will Scarlet7 solved because this is Access 2002, not Access 2003. However I will have the network administrator uninstall and reinstall the filters.

Also, it is not a problem of storing images because the picture is not stored in a table. It is an external 139 KB TIF file strored on a network drive, specifically, X:/bob.tif. The only thing stored in an Access table field, tifpath, which contains the string "X:/bob.tif". I then put this field as an invisible field on the report and in the VBA code for the report I reference the string value in this field:

Private Sub Detail_Format(cancel As Integer, FormatCount As Integer)
  imgSignature.Picture = Me.tifpath
End Sub

So no BLOB field is involved. . . .

Kathryn
0
 
Benjamin_LukCommented:
If so, please replace the file with another tif file to X:\  drive, and try the testing. Or replace it with one JPG file for testing.
0
 
shanesuebsahakarnCommented:
I still believe that it is because the TIF file filter hasn't been installed.
0
 
Benjamin_LukCommented:
Once more thing, is this imgSignature one Image or OLE Object Frame ? If it is OLE Object Frame, that will not work, please try to use Image

Best Regards

Ben
0
 
birsteinAuthor Commented:
When I told the desktop tech to make sure the TIF filters were installed for Microsoft Office, he realized that he hadn't assigned the TIF file type to a graphics editing program. The following steps solved the problem. Since everybody assisted in the solution, I've split the points. THANKS!

1. Open My Computer, go to Tools -> Options, select the File Types tab, scroll down to TIF
2. Click the Change button.
3. Click the Browse button and browse to C:\Program Files\Common Files\Microsoft Shared\PhotoEd and double-click on PHOTOED.EXE, click OK, click Close.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.