Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 265
  • Last Modified:

index server not indexing in a virtual directory located in a shared resource

I have a virtual directory... located in a shared resource (\\server\directory)... the IIS can see this resource... and show all the pages that this directory contains.

when i try to index this resource, the index server shows the number of documents in this directory... but not create the index. Searching with the test page.... the index server not provide any result.

I make a test... i copy this remote directory in the local disk of the machine where the IIS and the index server runs. I create a new catalog with the this new local directory. The index server now show the number of documents in this directory... and index all the documents!! Searching with the test page the index server show results!.

What's the problem?

TIA
0
arapahoe
Asked:
arapahoe
  • 2
1 Solution
 
kmorris1186Commented:
Is this on IIS 5 or 6?

I know 6 has problems (apperently is a security issue) with Mapped drives, but using UNC or IP should work fine.
0
 
kmorris1186Commented:
NOTE: If a virtual directory is on an NTFS drive, the access permissions for the directory must match the settings in Internet Information Server or Internet Information Services. If they do not match, the most restrictive settings are used. For example, if you give a folder Write permission but give a particular user group only Read access permissions in NTFS, those users cannot write files to the folder because the Read permission is more restrictive.
0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now