Error Accessing System Registry

When I try to set references in VB (Project - References), I get an error "Error accessing the system registry."
How can I resolve this?

Very URGENT!!
tawandatAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Experts Exchange Solution brought to you by ConnectWise

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
 
inthedarkCommented:
Further to  mladenovicz suggestion....
You must use regedt32 to be able to set registry security. If you are having a problem developing then you need read/write permissions.  When running the user nees read permissions. The normal and more user-friendly regedit does not show the security options.

Another good way of resolving strange error conditions is to use filemon.exe (a free download). Filemon shows access to any file, including registry, as sometimes security issues are not always registry issues.
0
 
EDDYKTCommented:
You can try to use regclean to clean the registry

http://www.download.com/3000-2094-881470.html?tag=list
0
 
rajaloysiousCommented:
You should be given permissions by an administrator using the reged32.exe (Registry Administration Tool)
Better to give read permissions for all keys vix HK_LOCAL_MACHINE etc....

Contact a administrator and this problem will be resolved.
Cheers..
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.