Regarding Squid Proxy Sever Configuration

I want to upgrade Redhat linux 9 from Redhat Linux 8, but when I start squid proxy at Redhat 9  after basic configuration it shows me the following error message and squid is not start at all, but in same configuration its working fine with Redhat 8. pls help

init_cache_dir /var/spool/squid...  /etc/init.d/squid : line 162
4472 Aborted
$SQUID -z -F -D>2/dev/null
LVL 5
ranadastidarAsked:
Who is Participating?
 
ramazanyichConnect With a Mentor Commented:
squid -z
means build cache structure. But it is probably already exists.
There are two ways:
1. comment out that line in /etc/init.d/squid
2. remove old cache.
I prefer first option.
0
 
ranadastidarAuthor Commented:
I had already tried to uncomment the line 162 but then squid proxy did not start and this fresh insatallation so remove old cache is not applicable,
0
 
ramazanyichCommented:
Could you send your /etc/init.d/squid script ?
0
 
ranadastidarAuthor Commented:
ok i will send it tomorrow
0
 
ranadastidarAuthor Commented:
it has been solved.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.