Solved

Sending mail from Redhat 9

Posted on 2004-09-22
4
682 Views
Last Modified: 2008-03-10
I'm using a web based helpdesk system (modelled on the IRM from www.Altrustrialie.org) which has always been associated with a domain name.

This is on a redhat 9 box with lamp.

We have just installed a number of public IP addresses on the LAN and want to use one for our helpdesk system.

The problem is when i try to change adddress from the dns (wtl.2y.net) url to the IP address (81.188.8.80), email ceases to function.

In the mail  log i see the following:

Final-Recipient: RFC822; support@wtl.be
Action: failed
Status: 5.1.1
Remote-MTA: DNS; smtp.easynet.be
Diagnostic-Code: SMTP; 550-Verification failed for <apache@linux2.localdomain>
Broadcast message from root (Wed Sep 22 14:28:59 2004):

Under the network settings i have mapped linux2 to the public IP of 81.188.8.80 but this has not helped much. Can anyone suggest some ideas?

Twisted up.

rIcHyRich.
0
Comment
Question by:richardwalton
  • 2
  • 2
4 Comments
 
LVL 40

Expert Comment

by:jlevie
ID: 12122704
Without knowing more I'd suspect that the mail is failing because the remote MTA can't verify, by DNS lookup, the sender's domain (apache@linux2.localdomain). And, obviously that hostname isn't a member of any registered domain.

The fix should be simply a matter of ensuring that the IP of the machine is associated with an A & PTR record in the DNS and setting the hostname in /etc/sysconfig/network to be that same hostname.
0
 

Author Comment

by:richardwalton
ID: 12124372
OK i've reconfigured the system back the way it was, using the domain name wtl.2y.net which maps to our external router(81.188.8.66) which takes it through to the NAT table and into 192.168.0.227 on port 28000

In my fwd looking DNS server I have a pointer that states: linux2 = 192.168.0.227
on the reverse i have :
linux2.wtl.be = 192.168.0.227

In my mail log from the linux box it tells me that previously the host name had been root@wtl.2y.net. e.g.

Sep 19 08:41:02 linux2 sendmail[25245]: i8J6f1dZ025243: to=<root@wtl.2y.net>, delay=00:00:01, xdelay=00:00:01, mailer=relay, pri=30478, relay=smtp.easynet.be. [212.100.160.77], dsn=2.0.0, stat=Sent (OK id=1C8vO5-0002iw-D8)

but now I see the following in my log instead and i dont receive the email:

Sep 22 17:56:22 linux2 sendmail[4644]: i8MFuMQX004644: from=apache, size=2536, class=0, nrcpts=2, msgid=<200409221556.i8MFuMQX004644@linux2.wtl.be>, relay=apache@localhost
Sep 22 17:56:22 linux2 sendmail[4646]: i8MFuMPr004646: from=<apache@linux2.wtl.be>, size=2758, class=0, nrcpts=2, msgid=<200409221556.i8MFuMQX004644@linux2.wtl.be>, proto=ESMTP, daemon=MTA, relay=localhost.localdomain [127.0.0.1]
Sep 22 17:56:22 linux2 sendmail[4644]: i8MFuMQX004644: to=support@wtl.be,richard.walton@wtl.be, ctladdr=apache (48/48), delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=60155, relay=[127.0.0.1] [127.0.0.1], dsn=2.0.0, stat=Sent (i8MFuMPr004646 Message accepted for delivery)
Sep 22 17:56:22 linux2 sendmail[4648]: i8MFuMPr004646: to=<richard.walton@wtl.be>, ctladdr=<apache@linux2.wtl.be> (48/48), delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=60377, relay=smtp.easynet.be. [212.100.160.77], dsn=5.1.1, stat=User unknown
Sep 22 17:56:23 linux2 sendmail[4648]: i8MFuMPr004646: to=<support@wtl.be>, ctladdr=<apache@linux2.wtl.be> (48/48), delay=00:00:01, xdelay=00:00:01, mailer=relay, pri=60377, relay=smtp.easynet.be. [212.100.160.77], dsn=2.0.0, stat=Sent (OK id=1CA9UZ-0002RW-Pe)
Sep 22 17:56:23 linux2 sendmail[4648]: i8MFuMPr004646: i8MFuNPr004648: DSN: User unknown
Sep 22 17:56:23 linux2 sendmail[4648]: i8MFuNPr004648: to=root, delay=00:00:00, xdelay=00:00:00, mailer=local, pri=33782, dsn=2.0.0, stat=Sent

Any Ideas?





0
 
LVL 40

Accepted Solution

by:
jlevie earned 300 total points
ID: 12124636
I'm confused by your setup. You state that when it was working the hostname was wtl.2y.net, but then state that your private DNS is using linux2.wtl.be. That's two completely different hostnames & domains.

Could you provide a better explanation of the environment?
0
 

Author Comment

by:richardwalton
ID: 12125297
:)) well what a supprise. Its been about 6 hours since i've been unable to send email and you hit the nail on the head:))

Under the network settings I had:

192.168.0.229 = linux2.wtl.be
AND!!
81.188.8.66 = wtl.2y.net

a mistake that has caused me pain. Never to be made again.

THANKYOU for your coments and support, i wouldnt have done it without you:))

BiGUP Yaself!!
rIcHyRich:)
0

Featured Post

Master Your Team's Linux and Cloud Stack

Come see why top tech companies like Mailchimp and Media Temple use Linux Academy to build their employee training programs.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Install Predefined Certificate on Ubunto 4 37
add some character at the end of line in vi 7 78
ignore other .htaccess 2 43
centos commands 6 50
If you have a server on collocation with the super-fast CPU, that doesn't mean that you get it running at full power. Here is a preamble. When doing inventory of Linux servers, that I'm administering, I've found that some of them are running on l…
Google Drive is extremely cheap offsite storage, and it's even possible to get extra storage for free for two years.  You can use the free account 15GB, and if you have an Android device..when you install Google Drive for the first time it will give…
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
Learn how to navigate the file tree with the shell. Use pwd to print the current working directory: Use ls to list a directory's contents: Use cd to change to a new directory: Use wildcards instead of typing out long directory names: Use ../ to move…

785 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question