[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 288
  • Last Modified:

PLEASE HELP ASAP! OLD FOX PRO Program will not run...

We are up grading our computer systems.

The new server is running Windows 2003.
I installed FOXPRO 6.0 as we have new programs that use this.

I coppied from our old server a folder called FOX that contains some of our product information...
When I run the program from a clinet I get a  
Divide overflow error??

the short cut I am using is as follows:
Command line =  F:\PUBLIC\FOXPRORT.EXE cable
Workng dir = g:\fox\mike1\cable1

F: is a mapped drive and is mapped to the server
G: is a mapped drive and is mapped to the server

is there any way to make this work?
0
mrchaos101
Asked:
mrchaos101
  • 11
  • 11
1 Solution
 
RanjeetRainCommented:
Do you have the necessary permissions on the shared folder? May be the program needs full access and you have only read access.
0
 
RanjeetRainCommented:
Also, have you verified that these paths are valid and all the necessary files exist in the expected location?
0
 
mrchaos101Author Commented:
Yes the paths are there and the user has 100% access.  Happens even with the admin access.

I get "

Cannot Creat Program Workspace
Devide Over Flow

0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
RanjeetRainCommented:
What is your temp folder? Is it the DOS version of Foxpro? See the TEMP environment variable and see if a a folder exists at the path specified and the user has full access to the TEMP directory.

Do you launch FoxPro with a shortcut? Check the shortcut properties to see if you got a valid "start in" folder mentioned in it.
0
 
mrchaos101Author Commented:
As stated above,....
the short cut I am using is as follows:
Command line =  F:\PUBLIC\FOXPRORT.EXE cable
Workng dir = g:\fox\mike1\cable1

those path's and files are there.
Wha would be the old DOS default TEMP dir?
0
 
RanjeetRainCommented:
Default temp dir on DOS is C:\TEMP
0
 
mrchaos101Author Commented:
OK I added c:\TEMP on the clinet AND on the server and gave 100% access

same error

How can I find out what the temp folder is set to?
0
 
RanjeetRainCommented:
Does the directory g:\fox\mike1\cable1 exist? Does in have some files with primary name cable (cable.*)?
0
 
mrchaos101Author Commented:
As stated above,
Command line =  F:\PUBLIC\FOXPRORT.EXE cable
Workng dir = g:\fox\mike1\cable1

those path's and files are there.


in g:\fox\mike1\cable1  most all files are .dbf, .bom, or.blk



0
 
mrchaos101Author Commented:
This files are on a beta network.

I have the SAME folders, and icons withe same paramaters on the current network.  Windows NT4 and XP clients.

They work just fine.  I belive it has to do with a missing path folder or a settng in windows 2003
0
 
RanjeetRainCommented:
I am unable to establish why "Divide overflow error??"? My doubts, only you can help me help you.

Does your program run at all? Is this error being thrown by the OS or by FoxPro or by your application? Any clues? I believe TEMP folder and full permssion is all that is needed.

0
 
mrchaos101Author Commented:
Fox pro is giving the error,

it shows a black box on screen
In the middel it says

FoxPro/LAN 1.02 Runtim
<c> Fox Software 1989, 1990
U.S./Canadian Edtion
Runtim Serial #xxxxxxxxxxx
Base Serial # xxxxxxxxxxx

Cannot creat program workspace
Divide overflow

I have put a c:\temp on the client pc and given the user 100% access to that folder.
I have put a c:\temp on the SERVER and given the user 100% access to tht folder as well.

The applacation runs on XP machine when it is being called from a Windows NT 4.0 Server enviorment.

The applacation will not run on a XP machine when being called from a Windows Server 2003.

I have installed FOXPRO 6.0 on the server.
I have a NEWER foxpro app that is called from the server and runs fine.

I hope that helps. let me know if you need more info.
0
 
RanjeetRainCommented:
Do you know how to tweak the COMMAND PROMPT configuration file? On NT platform (probably) the file is known as config.nt

Try looking for such a file (config.*) on your client. If you find any, see what the vital parameters are. Modify the lines if any already present to:


dos=high, umb
device=%SystemRoot%\system32\himem.sys
FILES=100
BUFFERS=50

Lets see if that helps.

There is another check you may do. Try running your current version of Foxpro on your client locally. That will establish whether it is due to C/S setting or it doesn't like the client (Win XP).
0
 
mrchaos101Author Commented:

I changed the config.nt on the client from:

dos=high, umb
device=%SystemRoot%\system32\himem.sys
files=40

to

dos=high, umb
device=%SystemRoot%\system32\himem.sys
FILES=100
BUFFERS=50

I then rebooted the client.
Problem is still there.
0
 
mrchaos101Author Commented:
Foxpro is not installed on the client. Only the run time files.
0
 
RanjeetRainCommented:
Please check the installation manual. I am not sure whether the version of FoxPro you are using is even supported to be run this way or not. Besides, Win XP as an OS ceratinly differs at places from its predecessors. My suggestion would be to install a full copy of Foxpro on the client and see the result. Initially you may just do a test install to see if that method works.

0
 
mrchaos101Author Commented:
I think I have found the problem.

It seems that when you copy files over form an NT4.0 server to a 2k3 server the files become write protected.

AT THIS point in time, I am unable to remove the read only attribute not matter what I do.  I have a feeling that this is the cause of the old fox pro not to run.

Once I am able to remove the attribute I will post back the results.
0
 
RanjeetRainCommented:
Having read only files is as good as having read/write file in a read only folder.

Is that because of the ownership of the files? Select all these files in Windows Explorer and open their properties. Give yourself or the desired user/group the ownership of the files and then see.
0
 
mrchaos101Author Commented:
I have given my self owner ship and have tried as admin.

It will not rest. Im still researching it. I have started a thread on this issue but nobody has been able to resolve it.
0
 
santosh26676Commented:
With my understanding read-only attributes on system files should not generate an error. But are you sure that it is the shortcut and not the startup code in the application which is causing the issue. The error you have mentioned is because thenumber you are trying to store is too large for the variable. Please check the datatype compatibility of XP and WiN2003.

0
 
RanjeetRainCommented:
Hi Santosh,

Newer OSs will have bigger WORDs, allowing more data to be stored. Going by your logic, it will never fail on XP or 2003 because these OS will have at least as many bits per WORD as the older OSs.
0
 
mrchaos101Author Commented:
Hmmm.. I cannot seem to remove teh -r attibutes for the life of me.

I guess I will need to do a FAT32 format on a drive and COPY it over to FORCE the attributes to be removed, then copy from there to the hd with NTFS  <shrug>
0
 
RanjeetRainCommented:
That should help you remove the read-only tag.
0

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

  • 11
  • 11
Tackle projects and never again get stuck behind a technical roadblock.
Join Now