Solved

Visual Studio .NET has detected that the web server is running ASP.NETversion 1.0

Posted on 2004-09-22
26
421 Views
Last Modified: 2008-02-01
When I try to create a new ASP.NET web application I get the following error

Visual Studio .NET has detected that the web server is running ASP.NETversion 1.0, the web application you are creating or opening can be configured to be compliant with ASP.NET1.0.

However the application will not be able to use new features from ASP.NET 1.1

What do you want to do?

*Do not open the application, I will upgrade ASP.NET on the server to the latsest version before proceeding(reccomended).

*Make the application compliant with ASP.NET version 1.0.
0
Comment
Question by:rourkas1
  • 10
  • 8
  • 2
  • +3
26 Comments
 
LVL 15

Expert Comment

by:praneetha
ID: 12126511
0
 

Author Comment

by:rourkas1
ID: 12126765
praneetha tried the commands listed on http://support.microsoft.com/default.aspx?scid=kb;en-us;306005&Product=aspnet
 but still reciving the message
 
0
 
LVL 17

Expert Comment

by:AerosSaga
ID: 12126794
I would try to completely uninstall and reinstall both the framework and ASP.NET

Regards,

Aeros
0
 
LVL 2

Expert Comment

by:netjkus
ID: 12126883
use aspnet_regiis.exe

from a command prompt

C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322>aspnet_regiis -c

C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322>aspnet_regiis -i

0
 
LVL 2

Expert Comment

by:netjkus
ID: 12126915
Also, Clear the VSCache.
0
 
LVL 15

Expert Comment

by:praneetha
ID: 12126924
did it say regiis succeeded...
0
 

Author Comment

by:rourkas1
ID: 12126999
Praneetha yes
0
 
LVL 15

Expert Comment

by:praneetha
ID: 12127013
try restarting the machine and see if that's any help
0
 

Author Comment

by:rourkas1
ID: 12127015
Netjkus

did this but still no go

di notice that under the framwork directory there is a v1.0.3705 directory as well as a v1.1.4322 ???
0
 

Author Comment

by:rourkas1
ID: 12127042
in my internet information services I can't start my default web site comes up with address allredy in use ??
0
 
LVL 15

Expert Comment

by:praneetha
ID: 12127070
use  v1.1.4322 .....

type in localhost in Ie and see what it yields...

and then type the Ip address in Ie and check what it shows...

0
 

Author Comment

by:rourkas1
ID: 12127174
praneetha I don't follow you????
0
IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

 

Author Comment

by:rourkas1
ID: 12127178
restart didn't work.
0
 

Author Comment

by:rourkas1
ID: 12127192
oh i c localhost and the ip go to the same page
0
 

Author Comment

by:rourkas1
ID: 12127204
This wouldn't be anything to do with uninstalling/unregistering v1.0 ?????
0
 
LVL 15

Expert Comment

by:praneetha
ID: 12127217
>>>I can't start my default web site comes up with address allredy in use

what exactly u were trying to do there....
0
 
LVL 15

Expert Comment

by:praneetha
ID: 12127233
is this the fresh install of visualstudio.net framework / IDE...

or did u allready have something and u tried to update it
0
 

Author Comment

by:rourkas1
ID: 12127278
Would you suggest a complete reinstall ???

starting of the default web site I thought this may have been another affect.
0
 
LVL 15

Expert Comment

by:praneetha
ID: 12127301
well i guess may be

 Uninstall both the framework and the ide, then reinstall the IDE first and then the framework (1.1).
0
 
LVL 15

Expert Comment

by:praneetha
ID: 12127309
or just try uninstalling framework and reinstalling and see if it is of any help.
0
 
LVL 8

Expert Comment

by:daffodils
ID: 12128033
Project --> Properties --> Project Property Pages dialog -->

Common Properties -->General --> Application -->Supported Runtimes

Click the ellipsis (…) button to open the .NET Framework Version dialog box.

What is the default ASP.NET version there ??
0
 

Author Comment

by:rourkas1
ID: 12138825
This probelm seems to have been due to an install of oracle which was running apache ...stopped apache now all ok...
0
 
LVL 17

Expert Comment

by:AerosSaga
ID: 12333728
self answered question...refund

Aeros
0
 
LVL 1

Accepted Solution

by:
Computer101 earned 0 total points
ID: 12393706
PAQed, with points refunded (500)

Computer101
E-E Admin
0

Featured Post

Free Trending Threat Insights Every Day

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

Join & Write a Comment

IntroductionWhile developing web applications, a single page might contain many regions and each region might contain many number of controls with the capability to perform  postback. Many times you might need to perform some action on an ASP.NET po…
User art_snob (http://www.experts-exchange.com/M_6114203.html) encountered strange behavior of Android Web browser on his Mobile Web site. It took a while to find the true cause. It happens so, that the Android Web browser (at least up to OS ver. 2.…
This video discusses moving either the default database or any database to a new volume.
Illustrator's Shape Builder tool will let you combine shapes visually and interactively. This video shows the Mac version, but the tool works the same way in Windows. To follow along with this video, you can draw your own shapes or download the file…

744 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

10 Experts available now in Live!

Get 1:1 Help Now