[Last Call] Learn about multicloud storage options and how to improve your company's cloud strategy. Register Now

x
?
Solved

Linksys wirles router WRT54G - problem connecting to internet via another router

Posted on 2004-09-22
7
Medium Priority
?
16,894 Views
Last Modified: 2013-11-29
My current network consists of a PC using w2000 professional & a wireless enabled laptop using XP. Both use cables to connect to a Conexant Dynamode ADSL router which is connected directly to the broadband.

I want to convert the network to a wireless network. Thus I purchased Linksys Wireless G Broadband router (model WRT54G) + USN network adaptor  (model WUS54G) for the desktop.

I was told that I could simply take an output from the Dynamode ADSL router into the Broadband socket of the Wireless G Broadband router, then set up as per instructions in the box.  Ignoring the PC for the time being, I hard wired the laptop to the wireles router (per instructions) which in turn is wired to the Dynamode ADSL router. I tried to connect to the internet but without success.  The firewall has been disabled.

I tried changing the laptop IP address to one not already on the system (192.186.1.2) and pointing the default gateway to the router default of 192.168.1.1 per wireless router instructions. TCP/IP is ticked. No success.

I have also tried pinging 192.168.1.1 from the system prompt on the laptop but get no response. I have rechecked all wiring, pressed the reset switch to ensure the router is set to factory default, rebooted everything but still cannot ping 192.168.1.1.  I have also changed the cables to prove that is not the problem.

Can anyone suggest what I do next please.  Many thanks
0
Comment
Question by:Nocturne
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
7 Comments
 
LVL 6

Expert Comment

by:darkfriend
ID: 12129586
You have performed textbook solutions on this problem.  The laptop should be able to ping the router.  My first instinct is that the ADSL router is already using IP 192.168.1.1.  Do you remember what IP address your computer received when connected to the ADSL router?

All-in-all if you connect ONLY your computer(any) to a numbered port on the router and DO NOT connect the modem to it at all you should be able to ping 192.168.1.1, especially if you use a static IP address (i.e. 192.168.1.50/255.255.255.0/192.168.1.1).  If that works probably they have the same IP.  If not probably the router is defective or NIC port in laptop is bad or missing driver.  Also try same idea just hook the router to the desktop with wire or wireless and try to ping.  You don't need internet to establish connection to the router.
-DF
0
 

Author Comment

by:Nocturne
ID: 12138408
Many thanks. What I have found out is that the IP address of my computers have to be in the 192.168.1.xxx range, not 192.168.0.xxx range. Changing the PC IP address to the 1.xxx range and I can now ping the wireless modem ((default 1.1).

The conexant router connected to the internet is set up as 192.0.0.254. I wish to keep this between the wireless modem and the internet. I presime I will need to change the conexant IP to 1.xxx as well?

If so, can you confirm if the following is correct?
Conexant router to internet 192.168.1.254 / 255.255.255.0
Wirless router to above 192.168.1.1 / 255.255.255.0 / internet gateway 192.168.1.254
PC 192.168.1.2 / 255.255.255.0/ default gateway 192.168.1.1 (?)
laptop 192.168.1.3 / 255.255.255.0 / default gateway 192.168.1.1 (?)
As yo may gather thsi is something I am not at home with.
Many thanks. N
0
 
LVL 6

Accepted Solution

by:
darkfriend earned 1000 total points
ID: 12139709
"I presime I will need to change the conexant IP to 1.xxx as well?"

Actually that is not correct.  You cannot have 2 routers on the same subnet(192.168.1.x).  At least not practically.  Both have DHCP servers and will conflict with one another, so you never know which one will give you the right IP address.

If you can ping now just leave it be.  Leave the IP address alone for the conexant, 192.0.0.254 should work.  You can plug the conexant router to the WAN port of the Linksys and it should work fine as is.  The Linksys should get a WAN ip address of 192.0.0.2, or similar, and a default gateway of 192.0.0.254.  The computer's configurations above are correct.  Your computers will look to the Linksys(default gateway) for internet and the Linksys will look to the Conexant(default gateway) for it's internet.  All should be well.

Unplug both from power, plug in the conexant first...wait for good lights, then plug in the Linksys.
-DF
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
LVL 6

Expert Comment

by:darkfriend
ID: 12139733
You could also use your original plan with the IP numbers you chose and simply turn off the Linksys DHCP server, then connect the conexant to a # port on the Linksys.  This will simply use the Linksys as a wireless switch(or access point).  This assumes the conexant is capable of handling multiple IP addresses.  I've done both ways.
-DF
0
 

Author Comment

by:Nocturne
ID: 12141226
Hi DF
Success. I will look at the wireless side later when I recover from the shock..

For the benefit of others I did the following:
Laptop: changed IP to 192.168.1.3
opened web browser to hyyp://192.168.1.1
Setup page - Automatic DHCP.  Disabled DHCP server. Saved setup
Advanced routing: Changed gateway to router. Disabled dynamin routing. Saved setup
Basic setup: changed local IP to 192.168.0.10, subnet 255.255.255.0. Save & close browser
Laptop: changed IP to original 192.168.0.2

Many thanks for your help. Best wishes. N  

0
 

Author Comment

by:Nocturne
ID: 12141258
ps the wire from the Conexant router had to go into one of the standard ports not the WAN port.
0
 
LVL 6

Expert Comment

by:darkfriend
ID: 12149072
I'm glad I could at least bat around some ideas with you.  Sounds like two heads are better than one.  Glad you got it working.
-DF
0

Featured Post

Plesk WordPress Toolkit

Plesk's WordPress Toolkit allows server administrators, resellers and customers to manage their WordPress instances, enabling a variety of development workflows for WordPress admins of all skill levels, from beginners to pros.

See why 2/3 of Plesk servers use it.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Short answer to this question: there is no effective WiFi manager in iOS devices as seen in Windows WiFi or Macbook OSx WiFi management, but this article will try and provide some amicable solutions to better suite your needs.
This article will inform Clients about common and important expectations from the freelancers (Experts) who are looking at your Gig.
NetCrunch network monitor is a highly extensive platform for network monitoring and alert generation. In this video you'll see a live demo of NetCrunch with most notable features explained in a walk-through manner. You'll also get to know the philos…
Michael from AdRem Software explains how to view the most utilized and worst performing nodes in your network, by accessing the Top Charts view in NetCrunch network monitor (https://www.adremsoft.com/). Top Charts is a view in which you can set seve…

650 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question