Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Unable to ping Windows XP machine in the network

Posted on 2004-09-22
8
Medium Priority
?
12,719 Views
Last Modified: 2010-07-27
I run a server on my workstation, and also try to VPN from home, but my box has never been accessible.  I can ping anyone else on my team, and they can use my computer name to ping me, and when they do, it shows the resolved IP address -- but the request times out.

I have tweaked all the settings I can think of, but no dice.

It is a Windows XP Pro system.  The firewall is turned off, and there is no other firewall software running.  I can get out fine (pcAnywhere, internet, email), but no one can get to me.

Here are the current TCP/IP settings:
General
---------
Obtain an IP address automatically; Obtain DNS server address automatically

Advanced - IP Settings
--------------------------
IP addresses: DHCP Enabled
Default gateways: (blank)

Advanced - DNS
------------------
DNS server addresses: (blank)
Append primary and connection specific DNS suffixes selected
Register this connection's addresses in DSN checked

Advanced - WINS
--------------------
WINS addresses: (blank)
Enable LMHOSTS lookup checked
NETBios Setting: Default

Advanced - Options
----------------------
Optional Settings: TCP/IP Filtering Properties: Enable TCP/IP filtering (All Adapters) unchecked
Note: on this setting, I tried selecting "Permit All" on TCP, UDP, and IP, and both checking and unchecking the checkbox, applying all the way out, and then rebooting.

In the LAN Properties/Advanced/Windows Firewall/Settings, the firewall is off.  But under Exceptions, everything is checked except File and Printer Sharing and UPnP Framework.

On the Advanced tab: Local Area Conection/Settings/Services, Remote Desktop is checked (nothing else really applies), and everything is checked on the ICMP tab.   Back on Advanced/ICMP/Settings, everything is checked.

So I'm at my wits end.  What is wrong?
0
Comment
Question by:perljavageek
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
  • 2
  • +1
8 Comments
 
LVL 1

Expert Comment

by:jonathan6587
ID: 12128971
perljavageek

Resolving computer name to IP is a DNS function (assuming you're not on the same LAN).  

If your ping times out - there is something blocking ICMP between your computer and your team.  Most likely a router or firewall.  

Do you have a BroadBand connection?  If so are you using a Cable/DSL router?

-Jonathan
0
 
LVL 3

Accepted Solution

by:
hehewithbrackets earned 500 total points
ID: 12128973
Can you describe your network topology a little more?  These team members are all people on the same LAN?  How are you connected to each other?  All of the information you gave simply says that your computer is using DHCP.

You referred to settings in your LAN Properties.  I'm not sure which dialog windows you are referring to but generally speaking you want File and Printer sharing to be turned on.  That setting is normally in the main dialog window of your Local Area Connection settings.

'I run a server on my workstation'.  What kind of server are you talking about?
0
 

Author Comment

by:perljavageek
ID: 12137861
I talked to our network admin, and here is what he told me:
1.  In this case, all of us are on the same vLAN -- in fact we're all on the same blade of the router.  The network topology is a simple bus.
2.  Yes, something is blocking ICMP.  Something is blocking everything.  It is, in fact, acting like a firewall is blocking all access to my box.  But I do not have a firewall running.  At least, I don't think so.  Windows firewall is definitely turned off.
3.  We have a T1 connection.  That's not really relevant here.  I just have a network card in my box.
4.  Everything from my description above comes from Local Area Connection properties.  Sorry if I was unclear.
5.  As far as what kind of server I run, it doesn't really matter.  I've run numerous servers -- Apache for one.  I've used a couple of others, but the bottom line is that they're inaccessible anywhere off this box.

I'm going to try to solve this first, but if I can't then I'll just make backups and re-stage the box.  Hate to do that, though.  I await your response.  :)
0
Will your db performance match your db growth?

In Percona’s white paper “Performance at Scale: Keeping Your Database on Its Toes,” we take a high-level approach to what you need to think about when planning for database scalability.

 
LVL 3

Expert Comment

by:hehewithbrackets
ID: 12138186
1.  Ok, so you are on a simple LAN and cannot communicate with the other clients on your network.  Are you really connected to a router or a switch?
2.  Ok, Windows firewall is not on.  Good.
3.  You are correct that your T1 connection is not relevant here, but you mentioned inaccessible connection through VPN so it was unclear what your problem was.  You want to first make sure you can communicate with your LAN before tackling any VPN issues.
4.  I'm still a bit unclear, but file and printer sharing MUST be enabled.  You said it was unchecked in your description above.  Please double check this.
5.  How could you have run numerous servers on a machine that is inaccessible to the rest of your network?

Out of curiosity, why are you working on this problem instead of your network admin?  Communicating with the rest of your LAN is a basic function of your network or are you guys tackling this problem together?
0
 

Author Comment

by:perljavageek
ID: 12183353
Sorry for the delay.

1.  [snip]  ...Are you really connected to a router or a switch?

It's a switch.  They refer to it here as a Cisco blade.

4.  [snip]  ...file and printer sharing MUST be enabled...

It wasn't enabled.  I enabled it and rebooted, and communication is still blocked.  Bummer.

5.  How could you have run numerous servers on a machine that is inaccessible to the rest of your network?

Running and accessible are 2 different states, so I'm not really sure where you're going with the question.  They ARE accessible from within the box itself.  So, for example, when I run Apache, I can open http://localhost/index.html.  But if you're on my network and try going to my box at http://10.1.20.13/index.html, and you'll get nowhere.

The network admin has looked at this twice, which is a feat in and of itself, considering that getting him to check out my box is nigh unto seeking an audience with the Pope.  He's very busy (as we all are); he has very little help, and we really need more.  He's actually pretty good, but leave it to me to expose his deficiencies... :D

Now I'll expose MY lack of networking knowledge here by asking: is it possible to network 2 computers together without a hub?  That is, can you just run an ethernet cable from the network card of one box to the card of the other?  If I could do that, it would quickly pinpoint my box as the problem.

Is there a software utility I could use to try to isolate the trouble?  I have used some of the stuff on www.sysinternals.com before, so I'm wondering if something they have could help me see why traffic is getting blocked.
0
 
LVL 1

Expert Comment

by:jonathan6587
ID: 12184708
perljavageek

>> can you just run an ethernet cable from the network card of one box to the card of the other?

Yes, a crossover cable.  


>>Is there a software utility I could use to try to isolate the trouble?  I have used some of the stuff on www.sysinternals.com before, so I'm wondering if something they have could help me see why traffic is getting blocked.

What I normally do in situations like this is run a sniffer on the box I'm trying to reach to see if the packet I'm sending actually makes it to the computer.  


Try ethereal - ftp://mirror.sg.depaul.edu/pub/security/ethereal/win32/
you also need to download winpcap --> ftp://mirror.sg.depaul.edu/pub/security/ethereal/win32/

Ethereal Main Page --> http://www.ethereal.com/


Jonathan
0
 

Author Comment

by:perljavageek
ID: 12192306
Eureka, problem solved.

Yesterday I spoke to a guy named David, who works in another department, who in turn got me in touch with Mike, who is Craig's boss -- Craig is the IS guy who had looked twice at my box.  Mike is our company's webmaster and SA (and used to work for David).  Mike came down and tried some other things, including disabling the onboard NIC and installing a NetGear card instead, suspecting that maybe there was a rule based on the card's MAC address that was restricting access.  However, this wasn't the case, so we had eliminated hardware as the source of the trouble.

Turns out this box had the Cisco VPN client software running as an automatic service, and while it should not have been breaking things...it was.  As soon as he disabled the service, my box responded to a Linux server from which I was pinging.

When I got home, I opened a connection from my personal system to our corporate VPN server and was able to get a Windows login prompt.  I put in my user/pass and got on without delay.

Thanks to everyone that offered help.
0
 
LVL 1

Expert Comment

by:MasterCheef
ID: 21724020
if you go to the cisco VPN cleint and make sure the stateful firewall always on is unchecked and restrat the cisco service it will work.
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I had an issue with InstallShield not being able to use Computer Browser service on Windows Server 2012. Here is the solution I found.
If you’re involved with your company’s wide area network (WAN), you’ve probably heard about SD-WANs. They’re the “boy wonder” of networking, ostensibly allowing companies to replace expensive MPLS lines with low-cost Internet access. But, are they …
Viewers will learn how to connect to a wireless network using the network security key. They will also learn how to access the IP address and DNS server for connections that must be done manually. After setting up a router, find the network security…
In this video we outline the Physical Segments view of NetCrunch network monitor. By following this brief how-to video, you will be able to learn how NetCrunch visualizes your network, how granular is the information collected, as well as where to f…

670 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question