Solved

No Dial Tone, LT Winmodem, Windows ME

Posted on 2004-09-22
21
658 Views
Last Modified: 2013-12-27
Many thanks in advance,

I'm running a Dell Inspiron 5000, pentium III, Windows ME.  It's a "new" hand-me-down, and have recently transferred all files (mostly just Word docs & email).  I installed an HP printer, Iomega Zip--everything worked fine, for about 3 days.  Suddenly, the LT Winmodem, already installed and functional on COM3, stopped working.  No Dial Tone (no lightning storms or anything--don't think it's mechanical).  For a while, also had the "port already open" problem in the CP Diagnostics, but that's fixed now. I know very little, but I think I may have messed things up in Device Manager (I know just enough to cause mischief, I'm afraid), and that my problem is either driver or IRQ conflict-related.

After scouring this & other boards, here are the things I've tried:

1. Updated drivers: nothing; following the advice of a link recommended here, I then "downgraded" using ltremove.  Currently, am at File Version 4.90.3000 for LT Winmodem.  It actually lists two drivers in the "Driver File Details" in the Device Man.: WDMMDMLD.VXD and VMM32.VXD (vcomm.vxd).  Under "WDM Modem Enumerator/WDM Communication Device" (a separate tree in Device Manager), I am at driver version 5.79.

2. Uninstalled/reinstalled modem: more times than I can count; no effect.

3. Although no conflicts are listed for any device, I noticed what appears to be a bad IRQ conflict (Winmodem--listed here as "WDM Communication Device"--is on IRQ 5; but so is ESS Device Manager, and Intel 82371AB/EB PCI to USB Universal Host Controller, as well as ACPI IRQ Holder for PCI IRQ Steering.  All on IRQ 5.  Device Manager/Windows will not let me switch IRQ assignments manually.  So I uninstalled ESS Device Manager, hoping it would choose another IRQ on startup.  No luck.  

4.  Uninstalled Iomega Drive.  (Seems unrelated, but I figured why not?)

--Another, possibly symptomatic quirk: My default dial-up "Connect To" window spontaneously opens when I click on Device Manager (and, actually, last time during startup even appeared out of nowhere on the pre-desktop wallpaper...).  What's going on here?  Is it possible I've got a bad TCP/IP file, or something?  My settings all appear normal there...

Any and all help will be hugely appreciated.  I'm driving myself nuts, and fear I'm only doing more damage.  Plus, I'm a teacher & rely on e-mailing from home to communicate with students.  Sorry to flag with such urgency, but this is a particularly bad & time-sensitive problem for me.  Thank you for your help.

Robert

0
Comment
Question by:rlg207
  • 6
  • 3
  • 2
  • +4
21 Comments
 
LVL 5

Expert Comment

by:XSINUX
Comment Utility
Try unchecking the wait for dial tone before dialing check box.

1) Go to the Control Panel.

2)Double click on the Modems Icon (may need to click on Show All icons to see modem icon).

3)Select their modem and left click on Properties.

4)Choose the connection tab and uncheck the dial tone check box.

5) Then Try Dialling.

Hope this Helps.

Cheers
Sinu
0
 
LVL 23

Expert Comment

by:DanCh99
Comment Utility
If you're getting Connect windows when you're nowhere near the internet, then I'd suspect either a dialler program or virus has infected your pc.
Get Spybot from
http://www.safer-networking.org/en/download/index.html
and give that a spin.  You may need some other spyware progs too.

for viruses, try these:
1. http://us.mcafee.com/root/mfs/default.asp?cid=9059
2. http://security.symantec.com/
3. http://housecall.trendmicro.com/
4. http://www.pandasoftware.com/activescan/com/activescan_principal.htm
5. http://www.pcpitstop.com/antivirus/default.asp
6. http://vil.nai.com/vil/stinger

list (c) deepthiji  !
0
 

Author Comment

by:rlg207
Comment Utility
Thank you Sinu & DanCh99 for your suggestions.

Sinu: I did try unchecking the "wait for dial tone" option; no luck.  The modem dials, but gets nothing--it doesn't appear to connect to the line out.  I should mention, too, that I checked the phone line with a telephone, and with another laptop--it works in both cases (with the other laptop connecting at 50.6).

DanCh99: I scanned the hard drive with Norton AntiVirus; everything checked out clean.  Spybot & Adaware turned up a few cookies, but that was it.  After re-booting & trying again, I still get no dial tone.  

Any other suggestions?  Again, I highly doubt the modem connection is fried--it worked fine for the first three days I had it (connecting up to 53); then suddenly stopped detecting a dial tone. It seems like it must be a side-effect of my monkeying around (installations, customization of settings, etc.)--but I have no good ideas about how to fix it.  Any other ideas will be much appreciated.  

Thanks,
Robert
0
 
LVL 5

Expert Comment

by:XSINUX
Comment Utility
Open the Modem Door ( Check the Link on how to opne the Modem ) and check if the Modem Cable is connected to  the Modem Daughter Card or have it reseated. http://support.dell.com/support/edocs/systems/pblan/removing.htm#modem

The Modem functionality on the Inspiron integrates part of the curcuits on a removable Modem Daoughter Board and the rest is integrated on the Laptop's Motherboard. We would'nt know in this case where the fault lies. You may end up replacing the Motherboard whcih maybe very expensive. But if its the Daughter card then its cheap. Unless you confirm this go for a PCMCIA modem.

This Link will help you see how to remove your modem. http://support.dell.com/support/edocs/systems/pblan/removing.htm#modem


Better go for a PCMCIA modem if the Above Fails. These PCMCIA modems are not too expensive.

Some info on your PCMICA Slot :
http://support.dell.com/support/edocs/systems/pblan/specs.htm
PC Card Slot
PCI controller  Texas Instruments PCI 1225 CardBus controller
PC Card connectors  two (supports two Type I cards, two Type II cards, or one Type III card)
Cards supported  3.3 V and 5 V  
PC Card connector size  68 pins  
Data width (maximum)  32 bits

0
 
LVL 1

Expert Comment

by:kirklandltduk
Comment Utility
As its windows ME have you tried to restore to a previous restore point?
Go to System Tools, System Restore

Other than that start the computer in safe mode by pressing F8 at boot up and remove any modems listed including Modem Enumerator then reinstall the modem.
0
 

Author Comment

by:rlg207
Comment Utility
Thank you for your suggestions.  Unfortunately, things have taken a VERY drastic turn for the worse.  Help!

System restore didn't help.  So I started in safe mode to see what came up in the Device Manager (to see if Modem Enumerator was still there, etc.).  It wasn't--the system appeared to be restored correctly to where it was last week.  On a hunch (a very bad, bad hunch), I decided to reassign the IRQ for the modem from 5 (which, as I mentioned, seemed heavily loaded) to 11, which was free (and which I was allowed to do in safe mode).  

After doing so, it prompted for a restart; after hitting ok, I waited--unexpectedly, it did not restart normally, but went to the screen where one can choose from (I believe) 3 options--regular Windows startup; safe mode; step-by-step confirmation.  Not suspecting anything was truly amiss, I decided to go with step-by-step confirmation to see what that would tell me.  After hitting yes/ok for every prompt (I got through about ten drivers), the computer suddenly switched off.  Now, when I turn on the computer it will give me a very brief "Windows ME" screen, then tell me that I have an invalid system disk (with the prompt, "Replace and Strike any key when ready").  There is no disk of any kind in the machine (right now, I have two batteries in the bays; and the floppy is mechanically broken--it has no disk in it, and has not had one since I got the machine).  Striking any key just repeats the message.  Hitting F8 at startup does not circumvent this; I can't seem to get away from this.  

What happened?  How can I fix this?  Right now, the modem is the least of my worries....  I just want to get back to where I was.  Please say I haven't completely broken this machine.  Can someone help?

Robert
0
 

Author Comment

by:rlg207
Comment Utility
Correction: Although this is probably obvious, it doesn't show a "Windows ME" screen prior to the "Invalid System Disk" prompt (as I wrote in my last post), but rather the blue Dell/Inspiron screen.  Also, it makes noise at the floppy drive whenever I hit a key at the ISD prompt--like it wants to go there, instead of the hard drive.  Did I inadvertently hit the wrong key at the wrong time in the step-by-step confirmation?  I'm completely baffled.

Thanks again for all of your patient help--and apologies for mishandling your excellent advice.  But any further help will be much appreciated.

Robert
0
 
LVL 31

Accepted Solution

by:
rid earned 168 total points
Comment Utility
This does sound like a hard drive problem. You may need to boot off something else (sincd FDD broken, you have only CD as a "choice") and see if you can access the hard drive to do some diagnostics.

First, however, you should take a look in BIOS setup (I believe you hit F2 at the POST (Dell) screen) to determine if the HD is indeed detected by BIOS. If not, your only reasonable course of action is to remove the HD and hook it up to another machine and try to rescue anything you need. If it is recognised in BIOS, you may have the opportunity to reinstall or repair ME (I don't know much about that O/S) without losing your documents etc.

If you find that you want to diagnose or zero-fill the hard drive to give it a last chance, you might find it worth while to get a new FDD as it is a lot easier to make and use floppies for these purposes than CD's; at least I think so.

I don't think your actions brought this on - the HD was probably having some not-so-obvious problems already.
/RID
0
VMware Disaster Recovery and Data Protection

In this expert guide, you’ll learn about the components of a Modern Data Center. You will use cases for the value-added capabilities of Veeam®, including combining backup and replication for VMware disaster recovery and using replication for data center migration.

 

Author Comment

by:rlg207
Comment Utility
Thanks RID,

BIOS does recognize the hard drive.  So that's a small positive.  Getting a new FDD does seem like a good idea; but that likely won't happen for a while.  To complicate matters, I don't have the Windows ME CD.  Question: can I burn the contents of a regular startup disk (I've heard the 98 boot disk is better than teh ME version) onto a blank CD, then try to boot up from the CD?  That might at least give me a chance to save unbacked-up files before trying anything else.

If the hard disk is indeed failing, how can I test that?  More specifically, to which hard drive diagnostics were you referring?  

Thanks,
Robert
0
 
LVL 31

Expert Comment

by:rid
Comment Utility
Your problem is very likely going to be finding a medium to which you can save your files, something you can write your files to... you'd need USB or network support and a USB or network drive to save them to. Which may be a bit complicated... you could of course use a Knoppix CD that will boot you into a network-capable environment (probably with USB support, too) and copy your files from the HD, if it is accessible. FAT or FAT32 is no problem for Knoppix, but if you're not familiar with Linux, there'll be some new things to learn. It's free, though...

The diagnostic I was thinking about is probably available at the HD maker's web site. You may be able to find out details about the HD in BIOS setup (sometimes it will show particulars in the detection screen in BIOS setup) or you can just pull out the HD and look at the label to get maker info.

/RID
0
 
LVL 23

Assisted Solution

by:DanCh99
DanCh99 earned 166 total points
Comment Utility
Making bootable CDs is a little more complicated than copying files from a floppy, but not much - the full How To is here:
http://www.informationweek.com/story/showArticle.jhtml?articleID=10700681
 - but you say you don't have a CD for an OS, which may make some bits tricky.  

The easiest way to get data off may be to remove the laptop hdd, and fit it to a pc with a converter
eg
http://www.laptopshop.co.uk/cyberlink-25hddkit-laptop_hard_drive-1-hd2.htm
obviously you just need the cable.

If the disk reads ok from either a boot disk or another pc, it may be salvagable - we can advise on this at the appropriate time!
0
 
LVL 10

Assisted Solution

by:tfjeff
tfjeff earned 166 total points
Comment Utility
the diagnostics you need are called the dell32 bit diagnostics, they are available here:
http://support.dell.com/support/downloads/format.aspx?c=us&cs=19&l=en&s=dhs&SystemID=INS_PNT_P03_5000&os=WW1&osl=en&deviceid=196&devlib=13&category=0&releaseid=R15505

unfortunately they require that you boot from floppy diskettes, obviously this cannot be done...if you still have your drivers and utilities CD that came with the system originally, you can boot to it and run the same diags.  Also try pressing ctrl+alt+D at the dell screen, that might work but I think this particular notebook is too old for that.
good luck
jeff
0
 

Author Comment

by:rlg207
Comment Utility
rid, danch99, jeff--

You've all been extremely generous and helpful.  On a lark, I decided to see how damaged the reputedly "broken" floppy disk drive actually is--answer, pretty messed up, but intermittently functional (i.e., frequent data errors).  Using the customized me startup disk from bootdisk.com, I did manage to get to MS-DOS.  This is what I've found:

scanreg /restore--"No backups were found to restore."; "System restore operation failed."

scanreg /fix--"Windows found an error in your system files and was unable to fix the problem.  Try deleting some files to free up disk space, etc., etc."  

c:\>win--bad command or file name.

c:\>dir--"Volume in drive C has no label...  The directory of C contains four titles (with weird names like j, (j, one with a greek letter...all with 12:00a time signatures...  They take up a grand total of 108, 736 bytes, leaving some 8500 MB "free"

This all seems like very bad news.  But I have no idea what any of it means.  Has anyone seen this before?  Of what is this symptomatic?  Corrupted system files?  A failed hard disk? Some pernicious virus my outdated Norton antivirus did not detect?

I haven't had a chance to try the dell diagnostic--but is it worth it?  At this point, I can't imagine it'll tell me anything I especially want to hear...  Is there anything to be done?

Yours, perseveringly,
Robert
0
 
LVL 31

Expert Comment

by:rid
Comment Utility
Sounds like corruption in the FAT's. Data is still there, probably, but inacessible as the File Allocation Table(s) may be shot.

Moving the HD to another machine and running a data recovery program is probably the best way to go from here.
/RID
0
 
LVL 10

Expert Comment

by:tfjeff
Comment Utility
if you can boot to a floppy, there is a utility that may work called hddct.exe (hard disk drive confidence test)
at dell's website...
looks like its now called dhddct13.exe, here's the link
http://support.dell.com/support/downloads/format.aspx?releaseid=r22209&c=us&l=en&s=dhs&cs=19
don't know if the I5000 is going to support that or not, but it might...if it's not supported it either won't see the drive or will give you a message that the drive is not supported.  
I'd run this after you try and recover data, or if it locks up or gives you problems when trying to recover data.
Definately run the diagnostics before you try reinstalling windows.
good luck
jeff

0
 

Author Comment

by:rlg207
Comment Utility
Hello.  

Sorry for the slow reply.  Would like to close out the question, but am having trouble figuring out how to assign points without  "accepting" a solution.  I received excellent advice here, but none were exactly teh problem--I had to take it to a repair store, and they inform me that the motherboard is fried.  Won't accept os installs, won't even permit hardware diagnostics.  If possible, may I split the 500--250 to rid, 125 to danch99, and 125 to tjeff?

Thanks.
0
 
LVL 13

Expert Comment

by:frankhelk
Comment Utility
The quesion comments thread looks like it ran somewhat out of the initial topic,
but (even with no points to expect) I would like to add something to the modem
part of the discussion.

The tip from XSINUX failed, as you've stated. If that box won't work, you might go to
"Advanced settings" (or similar, reached thru a button) and enter

X3

into the field "additional modem commands" (or similar field name). This does the
same as the checkbox, but in a more "basic" way.

Best regards

Frank
0

Featured Post

Free Trending Threat Insights Every Day

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

Join & Write a Comment

Broadband over Power Lines Broadband over Power Lines is the technology of transmitting computer data through power lines. This method of connectivity allows the user to have access to the internet without having to rely on additional cables, suc…
 One of the main issues with network wires is that you never have enough.  You run plenty and plan for the worst case but you still end up needing more.  What many people do not realize is with 10BaseT and 100BaseT (but not 1000BaseT) networks you …
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…
This video shows how to remove a single email address from the Outlook 2010 Auto Suggestion memory. NOTE: For Outlook 2016 and 2013 perform the exact same steps. Open a new email: Click the New email button in Outlook. Start typing the address: …

763 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

14 Experts available now in Live!

Get 1:1 Help Now