Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Turn off Smart Linking in Crystal Reports 10

Posted on 2004-09-23
6
Medium Priority
?
1,075 Views
Last Modified: 2010-11-30
How do you turn off smart linking in Crystal Reports 10?  I've had to relink my tables in CR for the 15th time because of not have the ability to turn off smart linking.  This is driving me crazy!!  I used to be able to turn this option off in past versions.  Why isn't there an option now?

Thanks for your help!

Bill
0
Comment
Question by:blouckswwu
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
6 Comments
 
LVL 28

Accepted Solution

by:
bdreed35 earned 500 total points
ID: 12133753
There is a registry key that allows you to disable the Smart Linking feature.
Follow the steps layed out in this BO KB article:
http://support.businessobjects.com/library/kbase/articles/c2014792.asp
0
 

Author Comment

by:blouckswwu
ID: 12133796
When I change it to no and reload Crystal Reports it changes it back to yes.  Am I missing something here?

I can't believe you have to go into the registry to change this.  Why did they take the option out of the menus?

Thanks

Bill
0
 
LVL 28

Expert Comment

by:bdreed35
ID: 12133856
Close the Crystal Report designer before you make the change, make the change, then open it up again.

Not sure why they took that option out of the tool, but at least it is still availble to disable!
0
Important Lessons on Recovering from Petya

In their most recent webinar, Skyport Systems explores ways to isolate and protect critical databases to keep the core of your company safe from harm.

 

Author Comment

by:blouckswwu
ID: 12133901
That did it!  Thanks for your help!

Have a nice day!!
0
 
LVL 28

Expert Comment

by:bdreed35
ID: 12134186
No problem.  Glad you got it working!
0
 
LVL 44

Expert Comment

by:zephyr_hex (Megan)
ID: 32699822
that link doesn't work anymore.  
here's the reg key location:
HKEY_CURRENT_USER\Software\Crystal Decisions\10.0\Crystal Reports\DatabaseOptions

the key is called "DoAutoSmartLinking"

in my case, it was originally set to No, which sounds like it's disabled.  but i was still getting "smart links".  so for kicks, i set the key to Yes.  and now smart links are disabled.
0

Featured Post

Enroll in September's Course of the Month

This month’s featured course covers 16 hours of training in installation, management, and deployment of VMware vSphere virtualization environments. It's free for Premium Members, Team Accounts, and Qualified Experts!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Crystal Reports: 5 Tests for Top Performance It is complete, your masterpiece report.  Not only does it meet your customer’s expectations, it blows them out the water, all they want is beautifully summarised and displayed in a myriad of ways. …
Hello everyone, Hope you find this as helpful as we did. We have on the company I work for an application built in Delphi V with Crystal Reports 8. We all know that Crystal & Delphi can be temperamental sometimes and the worst thing is, nearly…
This tutorial will teach you the special effect of super speed similar to the fictional character Wally West aka "The Flash" After Shake : http://www.videocopilot.net/presets/after_shake/ All lightning effects with instructions : http://www.mediaf…
In this video, Percona Director of Solution Engineering Jon Tobin discusses the function and features of Percona Server for MongoDB. How Percona can help Percona can help you determine if Percona Server for MongoDB is the right solution for …

670 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question