[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 526
  • Last Modified:

500 POINTS On Click Event not firing on specific machine C# ASPX 500 POINTS

The strangest thing has happened.

We are currently working on a project and using 6 identical development machines which all werre ghosted.  Last week one of the guys installed the service packs for windows XP and all of a sudden none of the buttons on a a specific project fire an event to the web server.  We have uninstalled and reinstalled visual studio.net 2003 EA.  Deleted all of the virtual webs associated with the project deleted all of the source code associated.  reinstalled VS.NET and got the latest version from source safe which makes him current with everyone else.  Still the button press will not fire an event on the server.  We did put break points on the button onClick  event bt it doesn't even get there.  

This button is used for the sign in page and there is a userid and password text box on the psge.  if nothing is entered we do get the required field error message but when there is data in the field NOTHING HAPPENS on the button click.  

We have tried adding a new button to the page that has a small bit of code just to see if we can get a break point there.  Still nothing

Please help

I am spending alot of hours on this and gettign no where

Thanks

Steve
0
stevetheski
Asked:
stevetheski
  • 3
  • 3
  • 2
  • +1
3 Solutions
 
praneethaCommented:
just check at the left hand cornet in the status bar in IE...does it say anything...

0
 
KaiserSoseCommented:
You may have already checked this, but I have had the same type of problem with VS 2003.  My  events in InitializeComponent() would just disappear and I would have to recreate them manually.
0
 
mAjKoLCommented:
It looks like you have an extra <form> in the page presentation layer HTML/XHTML code.
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
stevetheskiAuthor Commented:
pranetha the left hand corner says nothing no error or anything of that matter,

Kaiser
We have had the events get unhooked before but that wasnt a problem either.

Majkol
Nope their is just 1 form in the page <form>...</form>

0
 
praneethaCommented:
can u make some javascript function fire on the button click..and

say u have a dropdownlist with autopostback will the selectindexchanged event fire...

or only buttons are not fired
0
 
praneethaCommented:
can u add a new webform in the sameproject and see if button click works there
0
 
stevetheskiAuthor Commented:
right now we are in the process of reinstalling .NET onnthe cuplrit computer.  Will get back with you after that is complete.  
We did add a new botton and that didnt postback either


Steve
0
 
KaiserSoseCommented:
Hey, I just re-read your question and you said it happened after he installed XP SP2 right?   Could it be a browser setting that disabled javascript or something?  Or maybe the personal firewall?

dave
0
 
stevetheskiAuthor Commented:
the reinstall of iis the framework and .net worked.  Possibly one of the answers may have solved the problem i dont know.  So i split up the points as i saw fit.  hope you guys enjoy them.  I have a good crystal report question comming up soon

Thanks
steve
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 3
  • 3
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now