Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people, just like you, are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
Solved

Raid 5 server fails to reboot after os installation

Posted on 2004-09-23
10
506 Views
Last Modified: 2011-09-20
Hello all,

We have a new RAID 5 server we built here at work. We can install Suse Linux Server 8 or Win2003 server
on it, and all seems to go well during the installation. The software "sees" the storage potential of 100
gigs and allows us to format the SCSI HDD's. Everything goes normal until it's time to reboot the systam after the OS install. After that it just comes up with an error that there is no bootable disk.
It's like it can't write to the boot sector or something. If I go through the setup again the OS "Sees" the
partition and that there is data on it. It even say's something about a previous OS already instaled on the system. We have it configed with 4 HDD's in the RAid set and a 5th one as a hotswap drive.
Anyone else see anything like this? We have upgraded all known ROMS by flashing them already.



Thanks.
0
Comment
Question by:lontek
10 Comments
 
LVL 55

Expert Comment

by:andyalder
ID: 12135861
You haven't told us what the RAID controller is!
0
 
LVL 4

Expert Comment

by:Kooroo
ID: 12136212
in the bios, set the first bootable device to your SCSI Controller. The procedure differs from manufacturer to manufacturer.
0
 
LVL 1

Author Comment

by:lontek
ID: 12136275
Adaptec 2015S Raid Controller.
0
Best Practices: Disaster Recovery Testing

Besides backup, any IT division should have a disaster recovery plan. You will find a few tips below relating to the development of such a plan and to what issues one should pay special attention in the course of backup planning.

 
LVL 55

Accepted Solution

by:
andyalder earned 500 total points
ID: 12136549
It was a bit tricky to install that card with 2000, you had to hit F6 during install and load the third party driver or the install proceedure would do the initial copy but not boot into windows but I haven't tried it with 2003 yet.
0
 
LVL 17

Expert Comment

by:Jared Luker
ID: 12137900
I would rethink your approach.  I would put another drive in the case (10 gig or so would be fine), and get your OS installed on that.  That way, you can set up your raid AFTER you get into windows and start setting things up.

This is a good idea for another reason - It's a bad idea to have your OS and swap file on your data's RAID array.  It causes a lot of unnecessary work for the RAID.

Jared
0
 

Expert Comment

by:bootscoot
ID: 12138460
Agree totally with jared_luker about installing OS on separate drive - if data protection is what you're after, install a OS software mirrored pair of drives for the OS and put them on the internal channels of your server's (PROBABLY ONBOARD) SCSI controller.  This way you maximize throughput btwn the two controllers.  

Preferred setup:
Onboard (or other card based) scsi controller
channel 1 :OS mirror drive 1
channel 2 :OS mirror drive 2
set this as boot device

RAID controller:
The rest of the drives

This solution will haul a$$ and be redundant<secure>

DRIVES ARE CHEAP, YOU KNOW............


0
 
LVL 6

Expert Comment

by:tapkep
ID: 12140979
Is your SCSI array in *Adaptec* configuration utility marked as "bootable"? You should be able to toggle that in RAID array properties. Also, in system bios first boot device should be that array.
0
 
LVL 1

Author Comment

by:lontek
ID: 12143016
Thanks guys for the speedy and knowledgeable responses, but:


I appreciate the OS mirroring solution and that would probably work in a pinch, but I disagree with
the approach because these SCSI drives can transfer 320-500 megs a second. So much of the daily operations occur through the OS that I feel we would really take a speed hit. We put the money in the system and went with the 320 SCSI card for the performance and redundandcy.
We are currently working with an Asus engineer and we have worked with the folks at Adaptec.

(Good answer-different strategy- if nothing better comes in the way of a solution I will probably split the points between bootscoot and Jared because theirs' would be a solution, albeit not the one our strategy is looking for ideally) The other answers are solutions/tips also, but to the best of my knowledge we have tried them all.

The bootable settings in the Bios and in the Adaptec SCSI settings have been tried. At least the more obvious ones. We still can't shake the feeling we are missing a setting somewhere though.....

What makes us think that is: Last night we removed the RAID 5 Adaptec add-in card and went with the integrated RAID 0-1 chipset on the ASUS board. SAME problem! Even trying RAID 1 produced the same issue. Well at least that eliminates the Adaptec SCSI 320 add-in board as the culprit.
The ASUS engineer wants to get his hands on the same hardware and try to duplicate the issue. Hopefully it won't drag out that long.
0
 
LVL 9

Expert Comment

by:cooledit
ID: 12150054
hi, there

What Server Model is it. ?? Dell Compaq

In Dell Server under F2 System BIOS is under integrated device's the system must be RAID first and then SCSI is this the setting...
0
 
LVL 1

Author Comment

by:lontek
ID: 12163499
Hello all,

A bunch of good answers but it turned out to be a driver issue in the end.
Although we had tried different drivers at the f6 prompt to no avail. The Asus tech pointed us to a  driver on the Asus M.B. driver CD. The drivers we tried off of the websites did not work but the one on the Asus CD did!

Happy computing all!
0

Featured Post

Complete VMware vSphere® ESX(i) & Hyper-V Backup

Capture your entire system, including the host, with patented disk imaging integrated with VMware VADP / Microsoft VSS and RCT. RTOs is as low as 15 seconds with Acronis Active Restore™. You can enjoy unlimited P2V/V2V migrations from any source (even from a different hypervisor)

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
NETAPP create a quota on a QTREE 2 41
Home lab datacenter 9 98
Exchange 2007 to 2016 Storage Sizing. 5 45
HP MSA2312i Controller fault 2 8
Ever notice how you can't use a new drive in Windows without having Windows assigning a Disk Signature?  Ever have a signature collision problem (especially with Virtual Machines?)  This article is intended to help you understand what's going on and…
AWS Glacier is Amazons cheapest storage option and is their answer to a ‘Cold’ storage service.  Customers primarily use this service for archival purposes and storage of infrastructure backups.  Its unlimited storage potential and low storage cost …
This video teaches viewers how to encrypt an external drive that requires a password to read and edit the drive. All tasks are done in Disk Utility. Plug in the external drive you wish to encrypt: Make sure all previous data on the drive has been …
This Micro Tutorial will teach you how to reformat your flash drive. Sometimes your flash drive may have issues carrying files so this will completely restore it to manufacturing settings. Make sure to backup all files before reformatting. This w…

809 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question