[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1237
  • Last Modified:

Unable to view Public Folders due to untrusted certificate in Exchange Manager.

I'm running OWA with SSL enabled using a chained SSL certificate from freessl.com which works great.

My problem is when I'm attemping to access public folders through the Exchange Manager I keep getting the following error:

The certificate chain was issued by an untrusted authority.

ID no: 80090325
Exchange System Manager

I've attempted to reinstall the certificate manually by double clicking on the certificate, clicking install, then browsing to a specific physical store (Trusted Root Certification Authorities/Local Computer) but this doesn't seem to help and I've attempted to restart Exchange/IIS without success.

Any thoughts?
0
Xelitus
Asked:
Xelitus
  • 7
  • 5
1 Solution
 
Yan_westCommented:
you have to unbind SSL from Exadmin in your IIS Manager...
0
 
Yan_westCommented:
open default website, right click exadmin, properties.

go to the directory security tab, and in secure communication, click edit, and uncheck the require SSL BOX..
0
 
Yan_westCommented:
BTW, this does not affect OWA in any way if it runs on SSL...
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
XelitusAuthor Commented:
I unchecked require SSL and restarted all IIS and Exchange services and the problem remains. Should I be looking at removing SSL from something other than Exadmin? Perhaps Exchange or public?

I appreciate the assistance.
0
 
Yan_westCommented:
I had a similar problem recently, and I had to unbind ssl from exadmin.. but the error message was slightly different..

I was shocked when you told me it didnt work :) lol second link should work!
0
 
XelitusAuthor Commented:
Unfortunately I tried that (Q 21089294) as well but to no avail.

This one is driving me nuts because it seems like such a simple issue but Exchange just won't let me into those public folders on the Exchange Admin.

Thanks Yan.
0
 
Yan_westCommented:
Make sure you did not apply SSL to the /public virtual directory, the only virtual directory that should have SSL applied to it is /exchange
0
 
XelitusAuthor Commented:
I have made sure that SSL is only applied to the Exchange virtual directory but the problem still exists.
0
 
Yan_westCommented:
I'm out of ideas.. i'll continue checking :)
0
 
XelitusAuthor Commented:
Humm... still have no solution to this problem.

I'm curious as to why my Public Folder's are even bound to the certificate in the first place.

The Certificate is only applied to the OWA components through the IIS Admin.

Any additional thoughts? Anybody?
0
 
XelitusAuthor Commented:
Since the SSL certificate was a Chained SSL certificate from freeSSL.com an intermediate certificate had to be downloaded from freeSSL.com and installed on the server. This resolves the issue as the authority is now trusted.
0
 
RomModCommented:
The question has been PAQ'd and the 200 points have been refunded.
RomMod
Community Support Moderator
0

Featured Post

Transaction-level recovery for Oracle database

Veeam Explore for Oracle delivers low RTOs and RPOs with agentless transaction log backup and transaction-level recovery of Oracle databases. You can restore the database to a precise point in time, even to a specific transaction.

  • 7
  • 5
Tackle projects and never again get stuck behind a technical roadblock.
Join Now