Solved

global.asa issue using .asp pages in .NET environment

Posted on 2004-09-23
19
436 Views
Last Modified: 2012-08-14
I installed VS.NET and the .NET environment and did a couple sites in asp.net.  Now I want to do a simple .asp page for somebody and now realize all my .asp sites get the same error.  They used to work fine, but obviously installing .NET screwed up the settings.  I never really understood what the global.asa file did. What do I change to get the .asp pages working?

Active Server Pages, ASP 0134 (0x80004005)
The object has an invalid ProgID of 'MSWC.MyInfo'.
//global.asa, line 1

I have windows XP.  
0
Comment
Question by:dougfosterNYC
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 7
  • 5
  • 3
  • +1
19 Comments
 
LVL 16

Expert Comment

by:OliWarner
ID: 12136012
for ASP.net your global file should be called:
global.asax
0
 
LVL 16

Expert Comment

by:OliWarner
ID: 12136031
Sorry my bad... read the question wrong... Has been a long day...

Could you print your global.asa file so i can see what's actually causing the error...
0
 

Author Comment

by:dougfosterNYC
ID: 12136302
Hence, my problem.  I never used global.asa files in my .asp pages.  The ASP sites worked fine, until I installed .NET.  So I guess I need a global.asa file in each of my .ASP sites unless there is a setting to change.

 I put in a blank global.asa file, but that didn't work.  Is there a basic template to use?
0
Get 15 Days FREE Full-Featured Trial

Benefit from a mission critical IT monitoring with Monitis Premium or get it FREE for your entry level monitoring needs.
-Over 200,000 users
-More than 300,000 websites monitored
-Used in 197 countries
-Recommended by 98% of users

 
LVL 16

Expert Comment

by:OliWarner
ID: 12136413
No, no global.asa or a blank file called global.asa should work fine...

I've just read that you need to replace the DLL file...
Download http://www.cagedguru.com/myinfo_dll.zip
and put it in your C:\WINDOWS\SYSTEM32 folder...

You'll have to restart IIS for that to take effect...


Another fix i've seen is just having a blank global.asa file...
0
 

Author Comment

by:dougfosterNYC
ID: 12136486
Yea, I put in a blank global.asa file, and that didn't work.  I also put in the dll in the system32 diretory and restarted my web site but it still doesn't work.  It seems like it's looking at a different file, because it says:

The object has an invalid ProgID of 'MSWC.MyInfo'.

in the error.  What is that about?  

0
 
LVL 16

Expert Comment

by:OliWarner
ID: 12136866
MSWeb Core i believe...

Have you tried downloading the framework from MS and installing it... or any updates
0
 

Author Comment

by:dougfosterNYC
ID: 12136919
You mean the .NET framework?  Well, yea, I installed it to develop and run .NET apps on my machine.  Those work fine.  I did it a little over a month ago.  I can't believe this is a problem of not being "up to date".  

But something changed on my .ASP page setup.   I can't be the only one who has had this happen..... ugh....
0
 
LVL 16

Expert Comment

by:OliWarner
ID: 12136971
I mean if you installed it off you VS disk it could be out of date...
You should download a copy off their site, uninstall the old version (even if it looks to be the same version) and install the new one...
0
 
LVL 10

Expert Comment

by:avidya
ID: 12138798
Hi,

if you have a blank global.asa, be sure to
- "Unload" your web in IIS
- stop your website
- clean your cache (both client and server)
- restart the computer with the webserver
- and start the website agian in IIS.

should work fine, if not:
scan for:
<OBJECT RUNAT=Server SCOPE=Session  ID=MyInfo   PROGID="MSWC.MyInfo">
</OBJECT>
and delete this lines
then "unload", stop, clean cache, restart ans start like above.
It should work now

0
 

Author Comment

by:dougfosterNYC
ID: 12139641
Hopefully this will work... but what do you mean by "unloading" the web service?
0
 
LVL 16

Expert Comment

by:OliWarner
ID: 12140773
type services.msc in the run dialogue
right click the IIS service and click stop
then clcik start...
0
 
LVL 10

Expert Comment

by:avidya
ID: 12141254
Hi DougfosterNYC,

To "Unload" a web:
- click "start/programs/administrative tools/Internet Information Services
- double click your computername
- double click "Web Sites"
- right click your website
- choose "properties"
- choose "home directory"
- click "Unload"
This unloads the webapp from memory, etc.



0
 

Author Comment

by:dougfosterNYC
ID: 12142852
Hey Avidya.  I went to "home directory" tab in my website and I don't see any "unload".  I might try scanning for the <object runat....." text but do you mean in any file in the web service and not just the website itself?  
0
 
LVL 16

Accepted Solution

by:
OliWarner earned 125 total points
ID: 12142936
Right click my computer
click manage
expand "services and applications"
rick click "Internet information service"
go to all tasks and click restart IIS
0
 
LVL 10

Assisted Solution

by:avidya
avidya earned 125 total points
ID: 12143576
Hi Doug,

"Unload" resides in IIS and is only available if someone is using your website

you can start IIS by  clicking "start/programs/administrative tools/Internet Information Services
0
 

Expert Comment

by:delolds
ID: 12540068
Doug,

One last thing - I ran into the same problem and it was the global.asa at the root of my webserver (Inetpub), not in the virtual server / directories causing the problem. At least on WinXP SP2 with .Net 1.1 installed.

-del
0

Featured Post

MIM Survival Guide for Service Desk Managers

Major incidents can send mastered service desk processes into disorder. Systems and tools produce the data needed to resolve these incidents, but your challenge is getting that information to the right people fast. Check out the Survival Guide and begin bringing order to chaos.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Developer portfolios can be a bit of an enigma—how do you present yourself to employers without burying them in lines of code?  A modern portfolio is more than just work samples, it’s also a statement of how you work.
When it comes to security, close monitoring is a must. According to WhiteHat Security annual report, a substantial number of all web applications are vulnerable always. Monitis offers a new product - fully-featured Website security monitoring and pr…
Viewers will get an overview of the benefits and risks of using Bitcoin to accept payments. What Bitcoin is: Legality: Risks: Benefits: Which businesses are best suited?: Other things you should know: How to get started:
The viewer will learn how to dynamically set the form action using jQuery.

705 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question