Solved

Microsoft Exchange will not send external mail since broadband - desperately need assistance!

Posted on 2004-09-23
15
311 Views
Last Modified: 2013-12-29
Hello there,

Sorry about the life-story, but I think a bit of background information may help in this case. I would be very grateful if you would read it all as I am in desperate trouble and really need as much help as I can get…

I have a good knowledge of computers generally and a reasonable grasp of networking but I have never set up or maintained any version of m’soft exchange. I have to do a lot of broadband installations. I use an ADSL router and in general it is a pretty seamless transition – causing a minimum of disruption to the customer.

What was meant to be a very routine installation has gone extremely wrong and I am now in a very awkward situation. I am always very wary about messing around with networks that someone else has set up. In this case I had no choice - we ordered ADSL (to replace an ISDN system) and the phone engineers went round and ripped the old box out, dumped the ADSL modem on the table and left my customer with no internet/email and me with the task of restoring it.

The network is comprised of a Windows 2000 server with a few clients running windows XP, 2000 and 98. They have Small Business Server – which I believe includes Exchange 2000. First thing I did is restore internet access to the server by pointing it to the ADSL router. This successfully got them receiving email again without me even touching the Exchange configuration. I was very happy at this point, but this was short-lived. It would not send external mail. I reasoned that this was because in switching to broadband they had effectively switched ISP – so whatever SMTP servers they were using before would no longer allow the mail through. After a bit of sifting through the Exchange system manager I found the SMTP connector. I checked the properties for this and found a box that said “forward all mail for this connector through the following smart hosts”. In there it said “smtp.freeserve.com” (their old ISP). I may be completely wrong, but I further reasoned that if I could switch this to some functional SMTP servers, the mail would start sending again. I know from experience that I cannot use the BTbroadband SMTP servers  (you have to submit the domain to them first and this takes 5 days which I don’t have). So I used some mail server details which I know should work (I tested the account separately through outlook express). But still none of the external mail would send.

I did a bit of further investigation and discovered the queues under server/protocols/default SMTP virtual sever. All the mail was accumulating in the “messages with an unreacheable destination queue”. I tried deleting all these just in case they could be clogging anything up, but this made no difference.

I am absolutely stuck. I am scared to change anything else because I don’t want to mess up their system. But I have to get this sorted. To make matters worse I have limited access to the system as I have to travel down there and I can’t keep popping in and out and tinkering with stuff or they are going to get annoyed (so far I have been able to keep everyone remarkably calm). I need as much help as possible and I need to solve this as quickly as possible – as I really cannot afford to lose this customer.

Many thanks in advance, and my fate is in your hands…..
0
Comment
Question by:elliot2002
15 Comments
 
LVL 11

Assisted Solution

by:NetoMeter Screencasts
NetoMeter Screencasts earned 250 total points
ID: 12138574
Hi!
You almost have done it.
If your new provider does not block outgoing port 25 then you do not need a smarthost. Just remove the entry and restart the virtual SMTP server.

Give it a try and tell us what happened.

NetoMeter :)
0
 
LVL 1

Accepted Solution

by:
iausten earned 250 total points
ID: 12138673
Have a look in Exchange System Manager and click on "connectors". If it is a default SBS2000 setup the connector should be called someting like "SmallBusiness SMTP Connector". Right click on this and look at the general tab and make sure that it is set to use DNS to route email.

BT doesn't block port 25 and this will be the quickest method of sending email.

Is email coming in OK (POP3?)

Ian
0
 

Author Comment

by:elliot2002
ID: 12138878
Thanks for the speedy response guys,

I wasn't sure exactly what a smarthost was to be honest - that makes sense. Just to be sure, how exactly do I restart the virtual SMTP server?

Yes, the incoming (pop3) mail works perfectly.

Are these two suggestions (from Neto and Jausten) complimentary or should I try them separately?



0
 
LVL 1

Expert Comment

by:iausten
ID: 12138960
To restart the SMTP server go to services and restart "Microsoft SMTP Service".

The "smarthost" is a method where you are sending all your mail to an ISP and their mail and DNS servers work out where to deliver the mail to. When you changed ISP the smarthost which was originally set up (freeserve) will block SMTP relay from outside their network as spammers would have a field day!

The suggestions from NetoMeter and myself are essentially the same - just change option from using a smarthost to using DNS to route email.

Ian
0
 

Author Comment

by:elliot2002
ID: 12138965
I was just checking on BTs port 25 policy and I saw this:

"Large email providers often block emails from mail servers hosted on dynamic addresses - you will not be able to send emails from your mail server to those domains, and if your dynamic DNS service (on which your mail server would have to rely) gets out of step with your current IP address, your incoming email would be sent to the wrong host and could therefore be picked up by the wrong person."

We did not get a static IP broadband package - is this likely to pose problems, or are BT exaggerating a bit?

0
 

Author Comment

by:elliot2002
ID: 12138970
Thanks very much Ian,

I will cross everything and give it a try tomorrow morning.
0
 
LVL 1

Expert Comment

by:iausten
ID: 12138995
I have seen this problem on a few customers who use BT - not so much on other ISP's. What happens is that these DHCP IP ranges get put on DNS blacklists which some network admins use to curb spam.

I would recommend a static address - looks like it's another £10 a month on their BT bill!

Ian
0
How to improve team productivity

Quip adds documents, spreadsheets, and tasklists to your Slack experience
- Elevate ideas to Quip docs
- Share Quip docs in Slack
- Get notified of changes to your docs
- Available on iOS/Android/Desktop/Web
- Online/Offline

 

Author Comment

by:elliot2002
ID: 12139024
Not to worry, they have plenty of money ;-)

Is it easy to switch to a fixed IP service - I have never done that before...
0
 
LVL 1

Expert Comment

by:iausten
ID: 12139072
You put in your request to BT and they'll change it (can take a bit of time). You'll know they've changed the IP as you'll loose internet access! When this happens reset the router and it will pick up the new address.

I'd also recommend using a small ISP (such as onyx.net) in the future as BT can be a nightmare to deal with due to their size. With smaller companies you can build up a relationship with their tech support teams which in my experience sort problems out a lot quicker. You can also get referal fees!

Ian
0
 

Author Comment

by:elliot2002
ID: 12139145
Many thanks,

I've been using BT up until now because we get commission by going through a second tier reseller or something. But I think I might take your advice because whenever I get problems their technical support are useless. They always want to perform "diagnostics" on the line - which take about 6 hours then when that inevtiably makes no difference they just offer to send out another modem. Oops I almost started ranting then.
0
 
LVL 1

Expert Comment

by:milkmon123
ID: 12141744
Hello again,

In the SMTP connector properties I knocked out the option to use a smarthost and checked the option to "use DNS to route each address space on this connector". I then went into services and restarted the "Simple Mail Transfer Protocol" service - this wasn't with the other exchange services incidentally. I sent some more test messages but unfortunately they did not send.

I checked the queues again (in Exhchange System Manager - Servers/server01/protocols/SMTP/default SMTP virtual server/Queues). This time they did not go into the “messages with an unreacheable destination queue". Instead some new queues had appeared - one for each domain that the test email was being sent to. It looked something like: SmallBusiness SMTP connector - hotmail (or whatever the domain).com (SMTP connector remote deilvery). The connection state was either active or retry. When I went into properties on the one it read "an internal DNS error caused a failure to find the remote server" and on the other "active remote delivery". None of them sent or arrived.

Any ideas?

I will not be able to get access to the factory until after the weekend, so the more information I can get in the meantime the better...
0
 
LVL 9

Expert Comment

by:pcchiu
ID: 12145496
Just a silly question, is your DNS working at all?   Is the computer able to goto http://www.msn.com or http://www.yahoo.com no problem?  when you try to ping yahoo.com what do you get?
0
 

Author Comment

by:elliot2002
ID: 12148259
Yeah as far as I can tell DNS is working perfectly. It surfs the web without any problem and I can send emails through outlook express fine...
0
 

Author Comment

by:elliot2002
ID: 12148267
By the way, the Milkmon123 comment is from me (elliot2002) - I was signed in on my mates ID by mistake when I posted that from work...
0
 

Author Comment

by:elliot2002
ID: 12164607
Hello there,

Just thought I would post back to say I have solved the problem - I can't tell you how relieved I am!

Turns out the server was pointing to the router (instead of itself) for DNS resolution. I rebuilt the configuration as follows:

* First I added the primary and secondary DNS addresses (which I obtained from BT) to the router.
 
* Then I changed the DNS address of server (in TCP-IP for NIC) so it pointed to itself.
 
* Then I went into the properties for DNS, went into the DNS forwarding tab (apparently this helps computer to resolve addresses that cannot be resolved locally) and added the two BT DNS's that I got from my ISP

Sorted!

Thanks very much for the help. How exactly do I award the points in a situation like this?

0

Featured Post

Maximize Your Threat Intelligence Reporting

Reporting is one of the most important and least talked about aspects of a world-class threat intelligence program. Here’s how to do it right.

Join & Write a Comment

Outsource Your Fax Infrastructure to the Cloud (And come out looking like an IT Hero!) Relative to the many demands on today’s IT teams, spending capital, time and resources to maintain physical fax servers and infrastructure is not a high priority.
Know what services you can and cannot, should and should not combine on your server.
Internet Business Fax to Email Made Easy - With eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, fr…
This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're looking for how to monitor bandwidth using netflow or packet s…

760 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

24 Experts available now in Live!

Get 1:1 Help Now