Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 301
  • Last Modified:

Samba - Server String change not working


I would like to change the Server String variable in my Samba setup.  I have changed the value in smb.conf and restarted the samba server, but all the Windows boxes still see the old name.  I've rebooted all the Windows boxes as well and they still come back up with the old Server String on the Samba share.  What do I have to do to get the Server String to change?

Even better, can I disable the Server String?  None of the Windows shares seem to have a Server String.  I've commented out the Server String variable, but just like changing it, all of the Windows boxes still see the old name.
0
phasevar
Asked:
phasevar
  • 2
1 Solution
 
itcnbwiseCommented:
If you're using a redhat or fedora like distro:

In /etc/samba/smb.conf:
Change:
server string = Samba Server
To:
server string =

Then as root type:
/etc/init.d/smb restart

Now reboot the windows machine to see the changes.
0
 
itcnbwiseCommented:
If you just comment it out, it will default to the version of the samba server, like "Samba xx.xx" - you have to set it to a blank string.
0

Featured Post

Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now