Can you make Windows 2000 not require any kind of authentication for a printer share?

I've got an XP and a 2000 machine networked. The printers on both are shared. The 2000 box can print to the XP printer no problem. If I attempt to print a test page from the XP box to the 2000 one after a reboot I get the error that I don't have access to the printer. If I browse through the network to the 2000 machine, and put in some login info (a user name, no password) then after that I can print from the 2000 printer just fine.

I need to know how to either make the XP system permanently save the login info so that it just works all the time, or I need to know how to make 2000 not want any authentication at all (preferable).

Thanks in advance. -Souter
Who is Participating?
zaneyfunsterConnect With a Mentor Commented:
Enable the Guest account in control panel - users.

XP needs most of the time a password to access a resource on another machine.
I will suggest you to use the same login and password on both machines.
Just a thought that will probably work for you.

If you map a drive from the XP box to the 2000 box... specify logon credentials that exist on the 2000 box and keep the reconnect at logon box ticked.
That way the XP box will alway use that drive mapping to authenticate thus allow you to print.
Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

SootahAuthor Commented:
Enable the guest account on the 2000 box, correct?
Right but it is already answered.
Exactly the same phrase as your ;-)
Have a look at the first answer...
Ah sorry, you are the questionner...
I am tired the friday evening ! ;-)
Thanks for looking out for me Longbow :o)

Sootah, correct, did it work?

Both the answers from Zaneyfunster and Markoid work for question. You can do either way. Else create a user in XP box with the same logon name and password as in 2000 box. and login with that user. now u r able print ur jobs
SootahAuthor Commented:
Guest didn't quite work. It was already enabled on the 2000 box. It did, however, lead me to what to do. In the security tab on the printer I added ANONYMOUS_LOGIN to the accepted users and it worked right after that.

Thanks for your help.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.