• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2219
  • Last Modified:

Linux X screenshot using xwd

I'm trying to get the console (X display) screenshot from remote machine.
usera is login on the console and use display 0.0.
I want to get his screenshot.
I'm login using ssh as root, trying to:

prompt> xwd -root -out screenshot.xwd -display 0:0
Xlib: connection to "0:0.0" refused by server
Xlib: No protocol specified
xwd:  unable to open display '0:0'

The same for:
prompt> xwd -root -out screenshot.xwd -display 127.0.0.1:0

Adding all  to the xhost list fail:
prompt> xhost +
xhost:  unable to open display ""
The system os in redhat 8 Linux.

Regards,
Addady
0
addady
Asked:
addady
2 Solutions
 
liddlerCommented:
DISPLAY=:0.0 export DISPLAY
I'm not sure you've got you : and . correct
0
 
griesshCommented:
liddler is right.

First step: set the DISPLAY variable on your target system: DISPLAY=:0.0 (:0 is the device, .0 is the screen)
Second step: xhost +

To enable a remote name by default, the name can be defined in the /etc/X?.hosts file, where ? is the display number to which you enable access.
0
 
GnsCommented:
This is (as you correctly deduce) a problem related to the remote X seerver denying you access. There is no way for you to amend this other that to intruct usera to allow localhost access (blithely letting remotes "in" isn't recommeded.... at least not by me:-). Havi him/her do
xhost + localhost
in an xterm, then do the "localhost xwd" above.

-- Glenn
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
GnsCommented:
As far as I can see I'm correct here... Although liddler is right that the first instance of the xwd command (in the Q) has a flawed display specification, the second (127.0.0.1:0) is equivalent to setting it to :0 ... And since that doesn't work, one can surmise that root lacks the proper credentials. Ergo, Adaddy needs do what I say (for the running instance... and perhaps add an explicit xhost + localhost in a suitable X startup script),

-- Glenn
0
 
liddlerCommented:
Venabili,
I think this one has been missed in a cleanup
0
 
VenabiliCommented:
liddler ,

Yeah... And after that I reduced my work as a CV for a while...
Handled now :)
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now