[Webinar] Streamline your web hosting managementRegister Today

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2933
  • Last Modified:

Port forwarding

Hi,

I have setup forwarding of port 8080 with the linksys router to the computer 192.168.1.100. Everything by instruction.

Now, when I enter http://localhost:8080 in IE, I get the JBoss to answer (this is what I am running). But when I enter the same from the outside (I do http://shmsoft.tzo.com:8080/), then I see the router console, not the forwarded application. What should I do?

Thank you.
0
kerzner
Asked:
kerzner
  • 5
  • 5
  • 2
  • +3
2 Solutions
 
Pete LongTechnical ConsultantCommented:
Hi kerzner,
why are you using the proxy port?

PeteL
0
 
kerznerAuthor Commented:
What is proxy port? 8080 is standard for JBoss and Apache.
0
 
scampgbCommented:
Hi kerzner,

A few things to test:

Do you have another computer on your internal LAN?  What happens if you use that to connect to http://192.168.1.100:8080 ?

www.dnsstuff.com resolves shmsoft.tzo.com as 24.174.73.138

Is this the external IP address of your Linksys router?
0
Evaluating UTMs? Here's what you need to know!

Evaluating a UTM appliance and vendor can prove to be an overwhelming exercise.  How can you make sure that you're getting the security that your organization needs without breaking the bank? Check out our UTM Buyer's Guide for more information on what you should be looking for!

 
lrmooreCommented:
On the Linksys, there is a feature for remote management. Be sure to either disable this completely, or change the port from the default 8080

0
 
kerznerAuthor Commented:
Yes, the same things happens from any other computer. And yes, this is the ip of my router. Tzo is the 'permanent' ip service.
0
 
infombpCommented:
On the Router disable the Web Remote Management function. Or in IIS change port 8080 to another port and do this also in port forwarding in the router so you can access the website on another port!
8080 is default being used for managing this router from outside (internet) so better not use this port.
0
 
kerznerAuthor Commented:
That was it! They used the same port 8080. To think that two ports should collide!

I change the router to 8081, and it all worked fine.
0
 
lrmooreCommented:
Great!
0
 
scampgbCommented:
Glad that you got it sorted :-)
0
 
lrmooreCommented:
How did infombp's information differ from what I posted earlier?

My post >or change the port from the default 8080 (on the Linksys)

Your post > I change the router to 8081, and it all worked fine.

What gives?
0
 
kerznerAuthor Commented:
You are right, you said the same thing. His was a bit more clearer, this is why I noticed it. But, i would gladly give you the points also, if I could change. Can I?
0
 
lrmooreCommented:
That's OK. I've asked a moderator to un-accept the question. Then you can split points if you want..
0
 
kerznerAuthor Commented:
Perfect, I will do that.
0
 
lrmooreCommented:
Thanks!
0
 
pt55Commented:
As a general Network Security comment:  In general, it is not a Good Thing to enable the Remote Management function on an Internet router (the Linksys).  Doing so opens yourself up to hacking attempts.  And it's fairly easy to brute-force attack the Linksys... There's no userID to search for.  Unless you really need it, disable it...

regardes.

0

Featured Post

The IT Degree for Career Advancement

Earn your B.S. in Network Operations and Security and become a network and IT security expert. This WGU degree program curriculum was designed with tech-savvy, self-motivated students in mind – allowing you to use your technical expertise, to address real-world business problems.

  • 5
  • 5
  • 2
  • +3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now